Как правильно маркировать пакеты по адреслисту?

Раздел для тех, кто начинает знакомиться с MikroTik
Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку "Действия до настройки роутера".
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там /export hide-sensitive. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.
Ответить
Corvus
Сообщения: 33
Зарегистрирован: 25 апр 2013, 05:39

11 июл 2013, 05:40

День добрый, не могу понять как правильно маркировать пакеты по адреслисту для использования в queues.
Проблема такая:
есть адреслист, в mangle делаю prerouting потом mark packet. повторяю два раза (как src address list и dst address list)
а проблема такая что работает только первое правило (то есть которая выше) а вторая, следующее правило не считает пакеты вообще... а если я наоборот поменяю местами, то пакеты начинает считать со второго (который уже первый после перемещения) а первый (который уже второй) не считает...
как заставить считать их всех?
PS я не указываю интерфейс, так как много интерфейсов и разбито по маршрутам


Аватара пользователя
simpl3x
Модератор
Сообщения: 1532
Зарегистрирован: 19 апр 2012, 14:03

11 июл 2013, 07:51

когда пакет попадает в filter rulles, nat, mangle, он движется сверху вниз, как только он соответствует какому то из правил, он выходит из этого списка и дальше не обрабатывается. для того чтобы пакет пошёл дальше на обработку, необходимо либо использовать функцию pasthought, либо создавать свои цепочки и продолжать обработку в них.
и кстати, две метки сразу на пакет помоему не ставится, одна перетирается другой, хотя это мое предположение.


Corvus
Сообщения: 33
Зарегистрирован: 25 апр 2013, 05:39

11 июл 2013, 08:20

Код: Выделить всё

/ip firewall mangle
add action=mark-packet chain=prerouting comment=out dst-address-list=loc \
    new-packet-mark=out passthrough=no
add action=mark-packet chain=prerouting comment=in new-packet-mark=\
    in passthrough=no src-address-list=loc


вот код маркировки, ведь по идее они разные, только адреслист один и тот же...


Ответить