PPTP - Error 619

Обсуждение ПО и его настройки
Ответить
EugenX
Сообщения: 26
Зарегистрирован: 22 май 2013, 16:51

17 июн 2013, 15:42

Добрый день,

Открыли маленький офис где есть 2 компа, зашёл удалёна на первый комп чтобы создать VPN (PPTP) соединение с центральным офисам, всё быстренко подключилось работает нормально. Через 5 минут зашёл на 2-ой комп чтобы сделать тоже самое, но ни как не получалось, Ошибка 619, посмотрел всe опций вроде всё правильно, оба компа одинаковые (клонировал) мучился мучился а потом не знаю как приблизительно через 20 минут всётаки подключилось, рад что всё нормально, говорю дай посмотрю сили уже первый комп сможет соеденится, сюрприз НЕ хочет. Ничего не понимаю что за хрень. Включил логинг, ниже можно увидеть что показывает.

Помогите пожалуйста решить проблему, Спасибо.

Код: Выделить всё

15:22:57 pptp,info TCP connection established from 37.211.40.XXX 
15:22:57 pptp,ppp,info <pptp-0>: waiting for call...
15:22:57 pptp,debug,packet rcvd Start-Control-Connection-Request from 37.211.40.XXX
15:22:57 pptp,debug,packet     protocol-version=0x0100
15:22:57 pptp,debug,packet     framing-capabilities=1
15:22:57 pptp,debug,packet     bearer-capabilities=1
15:22:57 pptp,debug,packet     maximum-channels=0
15:22:57 pptp,debug,packet     firmware-revision=0
15:22:57 pptp,debug,packet     host-name=
15:22:57 pptp,debug,packet     vendor-name=Microsoft
15:22:57 pptp,debug,packet sent Start-Control-Connection-Reply to 37.211.40.XXX
15:22:57 pptp,debug,packet     protocol-version=0x0100
15:22:57 pptp,debug,packet     result-code=1
15:22:57 pptp,debug,packet     error-code=0
15:22:57 pptp,debug,packet     framing-capabilities=2
15:22:57 pptp,debug,packet     bearer-capabilities=0
15:22:57 pptp,debug,packet     maximum-channels=0
15:22:57 pptp,debug,packet     firmware-revision=1
15:22:57 pptp,debug,packet     host-name=MikroTik
15:22:57 pptp,debug,packet     vendor-name=MikroTik
15:22:57 pptp,debug,packet rcvd Outgoing-Call-Request from 37.211.40.XXX
15:22:57 pptp,debug,packet     call-id=56377
15:22:57 pptp,debug,packet     call-serial-number=15
15:22:57 pptp,debug,packet     minimum-bps=300
15:22:57 pptp,debug,packet     maximum-bps=100000000
15:22:57 pptp,debug,packet     bearer-type=3
15:22:57 pptp,debug,packet     framing-type=3
15:22:57 pptp,debug,packet     packet-recv-window-size=64
15:22:57 pptp,debug,packet     packet-processing-delay=0
15:22:57 pptp,debug,packet     phone-number-length=0
15:22:57 pptp,debug,packet     phone-number=
15:22:57 pptp,debug,packet     subaddress=
15:22:57 pptp,ppp,debug <37.211.40.XXX>: LCP lowerup
15:22:57 pptp,ppp,debug <37.211.40.XXX>: LCP open
15:22:57 pptp,debug,packet sent Outgoing-Call-Reply to 37.211.40.XXX
15:22:57 pptp,debug,packet     call-id=294
15:22:57 pptp,debug,packet     peers-call-id=56377
15:22:57 pptp,debug,packet     result-code=1
15:22:57 pptp,debug,packet     error-code=0
15:22:57 pptp,debug,packet     cause-code=0
15:22:57 pptp,debug,packet     connect-speed=100000
15:22:57 pptp,debug,packet     packet-recv-window-size=100
15:22:57 pptp,debug,packet     packet-processing-delay=0
15:22:57 pptp,debug,packet     physical-channel-id=0
15:22:57 pptp,debug,packet rcvd Set-Link-Info from 37.211.40.XXX
15:22:57 pptp,debug,packet     peers-call-id=294
15:22:57 pptp,debug,packet     send-accm=0xffffffff
15:22:57 pptp,debug,packet     receive-accm=0xffffffff
15:22:57 pptp,debug,packet sent Set-Link-Info to 37.211.40.XXX
15:22:57 pptp,debug,packet     peers-call-id=56377
15:22:57 pptp,debug,packet     send-accm=0xffffffff
15:22:57 pptp,debug,packet     receive-accm=0xffffffff
15:22:58 pptp,ppp,debug <37.211.40.XXX>: LCP timer
15:22:58 pptp,ppp,debug,packet  <37.211.40.XXX>: sent LCP ConfReq id=0x1
15:22:58 pptp,ppp,debug,packet    <mru 1460>
15:22:58 pptp,ppp,debug,packet    <magic 0x39c2a847>
15:22:58 pptp,ppp,debug,packet    <auth  mschap2>
15:22:59 pptp,ppp,debug <37.211.40.XXX>: LCP timer
15:22:59 pptp,ppp,debug,packet  <37.211.40.XXX>: sent LCP ConfReq id=0x2
15:22:59 pptp,ppp,debug,packet    <mru 1460>
15:22:59 pptp,ppp,debug,packet    <magic 0x39c2a847>
15:22:59 pptp,ppp,debug,packet    <auth  mschap2>
15:23:01 pptp,ppp,debug <37.211.40.XXX>: LCP timer
15:23:01 pptp,ppp,debug,packet  <37.211.40.XXX>: sent LCP ConfReq id=0x3
15:23:01 pptp,ppp,debug,packet    <mru 1460>
15:23:01 pptp,ppp,debug,packet    <magic 0x39c2a847>
15:23:01 pptp,ppp,debug,packet    <auth  mschap2>
15:23:03 pptp,ppp,debug <37.211.40.XXX>: LCP timer
15:23:03 pptp,ppp,debug <37.211.40.XXX>: LCP timeout sending ConfReq
15:23:03 pptp,ppp,debug <37.211.40.XXX>: LCP lowerdown
15:23:03 pptp,ppp,info <pptp-0>: terminating...
15:23:03 pptp,ppp,debug <37.211.40.XXX>: LCP lowerdown
15:23:03 pptp,ppp,debug <37.211.40.XXX>: LCP down event in starting state
15:23:03 pptp,ppp,info <pptp-0>: disconnected
[admin@MikroTik] >


Vladislav_A
Сообщения: 71
Зарегистрирован: 27 ноя 2012, 17:30

17 июн 2013, 16:28

Компы за NAT-ом или у каждого свой внешний IP?
В случае с NAT оба ваших компьютера имеют один и тот же IP, который видит VPN сервер.
В настройках PPP профиля установите: Only one - no


Аватара пользователя
simpl3x
Модератор
Сообщения: 1532
Зарегистрирован: 19 апр 2012, 14:03

17 июн 2013, 18:59

Код: Выделить всё

15:23:03 pptp,ppp,debug <37.211.40.XXX>: LCP timer 
15:23:03 pptp,ppp,debug <37.211.40.XXX>: LCP timeout sending ConfReq
15:23:03 pptp,ppp,debug <37.211.40.XXX>: LCP lowerdown


сессия рвётся по таймауту управляющего пакета. такое ощущение что удаленное устройство не может\не хочет принять настройки. проверьте, сходится ли шифрование, прописаны ли все адреса которые надо выдать.


EugenX
Сообщения: 26
Зарегистрирован: 22 май 2013, 16:51

18 июн 2013, 10:01

Vladislav_A писал(а):Компы за NAT-ом или у каждого свой внешний IP?
В случае с NAT оба ваших компьютера имеют один и тот же IP, который видит VPN сервер.
В настройках PPP профиля установите: Only one - no


Оба компа за рoутерам (Huawei HG8245) который выдает (DHCP) компам локальные IP 192.168.100.Х. PPTP server выдаёт IP (pool) 192.168.0.60-192.168.0.80
В настройках PPP профиля установил: Only one - NO ...нету изминений, не хочет подключится.

simpl3x писал(а):сессия рвётся по таймауту управляющего пакета. такое ощущение что удаленное устройство не может\не хочет принять настройки. проверьте, сходится ли шифрование, прописаны ли все адреса которые надо выдать.


Не знаю что там проверять если первый раз подключился без проблем, а после того как всё таки через некоторое время смог подключить 2-ой комп уже этот не хочет подклучатся ошибка 619.
Могу показать свои настройки только скажите какие. А проблема не может быть в настройках роутера Huawei HG8245 ? Потому что у Микротика настройки правильные, на компах тоже (уже подклучался) может по середине (роутер) проблема ?!

Спасибо.


Ответить