Не могу настроить тегированный VLAN в связке со свичами Cisc

Обсуждение оборудования и его настройки
Ответить
Spar
Сообщения: 2
Зарегистрирован: 24 май 2013, 11:20

24 май 2013, 11:25

странная проблема с Микротиком (RouterBOARD CCR1016-12G) ... почти новый... купленный пару месяцев назад. Паршивка последняя, 6.0. поставил 8 гб озу вместо штатных 2-ух. До сего момента на "боевое дежурство" железку не ставил. Постоянно тестировал и эксперементировал. Работаю с Cisco и OC Linux лет 10, с Микротиком познакомился недавно.

Вот какая у меня проблема. НЕ МОГУ НАСТРОИТЬ тегированный VLAN в связке со свичами CISCO.
Просто бред какойто. С д-линками - всё ок. С Цисками - нивкакую!

Циска:

interface GigabitEthernet0/19
description Miktotik_downlink
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 18,40
switchport mode trunk
switchport nonegotiate (пробовал и без него)



на Микротике на интерфейс etherX вешаю два влана (пробовал и с одним и с тремя ит.д.)
с тегами 18 и 40 соответсвенно (разумеется номера тегов пробовал разные и свичи (циски) пробовал разные)
на эти вланы вешаю ip адреса из соотв. подсетей. Адреса недоступны.

ИНОГДА (!!) если повесить ip address не на vlan а на etherX - то он начинает пинговаться (о, чудо!). Работает это только с одноим вланом и одним адресом. Второй ip уже не повесишь.



повторюсь, если настраивать связку mikrotik + свич dlink , то всё работает.


на микротике вланы настраивал и через winbox и через командную строку. вот так:

/interface vlan
add name=VLAN18 vlan-id=18 interface=ether1 disabled=no
add name=VLAN40 vlan-id=40 interface=ether1 disabled=no

/ip address
add address=10.1.18.1/24 interface=VLAN18
add address=10.1.40.1/24 interface=VLAN40


В винбоксе есть галочка что-то типа "use service tag" - пробовал и с ней и без нее.
---------------------------

это первая проблема. вторая, возможно произрастающая из нее:

НЕ МОГУ НАСТРОИТЬ БРИДЖ в связке с CISCO. На длинках опять же всё работает, Подключаю бридж к циске - не идёт трафик. При том что вланов нкиаких уже нет, просто два порта в режиме "switchport mode access"


---------------------------

Единственное что еще не пробовал - поменять оперативку обратно на родную (т.к. стоит в стойке и сложно достать). И еще одно.. иногда во_время_настройки_через_winbox теряется связь с миктотиком и до него не достучаться. приходится ребутить по питанию :(

Перерыл гугл и яндекс, нигде похожих проблем не находил. Может надо чинить железку ?


asket
Сообщения: 31
Зарегистрирован: 06 май 2013, 20:31

25 май 2013, 17:24

Вряд ли проблема с Микротиком, у нас почти десяток CCR1036 стоят в связке с Cisco-свитчами (Каталисты 35ХХ), никаких проблем. Покажите полный конфиг свитча.


Spar
Сообщения: 2
Зарегистрирован: 24 май 2013, 11:20

26 май 2013, 09:58

на форуме opennet мне подсказали попробовать на циске native vlan указать на порту, подключенному к микротику. я еще не успел попробовать.

мой конфиг ниже. свич, кстати, тоже 3500-й серии

 "конфиг 3560"
3560#show run
Building configuration...

Current configuration : 10920 bytes
!
! Last configuration change at 14:03:10 MSD Fri May 24 2013 by jxxx
! NVRAM config last updated at 13:21:07 MSK Fri Mar 29 2013 by jxxx
!
version 12.2
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
service unsupported-transceiver
!
hostname 3560
!
boot-start-marker
boot-end-marker
!
logging snmp-authfail
logging buffered 20000
no logging console
enable secret 5 xxxx
!

username jxxx privilege 15 secret 5 $xxxxxxxx
aaa new-model
!
!
aaa authentication login default local
!
!
!
aaa session-id common
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 3:00
system mtu routing 1500
vtp mode transparent
ip subnet-zero
ip name-server x.x.x.x
ip name-server y.y.y.y
ip dhcp relay information trust-all
!
!
no ip igmp snooping report-suppression
!
!
!
!
errdisable recovery interval 30
!
!
archive
log config
logging enable
notify syslog contenttype plaintext
hidekeys
path tftp://z.z.z.z/10.35.1.3/$H$T
write-memory
!
mac access-list extended MAC_PPPoE_DOSers
deny host 2a18.f379.edca any
deny host 2a18.f379.d36a any
deny host 2a18.f3b5.90a8 any
deny host 2a18.f379.d379 any
permit any any
!
spanning-tree mode rapid-pvst
spanning-tree logging
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2-30

vlan 40-41
!
vlan 42
name MTK
!
vlan 43
!
vlan 44-60
!
vlan 99
!
vlan 100-150
vlan 209
!
vlan 250,331-335,403,666
!
vlan 1011
!
vlan 4001
!
vlan 4011
!
vlan 4012

!
!

< --- кусь -- >

!interface GigabitEthernet0/19
description Miktotik_downlink
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 18,40
switchport mode trunk

< --- кусь --->

!
interface Vlan1
ip address 10.35.1.3 255.255.255.0
!
!
ip classless
no ip http server
!
logging facility local1
logging source-interface Vlan1
logging z.z.z.z
access-list 1 permit z.z.z.z.
access-list 23 permit 10.35.z.z
access-list 23 permit 10.35.z.z
access-list 23 permit z.z.z.z
access-list 23 permit 192.168.0.0 0.0.0.255
snmp-server community йцуйуйц RO 12
snmp-server community йцуйцуцц RO 12
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps cluster
snmp-server enable traps entity
snmp-server enable traps vtp
snmp-server enable traps vlancreate
snmp-server enable traps vlandelete
snmp-server enable traps flash insertion removal
snmp-server enable traps port-security
snmp-server enable traps envmon fan shutdown supply temperature status
snmp-server enable traps config-copy
snmp-server enable traps config
snmp-server enable traps bridge newroot topologychange
snmp-server enable traps stpx inconsistency root-inconsistency loop-inconsistency
snmp-server enable traps syslog
snmp-server enable traps mac-notification change move threshold
snmp-server enable traps vlan-membership
snmp-server host z.z.z.z
snmp-server host q.q.q.q
!
control-plane
!
!
line con 0
line vty 0 4
access-class 23 in
exec-timeout 200 0
length 0
line vty 5 15
access-class 23 in
exec-timeout 200 0
!
!
ntp clock-period 36029002
ntp server 10.35.1.1
end


asket
Сообщения: 31
Зарегистрирован: 06 май 2013, 20:31

04 июн 2013, 22:46

Абсолютно ничего криминального в конфиге нет, должно работать с полпинка. А в МТ какие-либо настройки интерфейса есть?


unik
Сообщения: 3
Зарегистрирован: 13 фев 2013, 05:12

04 июл 2013, 13:36

У себя реализовал следующие схемы:
mtik.png
(20.27 КБ) 0 скачиваний

на верхней - все юзеры находятся в одном влане и работают через центральный роутер.
на нижней - задача изолировать юзеров друг от друга сабвланами и чтобы влан остался один.
Все делал через winbox.


Ответить