OpenVPN Server на Mikrotik RB951G-2HnD

Обсуждение ПО и его настройки
soldat
Сообщения: 25
Зарегистрирован: 25 фев 2013, 02:17

25 фев 2013, 15:24

Всем привет.

Хочу поднять OpenVPN Server, чтобы коннектиться к дому и пользоваться домашним инетом (дома анлим, на работе только местный анлим).

Курил уже кучу мануалов, но пока не заводится.
http://wiki.mikrotik.com/wiki/OpenVPN
по сертификатам http://wiki.mikrotik.com/wiki/Manual:Cr ... rtificates


 Конфиги сервера

Код: Выделить всё

[mtik@MikroTik] /interface ovpn-server server> print
enabled: yes
port: 1194
mode: ip
netmask: 24
 mac-address: FE:42:1E:F3:19:99
max-mtu: 1500
keepalive-timeout: 60
ovpn-profile
certificate: server
require-client-certificate: yes
auth: sha1,md5
cipher: blowfish128,aes128


Код: Выделить всё

[mtik@MikroTik] /certificate> print
Flags: K - decrypted-private-key, Q - private-key, R - rsa, D - dsa
 0 KR name="server" subject=C=ru,ST=65,O=Internet Widgits Pty Ltd,CN=***.dyndns.org
      issuer=C=ru,ST=65,O=Internet Widgits Pty Ltd,CN=***.dyndns.org serial-number="01"
      invalid-before=feb/25/2013 10:16:10 invalid-after=feb/23/2023 10:16:10 ca=yes

 1 KR name="ca" subject=C=ru,ST=65,O=Internet Widgits Pty Ltd,CN=***.dyndns.org
      issuer=C=ru,ST=65,O=Internet Widgits Pty Ltd,CN=***.dyndns.org serial-number="CF757CEAE318754D"
      invalid-before=feb/25/2013 10:14:46 invalid-after=feb/23/2023 10:14:46 ca=yes

      invalid-before=feb/25/2013 10


Код: Выделить всё

[mtik@MikroTik] /ip pool> print    
 # NAME                                                                           RANGES                         
 0 ovpn-pool                                                                      10.0.10.1-10.0.10.2 


Код: Выделить всё

[mtik@MikroTik] /ip firewall nat> print           
Flags: X - disabled, I - invalid, D - dynamic
 0   chain=srcnat action=masquerade to-addresses=0.0.0.0 out-interface=pppoe-ttk


Код: Выделить всё

[mtik@MikroTik] /ppp profile> print        
Flags: * - default
 0 * name="default" use-mpls=default use-compression=default use-vj-compression=default use-encryption=default
     only-one=default change-tcp-mss=yes

 1   name="ovpn-profile" local-address=10.0.10.2 remote-address=ovpn-pool bridge=vpn-bridge use-mpls=default
     use-compression=default use-vj-compression=default use-encryption=required only-one=default
     change-tcp-mss=default

 2 * name="default-encryption" use-mpls=default use-compression=default use-vj-compression=default
     use-encryption=yes only-one=default change-tcp-mss=yes


Код: Выделить всё

[mtik@MikroTik] /ppp secret> print
Flags: X - disabled
 #   NAME                    SERVICE CALLER-ID                  PASSWORD                  PROFILE                  REMOTE-ADDRESS
 0   soldat                  any                                asusp535                  ovpn-profile


Код: Выделить всё

[mtik@MikroTik] /ip firewall filter> print               
Flags: X - disabled, I - invalid, D - dynamic
 0   ;;; Allow ICMP Ping
     chain=forward action=accept protocol=icmp

 1   ;;; Allow established connections
     chain=forward action=accept connection-state=established

 2   ;;; Allow related connections
     chain=forward action=accept connection-state=related

 3   ;;; Drop invalid connection packets
     chain=forward action=drop connection-state=invalid

 4   ;;; Allow UDP
     chain=forward action=accept protocol=udp

 5   ;;; Allow all for all LAN
     chain=forward action=accept dst-address=10.0.1.0/24

 6   ;;; Allow all for all LAN
     chain=forward action=accept src-address=10.0.1.0/24

 7   ;;; OpenVPN
     chain=input action=accept protocol=tcp dst-port=1194

 8   ;;; All other forwards drop
     chain=forward action=drop


Код: Выделить всё

[mtik@MikroTik] /interface bridge> print            
Flags: X - disabled, R - running
 0  R name="bridge-local" mtu=1500 l2mtu=2290 arp=enabled mac-address=D4:CA:6D:7C:C9:FB protocol-mode=rstp priority=0x8000
      auto-mac=yes admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s transmit-hold-count=6 ageing-time=5m

 1  R name="vpn-bridge" mtu=1500 l2mtu=65535 arp=enabled mac-address=00:00:00:00:00:00 protocol-mode=none priority=0x8000
      auto-mac=yes admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s transmit-hold-count=6 ageing-time=5m


Код: Выделить всё

[mtik@MikroTik] /ip address> print      
Flags: X - disabled, I - invalid, D - dynamic
 #   ADDRESS            NETWORK         INTERFACE                                                                                 
 0 X 10.0.6.1/32        10.0.6.0        wlan1                                                                                     
 1 X 10.0.5.1/32        10.0.5.0        ether5-master-local                                                                       
 2   10.0.1.1/24        10.0.1.0        wlan1                                                                                     
 3 D 172.16.9.233/32    188.168.168.666   pppoe-ttk   


Вот конфиг клиента на винде

Код: Выделить всё

client
dev tun0
remote ****.dyndns.org 1194
auth-nocache
proto tcp-client
resolv-retry infinite
nobind
persist-key
persist-tun
ca "C:\\Program Files\\OpenVPN\\easy-rsa\\keys\\ca.crt"
cert "C:\\Program Files\\OpenVPN\\easy-rsa\\keys\\client.crt"
key "C:\\Program Files\\OpenVPN\\easy-rsa\\keys\\client.key"
ns-cert-type server
verb 3


Может кто подскажет в какую сторону копать? Или уж больно намудрил? Просто первый раз настраиваю.


iSupport
Сообщения: 2360
Зарегистрирован: 06 фев 2011, 20:44

27 фев 2013, 21:36

ОВПН всегда связан с определенным гемороем

статьи и видео можно найти в гугле и ютьюбе

я бы посоветовал использовать eoip, если и дома и на работе микротик


Граждане, сколько раз просил =) чем понятнее и точнее сформулирован вопрос - тем понятнее и точнее будет на него ответ.
Я просматриваю ВСЕ темы форума и стараюсь помочь в каждой из них
Поэтому, НА ЛС отвечаю в последнюю очередь
soldat
Сообщения: 25
Зарегистрирован: 25 фев 2013, 02:17

01 мар 2013, 01:50

На работе нет микротика (


kokish
Сообщения: 41
Зарегистрирован: 28 май 2012, 18:48

02 мар 2013, 13:42

А я бы использовал обычный PPTP, для OVPN на винде вроде же нужно устанавливать клиент.


RB751G-2HnD штук 15
RB751U-2HnD штук 40
RB450 одна штука
RB493G одна штука
SXT-5HPnD - штук 20
SXT-Lite 5
SXT-Lite 2
soldat
Сообщения: 25
Зарегистрирован: 25 фев 2013, 02:17

06 мар 2013, 05:13

Да, клиент нужен.

Значит так, поставил клиент с easy-rsa http://openvpn.net/index.php?option=com_content&id=357
С генерировал сертификаты http://wiki.mikrotik.com/wiki/OpenVPN#Creating_Certificates_with_Easy-RSA
там пример на линуксе, а на винде немного не так делается.

У меня есть сертификаты:
на клиенте
ca.crt
client.key
client.crt


на сервере
ca.crt
server.pem
server.crt



Пытаюсь подключиться, в интерфейсах появляется vpn-0 (пока пытаюсь подключиться), но после неудачных попыток, пропадает.

Thu Mar 07 09:39:38 2013 OpenVPN 2.3.0 i686-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [IPv6] built on Jan 8 2013
Enter Management Password:
Thu Mar 07 09:39:38 2013 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340
Thu Mar 07 09:39:38 2013 Need hold release from management interface, waiting...
Thu Mar 07 09:39:38 2013 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340
Thu Mar 07 09:39:38 2013 MANAGEMENT: CMD 'state on'
Thu Mar 07 09:39:38 2013 MANAGEMENT: CMD 'log all on'
Thu Mar 07 09:39:38 2013 MANAGEMENT: CMD 'hold off'
Thu Mar 07 09:39:38 2013 MANAGEMENT: CMD 'hold release'
Thu Mar 07 09:39:38 2013 MANAGEMENT: CMD 'proxy HTTP 10.0.80.33 8082'
Thu Mar 07 09:39:39 2013 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Thu Mar 07 09:39:39 2013 Socket Buffers: R=[8192->8192] S=[8192->8192]
Thu Mar 07 09:39:39 2013 Attempting to establish TCP connection with [AF_INET]10.0.80.33:8082
Thu Mar 07 09:39:39 2013 MANAGEMENT: >STATE:1362609579,TCP_CONNECT,,,
Thu Mar 07 09:39:39 2013 TCP connection established with [AF_INET]10.0.80.33:8082
Thu Mar 07 09:39:39 2013 Send to HTTP proxy: 'CONNECT ****.dyndns.org:1194 HTTP/1.0'
Thu Mar 07 09:39:39 2013 HTTP proxy returned: 'HTTP/1.0 200 Connection established'
Thu Mar 07 09:39:40 2013 TCPv4_CLIENT link local: [undef]
Thu Mar 07 09:39:40 2013 TCPv4_CLIENT link remote: [AF_INET]10.0.80.33:8082
Thu Mar 07 09:39:40 2013 MANAGEMENT: >STATE:1362609580,WAIT,,,
Thu Mar 07 09:39:40 2013 MANAGEMENT: >STATE:1362609580,AUTH,,,
Thu Mar 07 09:39:40 2013 TLS: Initial packet from [AF_INET]10.0.80.33:8082, sid=32990481 f0c8477d
Thu Mar 07 09:39:40 2013 VERIFY OK: depth=1, C=RU, ST=CA, L=SKH, O=OpenVPN, OU=Hm, CN=****.dyndns.org, name=changeme, emailAddress=****@bk.ru
Thu Mar 07 09:39:40 2013 VERIFY OK: nsCertType=SERVER
Thu Mar 07 09:39:40 2013 VERIFY OK: depth=0, C=RU, ST=CA, L=SKH, O=OpenVPN, OU=Hm, CN=server, name=changeme, emailAddress=****@bk.ru
Thu Mar 07 09:40:06 2013 Connection reset, restarting [0]
Thu Mar 07 09:40:06 2013 SIGUSR1[soft,connection-reset] received, process restarting
Thu Mar 07 09:40:06 2013 MANAGEMENT: >STATE:1362609606,RECONNECTING,connection-reset,,
Thu Mar 07 09:40:06 2013 Restart pause, 5 second(s)


конфиг клиента

Код: Выделить всё

client
dev tap0
proto tcp
remote ****.dyndns.org 1194
nobind
resolv-retry infinite
persist-tun
persist-key
auth-nocache SHA1
ns-cert-type server
ca "E:\\Program Files\\OpenVPN\\config\\ca.crt"
cert "E:\\Program Files\\OpenVPN\\config\\client1.crt"
key "E:\\Program Files\\OpenVPN\\config\\client1.key"
verb 3


Abus56
Сообщения: 30
Зарегистрирован: 11 мар 2012, 12:06

07 мар 2013, 11:51

а что пишет в логах openvpn на клиенте?
ip для vpn какие используете?
и в примере другой конфиг.

proto tcp-client
remote ip_address 1194 # Remote OpenVPN Servername or IP address
dev tun
nobind
persist-key
tls-client
ca keys/ca.crt
cert keys/ovpn-test.crt
key keys/ovpn-test.key
ping 10
verb 3
cipher AES-256-CBC
auth SHA1
pull
auth-user-pass auth.txt


soldat
Сообщения: 25
Зарегистрирован: 25 фев 2013, 02:17

10 мар 2013, 09:13

 Лог с клиента

Код: Выделить всё

Sun Mar 10 17:13:23 2013 us=927860 OpenVPN 2.3.0 i686-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [IPv6] built on Jan  8 2013
Enter Management Password:
Sun Mar 10 17:13:23 2013 us=937860 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340
Sun Mar 10 17:13:23 2013 us=937860 Need hold release from management interface, waiting...
Sun Mar 10 17:13:24 2013 us=384865 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340
Sun Mar 10 17:13:24 2013 us=489865 MANAGEMENT: CMD 'state on'
Sun Mar 10 17:13:24 2013 us=489865 MANAGEMENT: CMD 'log all on'
Sun Mar 10 17:13:24 2013 us=499865 MANAGEMENT: CMD 'hold off'
Sun Mar 10 17:13:24 2013 us=499865 MANAGEMENT: CMD 'hold release'
Sun Mar 10 17:13:24 2013 us=509865 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Sun Mar 10 17:13:24 2013 us=742366 Control Channel MTU parms [ L:1575 D:140 EF:40 EB:0 ET:0 EL:0 ]
Sun Mar 10 17:13:24 2013 us=742366 Socket Buffers: R=[8192->8192] S=[8192->8192]
Sun Mar 10 17:13:24 2013 us=742366 MANAGEMENT: >STATE:1362896004,RESOLVE,,,
Sun Mar 10 17:13:26 2013 us=132383 Data Channel MTU parms [ L:1575 D:1450 EF:43 EB:4 ET:32 EL:0 ]
Sun Mar 10 17:13:26 2013 us=132383 Local Options String: 'V4,dev-type tap,link-mtu 1575,tun-mtu 1532,proto TCPv4_CLIENT,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-client'
Sun Mar 10 17:13:26 2013 us=132383 Expected Remote Options String: 'V4,dev-type tap,link-mtu 1575,tun-mtu 1532,proto TCPv4_SERVER,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-server'
Sun Mar 10 17:13:26 2013 us=132383 Local Options hash (VER=V4): '10f35004'
Sun Mar 10 17:13:26 2013 us=134883 Expected Remote Options hash (VER=V4): 'a917298a'
Sun Mar 10 17:13:26 2013 us=134883 Attempting to establish TCP connection with [AF_INET]188.168.171.114:1194
Sun Mar 10 17:13:26 2013 us=134883 MANAGEMENT: >STATE:1362896006,TCP_CONNECT,,,
Sun Mar 10 17:13:27 2013 us=166902 TCP connection established with [AF_INET]188.168.171.114:1194
Sun Mar 10 17:13:27 2013 us=166902 TCPv4_CLIENT link local: [undef]
Sun Mar 10 17:13:27 2013 us=166902 TCPv4_CLIENT link remote: [AF_INET]188.168.171.114:1194
Sun Mar 10 17:13:27 2013 us=166902 MANAGEMENT: >STATE:1362896007,WAIT,,,
Sun Mar 10 17:13:27 2013 us=166902  event_wait returned 2
Sun Mar 10 17:13:27 2013 us=166902 TCPv4_CLIENT WRITE [14] to [AF_INET]188.168.171.114:1194: P_CONTROL_HARD_RESET_CLIENT_V2 kid=0 sid=35e55f4f e790ad0d [ ] pid=0 DATA
Sun Mar 10 17:13:27 2013 us=169402 TCPv4_CLIENT write returned 16
Sun Mar 10 17:13:27 2013 us=169402  event_wait returned 1
Sun Mar 10 17:13:27 2013 us=789404  event_wait returned 1
Sun Mar 10 17:13:27 2013 us=789404 TCPv4_CLIENT read returned 14
Sun Mar 10 17:13:27 2013 us=789404 TCPv4_CLIENT READ [14] from [AF_INET]188.168.171.114:1194: P_CONTROL_HARD_RESET_SERVER_V2 kid=0 sid=fcab1138 4533bc67 [ ] pid=0 DATA
Sun Mar 10 17:13:27 2013 us=789404 MANAGEMENT: >STATE:1362896007,AUTH,,,
Sun Mar 10 17:13:27 2013 us=789404 TLS: Initial packet from [AF_INET]188.168.171.114:1194, sid=fcab1138 4533bc67
Sun Mar 10 17:13:27 2013 us=789404  event_wait returned 2
Sun Mar 10 17:13:27 2013 us=789404 TCPv4_CLIENT WRITE [26] to [AF_INET]188.168.171.114:1194: P_CONTROL_HARD_RESET_CLIENT_V2 kid=0 sid=35e55f4f e790ad0d [ 0 sid=fcab1138 4533bc67 ] pid=0 DATA
Sun Mar 10 17:13:27 2013 us=789404 TCPv4_CLIENT write returned 28
Sun Mar 10 17:13:27 2013 us=789404  event_wait returned 1
Sun Mar 10 17:13:28 2013 us=726912  event_wait returned 1
Sun Mar 10 17:13:28 2013 us=726912 TCPv4_CLIENT read returned 22
Sun Mar 10 17:13:28 2013 us=726912 TCPv4_CLIENT READ [22] from [AF_INET]188.168.171.114:1194: P_ACK_V1 kid=0 sid=fcab1138 4533bc67 [ 0 sid=35e55f4f e790ad0d ]
Sun Mar 10 17:13:28 2013 us=726912  event_wait returned 2
Sun Mar 10 17:13:28 2013 us=729412 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=1 DATA 16030100 de010000 da030151 3c2487b0 c5de0c89 8c8cfc0b 4fde6fe4 17cf1aa[more...]
Sun Mar 10 17:13:28 2013 us=729412 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:28 2013 us=729412  event_wait returned 2
Sun Mar 10 17:13:28 2013 us=729412 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=2 DATA 009a0099 00450044 c00ec004 002f0096 00410007 c011c007 c00cc002 0005000[more...]
Sun Mar 10 17:13:28 2013 us=729412 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:28 2013 us=729412  event_wait returned 2
Sun Mar 10 17:13:28 2013 us=729412 TCPv4_CLIENT WRITE [41] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=3 DATA 00050012 00130001 00020003 000f0010 00110023 0000000f 000101
Sun Mar 10 17:13:28 2013 us=729412 TCPv4_CLIENT write returned 43
Sun Mar 10 17:13:28 2013 us=729412  event_wait returned 1
Sun Mar 10 17:13:29 2013 us=549415  event_wait returned 1
Sun Mar 10 17:13:29 2013 us=549415 TCPv4_CLIENT read returned 22
Sun Mar 10 17:13:29 2013 us=549415 TCPv4_CLIENT READ [22] from [AF_INET]188.168.171.114:1194: P_ACK_V1 kid=0 sid=fcab1138 4533bc67 [ 1 sid=35e55f4f e790ad0d ]
Sun Mar 10 17:13:29 2013 us=549415  event_wait returned 1
Sun Mar 10 17:13:30 2013 us=584418  event_wait returned 0
Sun Mar 10 17:13:30 2013 us=584418  event_wait returned 1
Sun Mar 10 17:13:30 2013 us=826919  event_wait returned 1
Sun Mar 10 17:13:30 2013 us=826919 TCPv4_CLIENT read returned 22
Sun Mar 10 17:13:30 2013 us=826919 TCPv4_CLIENT READ [22] from [AF_INET]188.168.171.114:1194: P_ACK_V1 kid=0 sid=fcab1138 4533bc67 [ 2 sid=35e55f4f e790ad0d ]
Sun Mar 10 17:13:30 2013 us=826919  event_wait returned 1
Sun Mar 10 17:13:31 2013 us=831926  event_wait returned 1
Sun Mar 10 17:13:31 2013 us=831926 TCPv4_CLIENT read returned 22
Sun Mar 10 17:13:31 2013 us=831926 TCPv4_CLIENT READ [22] from [AF_INET]188.168.171.114:1194: P_ACK_V1 kid=0 sid=fcab1138 4533bc67 [ 3 sid=35e55f4f e790ad0d ]
Sun Mar 10 17:13:31 2013 us=831926 TCPv4_CLIENT read returned 1414
Sun Mar 10 17:13:31 2013 us=834426 TCPv4_CLIENT READ [1414] from [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=fcab1138 4533bc67 [ ] pid=1 DATA 16030100 35020000 31030151 3d5861a1 77993530 13f29ef8 515d32a6 0adf7b2[more...]
Sun Mar 10 17:13:31 2013 us=834426  event_wait returned 3
Sun Mar 10 17:13:31 2013 us=834426 TCPv4_CLIENT WRITE [22] to [AF_INET]188.168.171.114:1194: P_ACK_V1 kid=0 sid=35e55f4f e790ad0d [ 1 sid=fcab1138 4533bc67 ]
Sun Mar 10 17:13:31 2013 us=834426 TCPv4_CLIENT write returned 24
Sun Mar 10 17:13:31 2013 us=834426  event_wait returned 2
Sun Mar 10 17:13:31 2013 us=834426 TCPv4_CLIENT read returned 0
Sun Mar 10 17:13:31 2013 us=834426 TCPv4_CLIENT READ [0] from [AF_INET]188.168.171.114:1194: DATA UNDEF len=0
Sun Mar 10 17:13:31 2013 us=834426  event_wait returned 1
Sun Mar 10 17:13:32 2013 us=226927  event_wait returned 1
Sun Mar 10 17:13:32 2013 us=226927 TCPv4_CLIENT read returned 1295
Sun Mar 10 17:13:32 2013 us=226927 TCPv4_CLIENT READ [1295] from [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=fcab1138 4533bc67 [ ] pid=2 DATA 6e646e73 2e6f7267 3111300f 06035504 29130863 68616e67 656d6531 1930170[more...]
Sun Mar 10 17:13:32 2013 us=226927 VERIFY OK: depth=1, C=RU, ST=CA, L=SKH, O=OpenVPN, OU=Hm, CN=*****.dyndns.org, name=changeme, emailAddress=zhsv@bk.ru
Sun Mar 10 17:13:32 2013 us=226927 VERIFY OK: nsCertType=SERVER
Sun Mar 10 17:13:32 2013 us=226927 VERIFY OK: depth=0, C=RU, ST=CA, L=SKH, O=OpenVPN, OU=Hm, CN=server, name=changeme, emailAddress=zhsv@bk.ru
Sun Mar 10 17:13:32 2013 us=348932  event_wait returned 2
Sun Mar 10 17:13:32 2013 us=348932 TCPv4_CLIENT WRITE [126] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ 2 sid=fcab1138 4533bc67 ] pid=4 DATA 16030101 06100001 0201001b 6e00e60e 1b4e4e53 e4a0e4ab 9082a202 59008fc[more...]
Sun Mar 10 17:13:32 2013 us=348932 TCPv4_CLIENT write returned 128
Sun Mar 10 17:13:32 2013 us=348932  event_wait returned 2
Sun Mar 10 17:13:32 2013 us=348932 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=5 DATA da08610f b052b2f4 47cb06f4 46933491 00b92a0d b8d82a48 4bc2aa93 a42a613[more...]
Sun Mar 10 17:13:32 2013 us=348932 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:32 2013 us=348932  event_wait returned 2
Sun Mar 10 17:13:32 2013 us=348932 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=6 DATA b1408bcd 47d0baad b7e1cb7e 31559a0f c89ba28e 2cd4d87c f1d230f9 0e44db2[more...]
Sun Mar 10 17:13:32 2013 us=348932 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:32 2013 us=348932  event_wait returned 2
Sun Mar 10 17:13:32 2013 us=348932 TCPv4_CLIENT WRITE [40] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=7 DATA 3406b4c7 c455cf50 a7eaef40 61d57986 ae49d95e 0db3d639 2107
Sun Mar 10 17:13:32 2013 us=348932 TCPv4_CLIENT write returned 42
Sun Mar 10 17:13:32 2013 us=348932  event_wait returned 1
Sun Mar 10 17:13:33 2013 us=383437  event_wait returned 0
Sun Mar 10 17:13:33 2013 us=383437  event_wait returned 1
Sun Mar 10 17:13:34 2013 us=225940  event_wait returned 1
Sun Mar 10 17:13:34 2013 us=225940 TCPv4_CLIENT read returned 22
Sun Mar 10 17:13:34 2013 us=225940 TCPv4_CLIENT READ [22] from [AF_INET]188.168.171.114:1194: P_ACK_V1 kid=0 sid=fcab1138 4533bc67 [ 4 sid=35e55f4f e790ad0d ]
Sun Mar 10 17:13:34 2013 us=225940  event_wait returned 1
Sun Mar 10 17:13:35 2013 us=260944  event_wait returned 0
Sun Mar 10 17:13:35 2013 us=260944  event_wait returned 2
Sun Mar 10 17:13:35 2013 us=260944 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=5 DATA da08610f b052b2f4 47cb06f4 46933491 00b92a0d b8d82a48 4bc2aa93 a42a613[more...]
Sun Mar 10 17:13:35 2013 us=260944 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:35 2013 us=260944  event_wait returned 1
Sun Mar 10 17:13:35 2013 us=763448  event_wait returned 1
Sun Mar 10 17:13:35 2013 us=763448 TCPv4_CLIENT read returned 22
Sun Mar 10 17:13:35 2013 us=763448 TCPv4_CLIENT READ [22] from [AF_INET]188.168.171.114:1194: P_ACK_V1 kid=0 sid=fcab1138 4533bc67 [ 5 sid=35e55f4f e790ad0d ]
Sun Mar 10 17:13:35 2013 us=763448 TCPv4_CLIENT read returned 22
Sun Mar 10 17:13:35 2013 us=763448 TCPv4_CLIENT READ [22] from [AF_INET]188.168.171.114:1194: P_ACK_V1 kid=0 sid=fcab1138 4533bc67 [ 6 sid=35e55f4f e790ad0d ]
Sun Mar 10 17:13:35 2013 us=763448 TCPv4_CLIENT read returned 22
Sun Mar 10 17:13:35 2013 us=763448 TCPv4_CLIENT READ [22] from [AF_INET]188.168.171.114:1194: P_ACK_V1 kid=0 sid=fcab1138 4533bc67 [ 7 sid=35e55f4f e790ad0d ]
Sun Mar 10 17:13:35 2013 us=763448 TCPv4_CLIENT read returned 248
Sun Mar 10 17:13:35 2013 us=773448 TCPv4_CLIENT READ [248] from [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=fcab1138 4533bc67 [ ] pid=3 DATA 16030100 aa040000 a6000000 0000a0bd d2bdbc9d 91206402 a496e574 3968535[more...]
Sun Mar 10 17:13:35 2013 us=773448  event_wait returned 2
Sun Mar 10 17:13:35 2013 us=773448 TCPv4_CLIENT WRITE [126] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ 3 sid=fcab1138 4533bc67 ] pid=8 DATA 17030100 20fa0520 259f8d6a df9494d4 f3b5edce d22e5b76 795e86e8 592028b[more...]
Sun Mar 10 17:13:35 2013 us=773448 TCPv4_CLIENT write returned 128
Sun Mar 10 17:13:35 2013 us=773448  event_wait returned 2
Sun Mar 10 17:13:35 2013 us=773448 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=9 DATA 20d74307 7d31b926 4a601b8c 275ac59e 90c6ea5f 5252faea 944a027c 6a9f49a[more...]
Sun Mar 10 17:13:35 2013 us=773448 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:35 2013 us=773448  event_wait returned 2
Sun Mar 10 17:13:35 2013 us=773448 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=10 DATA b594ece3 068da514 1a912541 683913d3 84c1401f 1fafe7d8 86689d42 10e3aac[more...]
Sun Mar 10 17:13:35 2013 us=773448 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:35 2013 us=773448  event_wait returned 2
Sun Mar 10 17:13:35 2013 us=773448 TCPv4_CLIENT WRITE [28] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=11 DATA 0c8229d8 5404d9d9 538b9279 e2fb
Sun Mar 10 17:13:35 2013 us=773448 TCPv4_CLIENT write returned 30
Sun Mar 10 17:13:35 2013 us=773448  event_wait returned 1
Sun Mar 10 17:13:36 2013 us=802956  event_wait returned 0
Sun Mar 10 17:13:36 2013 us=802956  event_wait returned 1
Sun Mar 10 17:13:37 2013 us=840460  event_wait returned 0
Sun Mar 10 17:13:37 2013 us=840460  event_wait returned 2
Sun Mar 10 17:13:37 2013 us=840460 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=8 DATA 17030100 20fa0520 259f8d6a df9494d4 f3b5edce d22e5b76 795e86e8 592028b[more...]
Sun Mar 10 17:13:37 2013 us=840460 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:37 2013 us=840460  event_wait returned 1
Sun Mar 10 17:13:38 2013 us=850463  event_wait returned 0
Sun Mar 10 17:13:38 2013 us=850463  event_wait returned 2
Sun Mar 10 17:13:38 2013 us=850463 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=9 DATA 20d74307 7d31b926 4a601b8c 275ac59e 90c6ea5f 5252faea 944a027c 6a9f49a[more...]
Sun Mar 10 17:13:38 2013 us=850463 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:38 2013 us=850463  event_wait returned 1
Sun Mar 10 17:13:38 2013 us=850463  event_wait returned 1
Sun Mar 10 17:13:38 2013 us=850463 TCPv4_CLIENT read returned 22
Sun Mar 10 17:13:38 2013 us=850463 TCPv4_CLIENT READ [22] from [AF_INET]188.168.171.114:1194: P_ACK_V1 kid=0 sid=fcab1138 4533bc67 [ 8 sid=35e55f4f e790ad0d ]
Sun Mar 10 17:13:38 2013 us=850463  event_wait returned 1
Sun Mar 10 17:13:39 2013 us=867967  event_wait returned 0
Sun Mar 10 17:13:39 2013 us=867967  event_wait returned 2
Sun Mar 10 17:13:39 2013 us=867967 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=10 DATA b594ece3 068da514 1a912541 683913d3 84c1401f 1fafe7d8 86689d42 10e3aac[more...]
Sun Mar 10 17:13:39 2013 us=867967 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:39 2013 us=867967  event_wait returned 1
Sun Mar 10 17:13:40 2013 us=882970  event_wait returned 0
Sun Mar 10 17:13:40 2013 us=882970  event_wait returned 2
Sun Mar 10 17:13:40 2013 us=882970 TCPv4_CLIENT WRITE [28] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=11 DATA 0c8229d8 5404d9d9 538b9279 e2fb
Sun Mar 10 17:13:40 2013 us=882970 TCPv4_CLIENT write returned 30
Sun Mar 10 17:13:40 2013 us=882970  event_wait returned 1
Sun Mar 10 17:13:41 2013 us=895473  event_wait returned 0
Sun Mar 10 17:13:41 2013 us=895473  event_wait returned 1
Sun Mar 10 17:13:42 2013 us=912976  event_wait returned 0
Sun Mar 10 17:13:42 2013 us=912976  event_wait returned 2
Sun Mar 10 17:13:42 2013 us=912976 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=9 DATA 20d74307 7d31b926 4a601b8c 275ac59e 90c6ea5f 5252faea 944a027c 6a9f49a[more...]
Sun Mar 10 17:13:42 2013 us=912976 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:42 2013 us=912976  event_wait returned 1
Sun Mar 10 17:13:43 2013 us=922980  event_wait returned 0
Sun Mar 10 17:13:43 2013 us=922980  event_wait returned 2
Sun Mar 10 17:13:43 2013 us=922980 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=10 DATA b594ece3 068da514 1a912541 683913d3 84c1401f 1fafe7d8 86689d42 10e3aac[more...]
Sun Mar 10 17:13:43 2013 us=922980 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:43 2013 us=922980  event_wait returned 1
Sun Mar 10 17:13:44 2013 us=935486  event_wait returned 0
Sun Mar 10 17:13:44 2013 us=935486  event_wait returned 2
Sun Mar 10 17:13:44 2013 us=935486 TCPv4_CLIENT WRITE [28] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=11 DATA 0c8229d8 5404d9d9 538b9279 e2fb
Sun Mar 10 17:13:44 2013 us=935486 TCPv4_CLIENT write returned 30
Sun Mar 10 17:13:44 2013 us=935486  event_wait returned 1
Sun Mar 10 17:13:45 2013 us=945489  event_wait returned 0
Sun Mar 10 17:13:45 2013 us=945489  event_wait returned 1
Sun Mar 10 17:13:46 2013 us=962992  event_wait returned 0
Sun Mar 10 17:13:46 2013 us=962992  event_wait returned 1
Sun Mar 10 17:13:47 2013 us=975495  event_wait returned 0
Sun Mar 10 17:13:47 2013 us=975495  event_wait returned 1
Sun Mar 10 17:13:49 2013 us=220504  event_wait returned 0
Sun Mar 10 17:13:49 2013 us=220504  event_wait returned 1
Sun Mar 10 17:13:50 2013 us=450508  event_wait returned 0
Sun Mar 10 17:13:50 2013 us=450508  event_wait returned 2
Sun Mar 10 17:13:50 2013 us=450508 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=9 DATA 20d74307 7d31b926 4a601b8c 275ac59e 90c6ea5f 5252faea 944a027c 6a9f49a[more...]
Sun Mar 10 17:13:50 2013 us=450508 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:50 2013 us=450508  event_wait returned 1
Sun Mar 10 17:13:51 2013 us=678011  event_wait returned 0
Sun Mar 10 17:13:51 2013 us=678011  event_wait returned 2
Sun Mar 10 17:13:51 2013 us=678011 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=10 DATA b594ece3 068da514 1a912541 683913d3 84c1401f 1fafe7d8 86689d42 10e3aac[more...]
Sun Mar 10 17:13:51 2013 us=678011 TCPv4_CLIENT write returned 116
Sun Mar 10 17:13:51 2013 us=678011  event_wait returned 1
Sun Mar 10 17:13:52 2013 us=913015  event_wait returned 0
Sun Mar 10 17:13:52 2013 us=913015  event_wait returned 2
Sun Mar 10 17:13:52 2013 us=913015 TCPv4_CLIENT WRITE [28] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=11 DATA 0c8229d8 5404d9d9 538b9279 e2fb
Sun Mar 10 17:13:52 2013 us=913015 TCPv4_CLIENT write returned 30
Sun Mar 10 17:13:52 2013 us=913015  event_wait returned 1
Sun Mar 10 17:13:54 2013 us=143020  event_wait returned 0
Sun Mar 10 17:13:54 2013 us=143020  event_wait returned 1
Sun Mar 10 17:13:55 2013 us=375525  event_wait returned 0
Sun Mar 10 17:13:55 2013 us=375525  event_wait returned 1
Sun Mar 10 17:13:56 2013 us=605530  event_wait returned 0
Sun Mar 10 17:13:56 2013 us=605530  event_wait returned 1
Sun Mar 10 17:13:57 2013 us=840534  event_wait returned 0
Sun Mar 10 17:13:57 2013 us=840534  event_wait returned 1
Sun Mar 10 17:13:58 2013 us=980537  event_wait returned 0
Sun Mar 10 17:13:58 2013 us=980537  event_wait returned 1
Sun Mar 10 17:14:00 2013 us=120540  event_wait returned 0
Sun Mar 10 17:14:00 2013 us=120540  event_wait returned 1
Sun Mar 10 17:14:01 2013 us=268044  event_wait returned 0
Sun Mar 10 17:14:01 2013 us=268044  event_wait returned 1
Sun Mar 10 17:14:02 2013 us=408047  event_wait returned 0
Sun Mar 10 17:14:02 2013 us=408047  event_wait returned 1
Sun Mar 10 17:14:03 2013 us=553051  event_wait returned 0
Sun Mar 10 17:14:03 2013 us=553051  event_wait returned 1
Sun Mar 10 17:14:04 2013 us=693054  event_wait returned 0
Sun Mar 10 17:14:04 2013 us=693054  event_wait returned 1
Sun Mar 10 17:14:05 2013 us=838057  event_wait returned 0
Sun Mar 10 17:14:05 2013 us=838057  event_wait returned 1
Sun Mar 10 17:14:06 2013 us=983061  event_wait returned 0
Sun Mar 10 17:14:06 2013 us=983061  event_wait returned 2
Sun Mar 10 17:14:06 2013 us=983061 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=9 DATA 20d74307 7d31b926 4a601b8c 275ac59e 90c6ea5f 5252faea 944a027c 6a9f49a[more...]
Sun Mar 10 17:14:06 2013 us=983061 TCPv4_CLIENT write returned 116
Sun Mar 10 17:14:06 2013 us=983061  event_wait returned 1
Sun Mar 10 17:14:08 2013 us=123065  event_wait returned 0
Sun Mar 10 17:14:08 2013 us=123065  event_wait returned 2
Sun Mar 10 17:14:08 2013 us=123065 TCPv4_CLIENT WRITE [114] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=10 DATA b594ece3 068da514 1a912541 683913d3 84c1401f 1fafe7d8 86689d42 10e3aac[more...]
Sun Mar 10 17:14:08 2013 us=123065 TCPv4_CLIENT write returned 116
Sun Mar 10 17:14:08 2013 us=123065  event_wait returned 2
Sun Mar 10 17:14:08 2013 us=123065 TCPv4_CLIENT WRITE [28] to [AF_INET]188.168.171.114:1194: P_CONTROL_V1 kid=0 sid=35e55f4f e790ad0d [ ] pid=11 DATA 0c8229d8 5404d9d9 538b9279 e2fb
Sun Mar 10 17:14:08 2013 us=123065 TCPv4_CLIENT write returned 30
Sun Mar 10 17:14:08 2013 us=123065  event_wait returned 1
Sun Mar 10 17:14:09 2013 us=380568  event_wait returned 0
Sun Mar 10 17:14:09 2013 us=380568  event_wait returned 1
Sun Mar 10 17:14:10 2013 us=635573  event_wait returned 0
Sun Mar 10 17:14:10 2013 us=635573  event_wait returned 1
Sun Mar 10 17:14:11 2013 us=885577  event_wait returned 0
Sun Mar 10 17:14:11 2013 us=885577  event_wait returned 1
Sun Mar 10 17:14:13 2013 us=140582  event_wait returned 0
Sun Mar 10 17:14:13 2013 us=140582  event_wait returned 1
Sun Mar 10 17:14:14 2013 us=398087  event_wait returned 0
Sun Mar 10 17:14:14 2013 us=398087  event_wait returned 1
Sun Mar 10 17:14:15 2013 us=648091  event_wait returned 0
Sun Mar 10 17:14:15 2013 us=648091  event_wait returned 1
Sun Mar 10 17:14:16 2013 us=900595  event_wait returned 0
Sun Mar 10 17:14:16 2013 us=900595  event_wait returned 1
Sun Mar 10 17:14:18 2013 us=150599  event_wait returned 0
Sun Mar 10 17:14:18 2013 us=150599  event_wait returned 1
Sun Mar 10 17:14:19 2013 us=373104  event_wait returned 0
Sun Mar 10 17:14:19 2013 us=373104  event_wait returned 1
Sun Mar 10 17:14:20 2013 us=598108  event_wait returned 0
Sun Mar 10 17:14:20 2013 us=598108  event_wait returned 1
Sun Mar 10 17:14:21 2013 us=818112  event_wait returned 0
Sun Mar 10 17:14:21 2013 us=818112  event_wait returned 1
Sun Mar 10 17:14:23 2013 us=43117  event_wait returned 0
Sun Mar 10 17:14:23 2013 us=43117  event_wait returned 1
Sun Mar 10 17:14:24 2013 us=268121  event_wait returned 0
Sun Mar 10 17:14:24 2013 us=268121  event_wait returned 1
Sun Mar 10 17:14:25 2013 us=485626  event_wait returned 0
Sun Mar 10 17:14:25 2013 us=485626  event_wait returned 1
Sun Mar 10 17:14:26 2013 us=703144  event_wait returned 0
Sun Mar 10 17:14:26 2013 us=703144  event_wait returned 1
Sun Mar 10 17:14:27 2013 us=920662  event_wait returned 0
Sun Mar 10 17:14:27 2013 us=920662 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Sun Mar 10 17:14:27 2013 us=920662 TLS Error: TLS handshake failed
Sun Mar 10 17:14:27 2013 us=920662 Fatal TLS error (check_tls_errors_co), restarting
Sun Mar 10 17:14:27 2013 us=920662 TCP/UDP: Closing socket
Sun Mar 10 17:14:27 2013 us=920662 SIGUSR1[soft,tls-error] received, process restarting
Sun Mar 10 17:14:27 2013 us=920662 MANAGEMENT: >STATE:1362896067,RECONNECTING,tls-error,,
Sun Mar 10 17:14:27 2013 us=920662 Restart pause, 5 second(s)
Sun Mar 10 17:14:29 2013 us=920692 SIGTERM[hard,init_instance] received, process exiting
Sun Mar 10 17:14:29 2013 us=920692 MANAGEMENT: >STATE:1362896069,EXITING,init_instance,,
Sun Mar 10 17:14:29 2013 us=920692 PKCS#11: pkcs11h_terminate entry
Sun Mar 10 17:14:29 2013 us=920692 PKCS#11: Removing providers
Sun Mar 10 17:14:29 2013 us=920692 PKCS#11: Releasing sessions
Sun Mar 10 17:14:29 2013 us=920692 PKCS#11: Terminating slotevent
Sun Mar 10 17:14:29 2013 us=920692 PKCS#11: _pkcs11h_slotevent_terminate entry
Sun Mar 10 17:14:29 2013 us=920692 PKCS#11: _pkcs11h_slotevent_terminate return
Sun Mar 10 17:14:29 2013 us=920692 PKCS#11: Marking as uninitialized
V4,dev-type tap,link-mtu 1575,tun-mtu 1532,proto TCPv4_CLIENT,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-clientdyndns171


Конфиг использую этот

Код: Выделить всё

client
dev tap0
proto tcp
remote ****.dyndns.org 1194 # Remote OpenVPN Servername or IP address
resolv-retry infinite
persist-tun
nobind
persist-key
auth-nocache  # ne ostavlat password v keshe windows
ns-cert-type server
ca "C:\\Program Files\\OpenVPN\\config\\ca.crt"
cert "C:\\Program Files\\OpenVPN\\config\\client1.crt"
key "C:\\Program Files\\OpenVPN\\config\\client1.key"


verb 10


Код: Выделить всё

[mtik@MTik] /ip pool> print
 # NAME                                                                                                  RANGES                         
 0 ovpn-pool                                                                                             10.0.10.0/30


на LAN IP 10.0.1.1/2414

Но похоже при коннекте отваливается PPPoE соединение. Т.к. появляется еще один динамический IP (внешний). Видимо я что-то перемудрил?
http://mikrotik.ru/forum/viewtopic.php?f=3&t=335125340
Sun Mar 10 17
Вложения
480_20130122015202_237677.jpg
(365.8 КБ) 76 скачиваний


Abus56
Сообщения: 30
Зарегистрирован: 11 мар 2012, 12:06

10 мар 2013, 18:36

Делай по примеру, который ты в начале статьи предоставил и проблем не будет.


soldat
Сообщения: 25
Зарегистрирован: 25 фев 2013, 02:17

11 мар 2013, 14:31

Вот делаю заново по примеру.
Bridge mode - RouterOS - Create the bridge http://wiki.mikrotik.com/wiki/OpenVPN#Bridge_mode
Create the bridge

Код: Выделить всё

/interface bridge add name=vpn-bridge
/interface bridge port add interface=ether1 bridge=vpn-bridge



тут все ясно

Код: Выделить всё

/interface bridge add name=vpn-bridge

а вот при добавлении порта в бридж

Код: Выделить всё

/interface bridge port add interface=ether1 bridge=vpn-bridge

мне не понятно, если делаю так, то инет отваливается.

У меня в ether1 подключен интернет, сам я работаю через wi-fi

Код: Выделить всё

[mtik@MTik] /interface> print
Flags: D - dynamic, X - disabled, R - running, S - slave
 #     NAME                                                                                     TYPE               MTU L2MTU  MAX-L2MTU
 0  R  ;;; WAN
       ether1                                                                                   ether             1500  1598       4074
 1     ;;; LAN
       ether2                                                                                   ether             1500  1598       4074
 2  X  ether3                                                                                   ether             1500  1598       4074
 3  X  ether4                                                                                   ether             1500  1598       4074
 4  X  ether5                                                                                   ether             1500  1598       4074
 5  R  ;;; WI-FI
       wlan1                                                                                    wlan              1500  2290
 6  R  bridge1                                                                                  bridge            1500  2290
 7  R  pppoe-ttk                                                                                pppoe-out         1394
 8     ;;; OpenVPN Server
       ovpn                                                                                     ovpn-in         
 9  R  vpn-bridge                                                                               bridge            1500 65535
64


И второй момент
из мануала
The network configuration of your box:

Код: Выделить всё

/ip address add address=10.15.30.31/24 interface=vpn-bridge comment=Lan 
/ip address add address=189.64.0.2/24 interface=ether2 comment=Internet
/ip route add dst-address=10.0.0.0/8 gateway=10.15.30.5 comment=Wan
/ip route add gateway=189.64.0.1 comment=Internet


тут понятно, добавляем адреса для лан

Код: Выделить всё

/ip address add address=10.15.30.31/24 interface=vpn-bridge comment=Lan

а тут уже не понятно, т.к. у меня IP динамический, какие адреса добавлять?

Код: Выделить всё

/ip address add address=189.64.0.2/24 interface=ether2 comment=Internet


Abus56
Сообщения: 30
Зарегистрирован: 11 мар 2012, 12:06

11 мар 2013, 14:48

значит не добавляй bridge=)


Ответить