Блокировка по URL

Обсуждение ПО и его настройки
Ответить
KOJI9IH
Сообщения: 3
Зарегистрирован: 11 ноя 2011, 14:41

19 сен 2012, 15:31

День добрый!
Как заблокировать определенный контент на сайте? например отдельный ролик на ютубе по ссылке http://www.youtube.com/watch?v=*********.
Пробовал так:
/ip firewall layer7-protocol
add comment="" name=block_soc_seti regexp=http:\/\/www.youtube.com\/watch\?v=xYVfBNKbfRQ
/ip firewall filter
add action=drop chain=forward comment="" disabled=no dst-port=80 layer7-protocol=block_soc_seti protocol=tcp src-address-list=!no_restricted
не получилось (что я пишу неправильно в регулярке?). Когда пишу regexp=youtube.com , то блокируется весь сайт.
Заранее спасибо!


iSupport
Сообщения: 2360
Зарегистрирован: 06 фев 2011, 20:44

19 сен 2012, 20:52

лучший вариант - поднять прокси и резать УРЛ на прокси


Граждане, сколько раз просил =) чем понятнее и точнее сформулирован вопрос - тем понятнее и точнее будет на него ответ.
Я просматриваю ВСЕ темы форума и стараюсь помочь в каждой из них
Поэтому, НА ЛС отвечаю в последнюю очередь
Аватара пользователя
Dragon_Knight
Сообщения: 1709
Зарегистрирован: 26 мар 2012, 18:21
Откуда: МО, Мытищи
Контактная информация:

21 сен 2012, 17:57

Самый простой и не ресурсоёмкий способ это прокси.
Вот мой конфиг:
Включаем и блочим сайты, и файлы писал(а):/ip proxy set cache-administrator="admin" enabled=yes
/ip proxy access
add action=deny dst-host=*vk.com*
add action=deny dst-host=*odnoklassniki.ru*
add action=deny dst-host=*facebook.com*
add action=deny path=*.flv
add action=deny path=*.webm
add action=deny path=*.3gp
add action=deny path=*.avi
add action=deny path=*.mp4
add action=deny path=*.mp3
add action=deny path=*.ogg


Заворачиваем весь трафик на прокси писал(а):/ip firewall nat
add action=dst-nat chain=dstnat dst-port=80 protocol=tcp src-address-list=!WITHOUT_PROXY to-addresses=192.168.10.1 to-ports=8080
/ip firewall address-list
add address=192.168.10.160 list=WITHOUT_PROXY

Зелёным мы обходим прокси для определённых адресов


И не забываем скрыть прокси от мира писал(а):add action=drop chain=input dst-port=8080 in-interface=[NAME] protocol=tcp src-address=0.0.0.0/0


Небольшой свод правил логики и ссылок:
  1. Если устройство имеет Ethernet порт, то оно обязано быть подключено через него. Компьютер, Ноутбук, Телевизор, Принтер, Камера видеонаблюдения, и т.д.
  2. Если нет возможности протянуть кабель, то найдите её, или страдайте со своими проблемами Wi-Fi дальше.
  3. Wi-Fi это сеть для мобильных устройств. Если Вы подключили свой шикарный 50" телевизор не кабелем, то без фотоотчёта, когда он лежит у Вас в кармане дальнейшего разговора не получиться. Это относится и ко всем остальным устройствам.
  4. Если Ваше устройство вызывает вопросы в работе, первое что необходимо делать: NetInstall + дальнейшая настройка вручную.
  5. Не используйте WebFig или QuickSet - это пути к глюкам и ошибкам. Только SSH или WinBox, и да, - WinBox есть под Android.
  6. name.rsc - это текстовый файл, и Вы можете его открыть блокнотом.
  7. Если Вы хотите связаться со мной для ремонта или настройки, то: Telegram
  8. Если моя помощь была полезной и Вы хотите меня поблагодарить, то: ЮМани 41001203322337
Tem
Сообщения: 11
Зарегистрирован: 20 авг 2012, 10:17

21 сен 2012, 19:37

Иногда юзать прокси нельзя, вот мой вариант блокировки ролика на ютубе

Код: Выделить всё

/ip firewall layer7-protocol
add name=youtube regexp="(^.+(youtu.be).*\$)"

/ip firewall filter
add action=drop chain=forward content=VzwCV0S6Hk8 disabled=no layer7-protocol=youtube


Ответить