Нужна помощь! Простой скрипт.

Здесь выкладываем скрипты
Ответить
xTeam
Сообщения: 5
Зарегистрирован: 27 ноя 2019, 10:59

27 ноя 2019, 11:03

Добрый день!
Подскажите как сделать чтоб при появлении в address-list определенного ip, включался-выключался определенный интерфейс или ip-адрес на интерфейсе? Типа:

:local interA [/ip firewall address-list find address="10.16.0.4"]
:if ($interA=10.16.0.4) do={
/ip address disable numbers=0
}

Заранее благодарен!


vqd
Модератор
Сообщения: 3605
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

27 ноя 2019, 11:18

:if ([len [/ip firewall address-list find address=1.1.1.1 list=name]] > 0] do={сделать что то}


Есть интересная задача и бюджет? http://mikrotik.site
xTeam
Сообщения: 5
Зарегистрирован: 27 ноя 2019, 10:59

27 ноя 2019, 11:30

сделал так:(не работает)

:if ([len [/ip firewall address-list find address=10.16.0.4 list=testList]] > 0] do={/ip address disable numbers=0}

вообщем есть пользователь с ip 10.16.0.4 при попадании его в testList должно проходить действие, данный скрипт не заработал!


vqd
Модератор
Сообщения: 3605
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

27 ноя 2019, 11:47

:if ([:len [/ip firewall address-list find address=10.16.0.4 list=testList]] > 0) do={/ip address disable numbers=0}


Есть интересная задача и бюджет? http://mikrotik.site
xTeam
Сообщения: 5
Зарегистрирован: 27 ноя 2019, 10:59

27 ноя 2019, 12:35

дьявол в мелочах! работает! СПАСИБО!


Ответить