2011UAS-2HnD-IN Vlans

Обсуждение оборудования и его настройки
Аватара пользователя
simpl3x
Модератор
Сообщения: 1532
Зарегистрирован: 19 апр 2012, 14:03

23 окт 2012, 15:15

к сожалению опыта общения с цисками нет, но по логике вещей:

Код: Выделить всё

interface FastEthernet0/22
switchport trunk native vlan 192
switchport trunk allowed vlan 172
switchport mode trunk
spanning-tree portfast

все что влетело в 22 порт тегируется 192 и если улетает с порта 192 метка, то она снимается? и 172 передается и принимается без изменений?
т.е. eth 1 должен получить адрес из того же диапазона, что и vlan 172?
попробуйте

Код: Выделить всё

system logging add topics=debug action=memory

и идите в закладку log
может там увидите что почему он не принимает адрес на этих интерфейсах.


rrock
Сообщения: 13
Зарегистрирован: 24 сен 2012, 16:15

23 окт 2012, 17:22

написали правильно вот лог собственно только broadcast

Код: Выделить всё

05:38:10 dhcp,debug,packet dhcp-client on eth1 sending discover with id 2601305392 to 255.255.255.255 
05:38:10 dhcp,debug,packet     secs = 6
05:38:10 dhcp,debug,packet     flags = broadcast
05:38:10 dhcp,debug,packet     ciaddr = 0.0.0.0
05:38:10 dhcp,debug,packet     chaddr = D4:CA:6D:63:44:89
05:38:10 dhcp,debug,packet     Msg-Type = discover
05:38:10 dhcp,debug,packet     Client-Id = 01-D4-CA-6D-63-44-89
05:38:10 dhcp,debug,packet     Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-Server,NTP-Server
05:38:10 dhcp,debug,packet     Host-Name = "mikro"
05:38:10 dhcp,debug,packet dhcp-client on eth2 sending discover with id 18055372 to 255.255.255.255
05:38:10 dhcp,debug,packet     secs = 52
05:38:10 dhcp,debug,packet     ciaddr = 0.0.0.0
05:38:10 dhcp,debug,packet     chaddr = D4:CA:6D:63:44:8A
05:38:10 dhcp,debug,packet     Msg-Type = discover
05:38:10 dhcp,debug,packet     Client-Id = 01-D4-CA-6D-63-44-8A
05:38:10 dhcp,debug,packet     Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-Server,NTP-Server
05:38:10 dhcp,debug,packet     Host-Name = "MikroTik"
05:38:14 dhcp,debug,packet dhcp-client on eth2 sending discover with id 18055372 to 255.255.255.255
05:38:14 dhcp,debug,packet     secs = 56
05:38:14 dhcp,debug,packet     ciaddr = 0.0.0.0
05:38:14 dhcp,debug,packet     chaddr = D4:CA:6D:63:44:8A
05:38:14 dhcp,debug,packet     Msg-Type = discover
05:38:14 dhcp,debug,packet     Client-Id = 01-D4-CA-6D-63-44-8A
05:38:14 dhcp,debug,packet     Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-Server,NTP-Server
05:38:14 dhcp,debug,packet     Host-Name = "MikroTik"
05:38:15 dhcp,debug,packet dhcp-client on eth1 sending discover with id 2601305392 to 255.255.255.255
05:38:15 dhcp,debug,packet     secs = 11
05:38:15 dhcp,debug,packet     flags = broadcast
05:38:15 dhcp,debug,packet     ciaddr = 0.0.0.0
05:38:15 dhcp,debug,packet     chaddr = D4:CA:6D:63:44:89
05:38:15 dhcp,debug,packet     Msg-Type = discover
05:38:15 dhcp,debug,packet     Client-Id = 01-D4-CA-6D-63-44-89
05:38:15 dhcp,debug,packet     Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-Server,NTP-Server
05:38:15 dhcp,debug,packet     Host-Name = "mikro"
05:38:17 dhcp,debug,packet dhcp-client on eth2 sending discover with id 18055372 to 255.255.255.255
05:38:17 dhcp,debug,packet     secs = 59
05:38:17 dhcp,debug,packet     ciaddr = 0.0.0.0
05:38:17 dhcp,debug,packet     chaddr = D4:CA:6D:63:44:8A
05:38:17 dhcp,debug,packet     Msg-Type = discover
05:38:17 dhcp,debug,packet     Client-Id = 01-D4-CA-6D-63-44-8A
05:38:17 dhcp,debug,packet     Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-Server,NTP-Server
05:38:17 dhcp,debug,packet     Host-Name = "MikroTik"
05:38:19 dhcp,debug,packet dhcp-client on eth2 sending discover with id 18055372 to 255.255.255.255
05:38:19 dhcp,debug,packet     secs = 62
05:38:19 dhcp,debug,packet     ciaddr = 0.0.0.0
05:38:19 dhcp,debug,packet     chaddr = D4:CA:6D:63:44:8A
05:38:19 dhcp,debug,packet     Msg-Type = discover
05:38:19 dhcp,debug,packet     Client-Id = 01-D4-CA-6D-63-44-8A
05:38:19 dhcp,debug,packet     Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-Server,NTP-Server
05:38:19 dhcp,debug,packet     Host-Name = "MikroTik"
05:38:21 dhcp,debug,packet dhcp-client on eth1 sending discover with id 2601305392 to 255.255.255.255
05:38:21 dhcp,debug,packet     secs = 18
05:38:21 dhcp,debug,packet     ciaddr = 0.0.0.0
05:38:21 dhcp,debug,packet     chaddr = D4:CA:6D:63:44:89
05:38:21 dhcp,debug,packet     Msg-Type = discover
05:38:21 dhcp,debug,packet     Client-Id = 01-D4-CA-6D-63-44-89
05:38:21 dhcp,debug,packet     Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-Server,NTP-Server
05:38:21 dhcp,debug,packet     Host-Name = "mikro"
05:38:22 dhcp,debug,packet dhcp-client on eth2 sending discover with id 3316318581 to 255.255.255.255
05:38:22 dhcp,debug,packet     flags = broadcast
05:38:22 dhcp,debug,packet     ciaddr = 0.0.0.0
05:38:22 dhcp,debug,packet     chaddr = D4:CA:6D:63:44:8A
05:38:22 dhcp,debug,packet     Msg-Type = discover
05:38:22 dhcp,debug,packet     Client-Id = 01-D4-CA-6D-63-44-8A
05:38:22 dhcp,debug,packet     Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-Server,NTP-Server
05:38:22 dhcp,debug,packet     Host-Name = "MikroTik"
05:38:23 dhcp,debug,packet dhcp-client on eth2 sending discover with id 815427052 to 255.255.255.255
05:38:23 dhcp,debug,packet     flags = broadcast
05:38:23 dhcp,debug,packet     ciaddr = 0.0.0.0
05:38:23 dhcp,debug,packet     chaddr = D4:CA:6D:63:44:8A
05:38:23 dhcp,debug,packet     Msg-Type = discover
05:38:23 dhcp,debug,packet     Client-Id = 01-D4-CA-6D-63-44-8A
05:38:23 dhcp,debug,packet     Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-Server,NTP-Server
05:38:23 dhcp,debug,packet     Host-Name = "MikroTik"


rrock
Сообщения: 13
Зарегистрирован: 24 сен 2012, 16:15

23 окт 2012, 19:57

simpl3x писал(а):к сожалению опыта общения с цисками нет, но по логике вещей:

Код: Выделить всё

interface FastEthernet0/22
switchport trunk native vlan 192
switchport trunk allowed vlan 172
switchport mode trunk
spanning-tree portfast

все что влетело в 22 порт тегируется 192 и если улетает с порта 192 метка, то она снимается? и 172 передается и принимается без изменений?
т.е. eth 1 должен получить адрес из того же диапазона, что и vlan 172?
попробуйте

Код: Выделить всё

system logging add topics=debug action=memory

и идите в закладку log
может там увидите что почему он не принимает адрес на этих интерфейсах.

Немного неверно в 192 vlan есть свой dhcp


rrock
Сообщения: 13
Зарегистрирован: 24 сен 2012, 16:15

24 окт 2012, 11:30

Вопрос разрешился.

Как оказалось потребовалось изменить конфиг на циске.
Было

Код: Выделить всё

c2950_bash#show run int fa0/23
Building configuration...

Current configuration : 154 bytes
!
interface FastEthernet0/23
 switchport trunk native vlan 172
 switchport trunk allowed vlan 192
 switchport mode trunk
 spanning-tree portfast
end


Добавил в trunk нативный влан

Код: Выделить всё

c2950_bash#show run int fa0/23
Building configuration...

Current configuration : 154 bytes
!
interface FastEthernet0/23
 switchport trunk native vlan 172
 switchport trunk allowed vlan 172,192
 switchport mode trunk
 spanning-tree portfast
end


Ответить