Как выборочно перенаправлять траффик в обход блокировок?

Обсуждение ПО и его настройки
Ответить
Fatau
Сообщения: 1
Зарегистрирован: 10 мар 2019, 15:44

10 мар 2019, 15:51

Друзья приветствую. Даже не прошу готового ответа, но подскажите в какую сторону копать.
Есть проплаченный NordVpn. Они предоставляют доступ по протоколам IKEv2/IPSec, Socks 5, HTTP Proxy, HTTP Proxy (SSL)
Можно ли мне как то настроить роутер так, для adress list например flibusta.net он направлял траффик через сервера NordVpn. (чтобы он через прокси например прогонял их) ?


Аватара пользователя
algerka
Сообщения: 339
Зарегистрирован: 14 дек 2011, 12:31

10 мар 2019, 20:19

Fatau писал(а):
10 мар 2019, 15:51
Даже не прошу готового ответа, но подскажите в какую сторону копать.
Если коротко, то у меня дома сделано так: есть адрес-лист, адреса из которого маркируются и маршрутизацией отправляются через туннель на виртуалку с chr, у которой нет ограничений.
Как вам это сделать на каком-то там NordVpn додумайте сами.


Александр
Аватара пользователя
podarok66
Модератор
Сообщения: 3228
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

15 мар 2019, 23:02

Надо создать адрес-лист с ресурсами, которые надо вести в обход Zapret:

Код: Выделить всё

ip firewall address-list
add list=Zapret address=flibusta.is
add  list=Zapret address=lib.rus.ec
add  list=Zapret address=lurkmore.to 
add  list=Zapret address=absurdopedia.net
add  list=Zapret address=rutracker.org
Вместо одного правила маскарада будет два. Адрес-лист "My user" - все адреса, локалки, которые получают выход в сеть по данным правилам:

Код: Выделить всё

/ip firewall nat
add action=masquerade chain=srcnat dst-address-list=!Zapret out-interface=WAN src-address-list="My user"
add action=masquerade chain=srcnat dst-address-list=Zapret out-interface=NordVpn src-address-list="My user"
Маркируем роуты:

Код: Выделить всё

/ip firewall mangle
add action=mark-routing chain=prerouting comment=vpn_rout dst-address-list=Zapret new-routing-mark=vpn_rout passthrough=yes
Прописываем маршрут для туннеля с учётом маркировки ( gateway=10.0.0.1 - адрес шлюза в туннеле, а не интерфейс, нам ведь надо добросить до того конца туннеля, а не просто выбросить из маршрутизатора пакеты):

Код: Выделить всё

/ip route
add comment=Zapret_address distance=1 gateway=10.0.0.1 routing-mark=vpn_rout
Цены, конечно на вашем NordVpn конские.


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
Ответить