Скрипт для blacklist

Здесь выкладываем скрипты
Правила форума
Уважаемые Пользователи форума, обратите внимание!
Ни при каких обстоятельствах, Администрация форума, не несёт ответственности за какой-либо, прямой или косвенный, ущерб причиненный в результате использования материалов, взятых на этом Сайте или на любом другом сайте, на который имеется гиперссылка с данного Сайта. Возникновение неисправностей, потерю программ или данных в Ваших устройствах, даже если Администрация будет явно поставлена в известность о возможности такого ущерба.
Просим Вас быть предельно осторожными и внимательными, в использовании материалов раздела. Учитывать не только Ваши пожелания, но и границы возможностей вашего оборудования.
Ответить
a.ivanov
Сообщения: 2
Зарегистрирован: 26 окт 2023, 20:36

Добрый день всем-всем!

Кто-нибудь может помочь с скриптом, который будет смотреть в лог и по строке к примеру denied winbox/dude connect from 71.хх.хх.ххх и отправлять эти айпишники в определенный адреслист? Я знаю что тут сидят люди, для которых это действие занимает минуту :-):


-13-
Сообщения: 126
Зарегистрирован: 18 мар 2021, 12:45

зачем для этого скрипт?
через firewall отлично работает
 blackList

Код: Выделить всё

/ip firewall filter
add action=accept chain=WAN-Input-Access comment=\
    "6.2.1 - WAN-Input-Access - WinBox WAN access" disabled=yes dst-port=8291 \
    log-prefix=6.2.1 protocol=tcp
add action=accept chain=output comment="6.2.2 - WinBox login, 3 try" content=\
    "invalid user name or password" dst-limit=1/1m,1,dst-address/1h \
    log-prefix=6.2.2 out-interface-list=WAN protocol=tcp src-port=8291
add action=add-dst-to-address-list address-list=WinBox-BlackList \
    address-list-timeout=1w chain=output comment=\
    "6.2.3 - Put IP in address-list, list=WinBox-BlackList" content=\
    "invalid user name or password" dst-limit=1/1m,1,dst-address/10m \
    log-prefix=6.2.3 out-interface-list=WAN protocol=tcp src-port=8291


Ответить