Статистика подключавшихся к АР.

Раздел для тех, кто начинает знакомиться с MikroTik
Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку "Действия до настройки роутера".
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там export. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.
maxim_minton
Сообщения: 101
Зарегистрирован: 14 мар 2017, 13:03

21 мар 2017, 20:21

podarok66 писал(а): Попробуйте немного реализма добавить в жизнь.

Вот и пытаюсь этот самый реализм добавить :)


maxim_minton
Сообщения: 101
Зарегистрирован: 14 мар 2017, 13:03

21 мар 2017, 20:22

podarok66 писал(а):Это не про ваш?

К сожалению, нет, это про производственный сегмент скорее всего.

Итак, настроил SYSLog на QNAPe. Теперь возникла мысль. Можно же ж по факту подключения клиента к микротику выполнять скрипт, который занесет в лог запись типа: Новое подключение МАС такой то, время такое то.

Ну вот и реализованное:

Код: Выделить всё

{
    :local t [/system clock get time];
    :local d [/system clock get date];
    :foreach i in=[/ip dhcp-server lease find] do={
        :if ([/ip dhcp-server lease get $i status]="bound" && [/ip dhcp-server lease get $i comment]="" && [/ip dhcp-server lease get $i server]="dhcp-free") do={
        :local g [("Guest" . "-" . $d . "-" . $t)]
         /ip dhcp-server lease set $i comment=$g;
        /ip firewall address-list add address=[/ip dhcp-server lease get $i address] list="Drop" timeout=1d
         :local o [/ip dhcp-server lease get $i mac-address];
         :local q [/ip dhcp-server lease get $i address];
         /log warning ("New_AP_User_$t - $d - $o - $q")
     

        }
    }
 }


Ответить