Проброс портов?

Обсуждение ПО и его настройки
Ответить
aleksandr.pimenov
Сообщения: 5
Зарегистрирован: 11 фев 2019, 14:08

12 фев 2019, 09:21

Ситуация в следующем настроена АТС на два провайдера SIP, один из них через Internet, второй (MTS) через SIP транк с авторизацией по IP.
Все работает, почти... Если сделать исходящий по SIP транку поднимается соединение и работаю и исходящие и входящие звонки.
Через некоторое время это соединение закрывается и перестают работать входящие звонки.

Когда не работаю входящие на порт ether5-MTS от SIP провайдера приходит:
INVITE sip:4957377342@10.60.104.34;user=phone SIP/2.0
From: <sip:9263009700@212.248.28.10;user=phone>;
To: <sip:4957377342@10.60.104.34;user=phone>
И соответственно это также есть на bridgeVoIP, куда подключена АТС с IP 10.0.0.200

А вот когда линия поднята исходящим соединением, и уже работает входящая связь, на порт ether5-MTS от SIP провайдера приходит:
INVITE sip:4957377342@10.0.0.200:5060;user=phone SIP/2.0
From: <sip:9263009700@212.248.28.10;user=phone>;
To: <sip:4957377342@10.0.0.200:5060;user=phone>
И соответственно это также есть на bridgeVoIP, куда подключена АТС с IP 10.0.0.200

Можно как нибудь сделать, чтобы приходящие SIP на ether5-MTS с адресом 10.60.104.34 преобразовывались 10.0.0.200?

 Настройки MokroTik

/interface bridge
add name="bridge Enternet"
add name=bridgeVoIP
/interface ethernet
set [ find default-name=ether5 ] name=ether5-MTS
set [ find default-name=ether6 ] name=ether6-WAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/dude
set data-directory=/disk1/dude enabled=yes
/interface bridge port
add bridge=bridgeVoIP interface=ether1
add bridge=bridgeVoIP interface=ether2
add bridge=bridgeVoIP interface=ether3
add bridge="bridge Enternet" interface=sfp1
add bridge="bridge Enternet" interface=ether7
add bridge="bridge Enternet" interface=ether8
add bridge="bridge Enternet" interface=ether9
add bridge="bridge Enternet" interface=ether10
/ip firewall connection tracking
set generic-timeout=5m
/ip address
add address=10.0.0.2/24 interface=ether1 network=10.0.0.0
add address=10.60.104.34/29 interface=ether5-MTS network=10.60.104.32
add address=192.168.20.170/30 interface=ether6-WAN network=192.168.20.168
/ip dns
set allow-remote-requests=yes max-concurrent-queries=200 max-concurrent-tcp-sessions=100 servers=192.168.20.169,8.8.8.8,8.8.4.4
/ip firewall address-list
add address=212.248.28.10 disabled=yes list="SIP VoIP"
add address=77.51.247.44 list="SIP RT"
add address=195.3.254.2 list="SIP RT"
/ip firewall filter
add chain=input protocol=icmp
add chain=forward protocol=icmp
add chain=input connection-state=established,related
add action=drop chain=input connection-state=invalid
add chain=input src-address=10.0.0.0/24
add action=drop chain=input
add chain=forward connection-state=established,related
add action=drop chain=forward connection-state=invalid
add chain=forward src-address=10.0.0.0/24
add action=drop chain=forward
/ip firewall mangle
add action=mark-connection chain=forward in-interface=ether5-MTS new-connection-mark=MTS-con passthrough=yes
add action=mark-connection chain=forward in-interface=ether6-WAN new-connection-mark=WAN-con passthrough=yes
add action=mark-routing chain=prerouting connection-mark=MTS-con new-routing-mark=MTS-rt passthrough=yes src-address=10.0.0.0/24
add action=mark-routing chain=prerouting connection-mark=WAN-con new-routing-mark=WAN-rt passthrough=yes src-address=10.0.0.0/24
add action=mark-connection chain=input dst-address=10.6.104.34 in-interface=ether5-MTS new-connection-mark=MTS->Input passthrough=yes
add action=mark-connection chain=input dst-address=192.166.20.170 in-interface=ether6-WAN new-connection-mark=WAN->Input passthrough=yes
add action=mark-routing chain=output connection-mark=MTS->Input new-routing-mark=MTS-rt passthrough=yes
add action=mark-routing chain=output connection-mark=WAN->Input new-routing-mark=WAN-rt passthrough=yes
add action=mark-connection chain=output new-connection-mark=MTS->out passthrough=yes src-address=10.60.104.34
add action=mark-connection chain=output new-connection-mark=WAN->out passthrough=yes src-address=192.168.20.170
add action=mark-routing chain=output connection-mark=MTS->out new-routing-mark=MTS-rt passthrough=yes src-address=10.60.104.34
add action=mark-routing chain=output connection-mark=WAN->out new-routing-mark=WAN-rt passthrough=yes src-address=192.168.20.170
add action=mark-routing chain=prerouting connection-state=new dst-address-list="SIP VoIP" new-routing-mark=MTS-rt passthrough=yes
add action=mark-routing chain=prerouting connection-state=new dst-address-list="SIP RT" new-routing-mark=WAN-rt passthrough=yes
/ip firewall nat
add action=src-nat chain=srcnat out-interface=ether5-MTS src-address=10.0.0.0/24 to-addresses=10.60.104.34
add action=src-nat chain=srcnat out-interface=ether6-WAN src-address=10.0.0.0/24 to-addresses=192.168.20.170
add action=dst-nat chain=dstnat in-interface=ether5-MTS protocol=udp src-address=10.60.104.34 src-port=5060 to-addresses=10.0.0.200 to-ports=5060
/ip firewall service-port
set sip sip-timeout=1d
/ip route
add distance=1 gateway=10.60.104.33 routing-mark=MTS-rt
add distance=1 gateway=192.168.20.169 routing-mark=WAN-rt
add distance=1 gateway=10.60.104.33,192.168.20.169
/lcd
set backlight-timeout=never default-screen=informative-slideshow time-interval=weekly
/snmp
set contact=alevpi@mail.ru enabled=yes location="VS ATS" trap-generators="" trap-version=2
/system clock
set time-zone-name=Europe/Moscow
/system identity
set name=VoIP
/system ntp client
set enabled=yes primary-ntp=89.109.251.23 secondary-ntp=46.175.224.7


Ответить