Проброс пула белых IP мимо NAT

Обсуждение ПО и его настройки
xvo
Сообщения: 3429
Зарегистрирован: 25 фев 2018, 22:41
Откуда: Москва

24 ноя 2022, 17:12

Да что тут непонятного со схемой то?
Подсеть провайдером маршрутизируется через адрес прилетающий от него по DHCP на первый порт.

От провайдера инструкция была правильная, и сделано все изначально было как надо - должно было работать без маскарада для этой подсети.
Если не работало - вероятно, причиной каша в firewall'е и nat'е.


Telegram: @thexvo

Дома: [CCR1009-7G-1C-1S+] [CRS112-8P-4S-IN] [wAP ac] [RB260GS]
Не дома: [RB4011iGS+] [CRS326-24G-2S+RM] [wAP 60ad] [cAP ac]...
...[hEX] [hAP ac²] [hAP ac lite] [hAP mini] [RB260GS]
gatall
Сообщения: 9
Зарегистрирован: 06 окт 2022, 21:47

Вчера, 10:34

Полагаю в нате дело, может не отключается полностью, ведь для bridge1 он продолжает работать, или может firawall правила в raw accept делать, или может у провайдера правило что пакеты с самого этого адреса должны быть или с него или с подсети за ним.(последнее сомневаюсь).
Шлюз правайдера *.*.80.81 и сеть *.*.82.80 с *.*.80.38 (адрес микротика полученный по dhcp от провайдера) пингуется,
а с сети *.*.82.80 провайдерский шлюз не пигуется, и пинг внутрь микротика с мира в коннекшен попадает. Правила firewall
Буду крутить дальше.


bst-botsman
Сообщения: 124
Зарегистрирован: 13 окт 2018, 20:53
Откуда: Беларусь

Вчера, 12:33

gatall писал(а):
Вчера, 10:34
Полагаю в нате дело, может не отключается полностью, ведь для bridge1 он продолжает работать, или может firawall правила в raw accept делать, или может у провайдера правило что пакеты с самого этого адреса должны быть или с него или с подсети за ним.(последнее сомневаюсь).
Шлюз правайдера *.*.80.81 и сеть *.*.82.80 с *.*.80.38 (адрес микротика полученный по dhcp от провайдера) пингуется,
а с сети *.*.82.80 провайдерский шлюз не пигуется, и пинг внутрь микротика с мира в коннекшен попадает. Правила firewall
Буду крутить дальше.
Хоспади.... Да покажите же Вы наконец-то полный конфиг микротика, а не кусочки... В Ваших мыслях вслух очень сложно что-либо понять...


RB3011UiAS x 1
RB4011iGS+5HacQ2HnD x 3
951Ui-2nD x 2
hAP ac^2 x 24
gmx
Модератор
Сообщения: 2984
Зарегистрирован: 01 окт 2012, 14:48

Вчера, 17:16

Да добейтесь вы работы ноутбука напрямую с нужным вам ip. И тогда все получится. Поймёте как это раьотает. Поставите коммутатор до микротика и все.


gatall
Сообщения: 9
Зарегистрирован: 06 окт 2022, 21:47

Вчера, 17:17

bst-botsman писал(а):
Вчера, 12:33
gatall писал(а):
Вчера, 10:34
Полагаю в нате дело, может не отключается полностью, ведь для bridge1 он продолжает работать, или может firawall правила в raw accept делать, или может у провайдера правило что пакеты с самого этого адреса должны быть или с него или с подсети за ним.(последнее сомневаюсь).
Шлюз правайдера *.*.80.81 и сеть *.*.82.80 с *.*.80.38 (адрес микротика полученный по dhcp от провайдера) пингуется,
а с сети *.*.82.80 провайдерский шлюз не пигуется, и пинг внутрь микротика с мира в коннекшен попадает. Правила firewall
Буду крутить дальше.
Хоспади.... Да покажите же Вы наконец-то полный конфиг микротика, а не кусочки... В Ваших мыслях вслух очень сложно что-либо понять...

Вот полный
 
# model = RB2011UiAS-2HnD

/interface bridge
add admin-mac=4C:5E:0C:0B:80:52 auto-mac=no comment=defconf name=bridge1
add admin-mac=4C:5E:0C:0B:80:52 auto-mac=no comment=defconf name=bridge2
/interface ethernet
set [ find default-name=ether1 ] advertise=1000M-half,1000M-full name=\
ether1MTS
set [ find default-name=ether3 ] name=ether3NAS
set [ find default-name=ether4 ] name="ether4 TP-Link5Ghz"
/interface wireless
set [ find default-name=wlan1 ] amsdu-limit=4096 amsdu-threshold=4096 \
antenna-gain=0 band=2ghz-g/n channel-width=20/40mhz-Ce country=\
no_country_set disabled=no frequency=2437 frequency-mode=manual-txpower \
mode=ap-bridge multicast-helper=full ssid=MTKGTL2 station-roaming=enabled \
wmm-support=enabled wps-mode=disabled
/interface wireguard
add disabled=yes listen-port=13231 mtu=1420 name=MainWG
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface lte apn
set [ find default=yes ] ip-type=ipv4 use-network-apn=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" \
group-key-update=10m mode=dynamic-keys supplicant-identity=MikroTik
/ip ipsec proposal
set [ find default=yes ] auth-algorithms=sha512,sha256,sha1 enc-algorithms=\
aes-256-cbc,aes-256-ctr,aes-256-gcm,aes-192-cbc,aes-128-cbc
/ip pool
add name=vpn ranges=192.168.0.101-192.168.0.200
add name=dhcp_pool_br2 ranges=222.33.82.82-222.33.82.85
add name=pool100 ranges=192.168.100.101-192.168.100.250
add name=dhcp_pool_br1 ranges=192.168.0.20-192.168.0.180
/ip dhcp-server
add add-arp=yes address-pool=dhcp_pool_br1 always-broadcast=yes \
conflict-detection=no interface=bridge1 lease-time=2d10h10m name=dhcp1 \
server-address=192.168.0.1
add add-arp=yes address-pool=dhcp_pool_br2 always-broadcast=yes \
conflict-detection=no interface=bridge2 lease-time=2d10h10m name=server2
/port
set 0 name=serial0
/ppp profile
set *0 use-encryption=no use-ipv6=no
set *FFFFFFFE bridge=bridge1 dns-server=192.168.0.1 local-address=192.168.0.1 \
remote-address=vpn use-encryption=no use-ipv6=no
/queue simple
add disabled=yes max-limit=256k/256k name=queue1 packet-marks=porn
/queue tree
add disabled=yes name=queue1 parent=global
add disabled=yes name=queue2 packet-mark=yt-download parent=global queue=\
pcq-download-default
/routing table
add fib name=youtube
add fib name=nout
add fib name=s10lite
/snmp community
set [ find default=yes ] addresses=127.0.0.1/32 read-access=no
/system logging action
add email-to=e@mailaddr name=sandemail target=email
/user group
add name=notfull policy="read,write,policy,test,winbox,web,sniff,api,romon,res\
t-api,!local,!telnet,!ssh,!ftp,!reboot,!password,!sensitive"
/interface bridge port
add bridge=bridge2 comment=defconf ingress-filtering=no interface=ether3NAS
add bridge=bridge2 comment=defconf ingress-filtering=no interface=\
"ether4 TP-Link5Ghz"
add bridge=bridge1 comment=defconf ingress-filtering=no interface=ether5
add bridge=bridge1 comment=defconf ingress-filtering=no interface=ether7
add bridge=bridge1 comment=defconf ingress-filtering=no interface=ether8
add bridge=bridge1 comment=defconf ingress-filtering=no interface=ether9
add bridge=bridge1 comment=defconf ingress-filtering=no interface=ether10
add bridge=bridge1 ingress-filtering=no interface=wlan1
add bridge=bridge1 ingress-filtering=no interface=ether2
add bridge=bridge1 comment=defconf ingress-filtering=no interface=ether6
/ip neighbor discovery-settings
set discover-interface-list=!WAN
/ip settings
set max-neighbor-entries=8192 tcp-syncookies=yes
/ipv6 settings
set disable-ipv6=yes max-neighbor-entries=8192
/interface detect-internet
set detect-interface-list=all
/interface l2tp-server server
set authentication=mschap2 enabled=yes max-mru=1420 max-mtu=1420 use-ipsec=\
yes
/interface list member
add comment=defconf interface=bridge1 list=LAN
add comment=defconf interface=ether1MTS list=WAN
add comment=defconf interface=*F00000 list=LAN
add comment=defconf interface=*F0002C list=LAN
/interface ovpn-server server
set auth=sha1,md5 certificate=DigiCertGlobalRootCA.crt.pem_0 cipher=\
blowfish128,aes128,aes192,aes256 default-profile=default-encryption mode=\
ethernet require-client-certificate=yes
/interface pptp-server server
# PPTP connections are considered unsafe, it is suggested to use a more modern VPN protocol instead
set enabled=yes
/interface sstp-server server
set default-profile=default-encryption
/interface wireguard peers
add allowed-address=222.33.0.0/16,192.168.100.0/24 disabled=yes interface=\
MainWG persistent-keepalive=30s public-key=\
"[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[["
add allowed-address=222.33.95.147/32,192.168.88.0/24 disabled=yes \
endpoint-address=222.33.95.147 endpoint-port=13231 interface=MainWG \
persistent-keepalive=30s public-key=\
"[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[[["
/ip address
add address=192.168.0.1/24 comment=defconf interface=bridge1 network=\
192.168.0.0
add address=222.33.82.81/29 comment=defconf interface=bridge2 network=\
222.33.82.80
/ip cloud
set ddns-enabled=yes ddns-update-interval=30m
/ip dhcp-client
add interface=ether1MTS
/ip dhcp-server config
set store-leases-disk=20h5m
/ip dhcp-server lease
add address=192.168.0.20 client-id=1:c:89:10:42:24:bc comment=\
TV_samsung55_ZAL mac-address=0C:89:10:42:24:BC server=dhcp1
add address=192.168.0.99 client-id=1:c4:57:6e:be:fa:83 comment=\
TV_samsung_kuhnya mac-address=C4:57:6E:BE:FA:83 server=dhcp1
add address=192.168.0.100 client-id=1:2c:fd:a1:5e:7e:c1 comment="Static comp" \
mac-address=2C:FD:A1:5E:7E:C1 server=dhcp1
add address=192.168.0.24 client-id=1:4c:8d:79:47:28:1e comment=iPad-Vitaly \
mac-address=4C:8D:79:47:28:1E server=dhcp1
add address=192.168.0.25 client-id=1:0:11:32:5f:be:12 comment=Sinology \
mac-address=00:11:32:5F:BE:12 server=dhcp1
add address=192.168.0.32 client-id=1:8c:18:d9:26:12:d0 mac-address=\
8C:18:D9:26:12:D0 server=dhcp1
add address=192.168.0.33 client-id=1:24:ee:9a:94:1c:db mac-address=\
24:EE:9A:94:1C:DB server=dhcp1
add address=192.168.0.38 client-id=1:68:ff:7b:63:e1:86 comment=\
"TPLink AP State" mac-address=68:FF:7B:63:E1:86 server=dhcp1
add address=192.168.0.37 client-id=1:68:ff:7b:63:e1:87 comment=\
"TPLink WAN Router state" mac-address=68:FF:7B:63:E1:87 server=dhcp1
add address=192.168.0.41 client-id=ff:12:34:56:78:0:3:0:6:68:a4:e:59:33:9f \
comment="Kuhnya Duhovka" mac-address=68:A4:0E:59:33:9F server=dhcp1
add address=192.168.0.48 client-id=1:6:82:1:20:13:ae mac-address=\
06:82:01:20:13:AE server=dhcp1
add address=192.168.0.51 client-id=1:2:e:d1:42:e1:15 mac-address=\
02:0E:D1:42:E1:15 server=dhcp1
add address=192.168.0.52 client-id=1:62:96:23:2e:20:5d mac-address=\
62:96:23:2E:20:5D server=dhcp1
add address=192.168.0.35 client-id=1:da:a7:5c:7c:9c:26 mac-address=\
DA:A7:5C:7C:9C:26 server=dhcp1
add address=192.168.0.56 client-id=1:88:66:5a:1e:c6:f8 mac-address=\
88:66:5A:1E:C6:F8 server=dhcp1
add address=192.168.0.40 client-id=1:28:6d:97:f5:92:b5 mac-address=\
28:6D:97:F5:92:B5 server=dhcp1
add address=192.168.0.90 client-id=1:0:e:c6:8f:d6:97 mac-address=\
00:0E:C6:8F:D6:97 server=dhcp1
/ip dhcp-server network
add address=222.33.82.80/29 dns-server=222.33.82.81,8.8.8.8 gateway=222.33.82.81
add address=192.168.0.0/24 dns-server=192.168.0.1,8.8.8.8 gateway=192.168.0.1
/ip dns
set allow-remote-requests=yes cache-max-ttl=1h servers=1.1.1.1
/ip dns static
add address=192.168.88.1 disabled=yes name=router.lan
add address=192.168.0.1 name=router.lan
add address=216.239.32.65 name=landing.mts.by
add address=192.168.0.25 name=nas
add address=192.168.0.25 name=gatall.myds.me
/ip firewall address-list
add address=192.168.0.0/24 comment=LAN list=LAN
add address=86.57.133.212 disabled=yes list=WORK
add address=79.98.51.11 disabled=yes list=WORK
add address=37533ХХХХХХ.dyndns.mts.by disabled=yes list=33ХХХХХХ
add address=37529ХХХХХХ.dyndns.mts.by disabled=yes list=29ХХХХХХ
add address=222.33.82.80/29 comment=LAN list=LAN
add address=152.89.217.28 list=Ban
add address=65.108.46.154 list=Ban
/ip firewall filter
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=drop chain=forward disabled=yes dst-port=1029 protocol=tcp \
src-address=109.120.191.218
add action=accept chain=forward src-address=109.120.191.218
add action=accept chain=forward src-address=89.208.199.134
add action=drop chain=forward disabled=yes dst-address-list=ddos-targets \
src-address-list=ddos-attackers
add action=drop chain=forward src-address-list=Ban
add action=return chain=detect-ddos dst-limit=32,32,src-and-dst-addresses/10s
add action=add-dst-to-address-list address-list=ddos-targets \
address-list-timeout=10m chain=detect-ddos
add action=add-src-to-address-list address-list=ddos-attackers \
address-list-timeout=10m chain=detect-ddos
add action=jump chain=forward connection-state=new jump-target=detect-ddos
add action=return chain=detect-ddos dst-limit=32,32,src-and-dst-addresses/10s
add action=add-dst-to-address-list address-list=ddos-targets \
address-list-timeout=10m chain=detect-ddos
add action=add-src-to-address-list address-list=ddos-attackers \
address-list-timeout=10m chain=detect-ddos
add action=return chain=detect-ddos dst-limit=32,32,src-and-dst-addresses/10s \
protocol=tcp tcp-flags=syn,ack
add action=fasttrack-connection chain=forward hw-offload=yes
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
protocol=udp
add action=accept chain=input comment="allow IPsec NAT" dst-port=13231 \
protocol=tcp
add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
add action=accept chain=input comment=GRE protocol=gre
add action=accept chain=input comment="allow l2tp" dst-port=1701 protocol=udp
add action=accept chain=input comment="allow pptp" dst-port=1723 protocol=tcp
add action=accept chain=input comment="allow pptp" dst-port=1194 protocol=tcp
add action=accept chain=input comment=Wireguardport disabled=yes dst-port=\
13231 protocol=udp
add action=accept chain=input comment="allow sstp" disabled=yes dst-port=443 \
protocol=tcp
add action=accept chain=input comment="allow 80" disabled=yes dst-port=80 \
protocol=tcp
add action=accept chain=input disabled=yes src-address-list=33ХХХХХХ
add action=accept chain=input disabled=yes src-address-list=29ХХХХХХ
add action=accept chain=input disabled=yes src-address-list=WORK
add action=accept chain=forward disabled=yes src-address-list=WORK
add action=accept chain=forward disabled=yes dst-address=222.33.82.80/29
add action=accept chain=input disabled=yes dst-address=222.33.82.80/29
add action=accept chain=forward disabled=yes src-address=222.33.82.80/29
add action=accept chain=forward disabled=yes in-interface=bridge2
add action=accept chain=input disabled=yes in-interface=bridge2
add action=accept chain=forward disabled=yes out-interface=bridge2
add action=accept chain=output disabled=yes out-interface=bridge2
add action=accept chain=input in-interface=all-ppp
add action=accept chain=forward in-interface=all-ppp
add action=accept chain=output out-interface=all-ppp
add action=accept chain=input comment=\
"input to mikrotik from LAN Address List" dst-port=445,8129 protocol=tcp \
src-address-list=LAN
add action=accept chain=input comment="defconf: accept ICMP" disabled=yes \
protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=drop chain=forward comment=Ipadmini disabled=yes src-address=\
192.168.0.24
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment="youtube block" disabled=yes dst-port=\
443 protocol=tcp tls-host=*.youtube.com
/ip firewall nat
add action=redirect chain=dstnat comment="redirect dns-query to local DNS" \
disabled=yes dst-port=53 in-interface-list=!WAN protocol=udp
add action=dst-nat chain=dstnat disabled=yes dst-address=222.33.82.82 \
to-addresses=222.33.82.81
add action=src-nat chain=srcnat disabled=yes src-address=222.33.82.81 \
to-addresses=222.33.82.82
add action=masquerade chain=srcnat out-interface-list=WAN src-address=\
192.168.0.0/24
add action=masquerade chain=srcnat out-interface-list=WAN src-address=\
192.168.100.0/24
add action=masquerade chain=srcnat dst-port=53 out-interface-list=WAN \
protocol=tcp
add action=masquerade chain=srcnat dst-port=53 out-interface-list=WAN \
protocol=udp
add action=masquerade chain=srcnat out-interface-list=WAN protocol=udp \
src-port=53
add action=masquerade chain=srcnat log=yes out-interface-list=WAN protocol=\
tcp src-port=53
add action=masquerade chain=srcnat log=yes out-interface-list=WAN
add action=accept chain=dstnat disabled=yes src-address=222.33.82.82 \
to-addresses=222.33.82.82
add action=same chain=srcnat disabled=yes out-interface=bridge2 \
same-not-by-dst=no to-addresses=222.33.80.38
add action=dst-nat chain=dstnat dst-port=7881 in-interface=ether1MTS \
protocol=tcp to-addresses=192.168.0.25 to-ports=7881
add action=netmap chain=dstnat comment="torrent to NAS" dst-port=51413 \
in-interface=ether1MTS protocol=tcp to-addresses=192.168.0.25 to-ports=\
51413
add action=netmap chain=dstnat comment="torrent to SOKS" dst-port=59486 \
in-interface=ether1MTS protocol=tcp to-addresses=192.168.0.195 to-ports=\
59486
add action=dst-nat chain=dstnat comment="Access to NAS" dst-port=\
!8291,1701,1723,4500 in-interface=ether1MTS protocol=tcp \
src-address-list=33ХХХХХХ to-addresses=192.168.0.25
add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
192.168.0.0/24
add action=dst-nat chain=dstnat comment=le.m dst-port=1000-1199 in-interface=\
ether1MTS protocol=tcp to-addresses=192.168.100.99 to-ports=1000-1199
add action=masquerade chain=srcnat out-interface=all-ppp protocol=tcp \
src-address=188.120.244.240
add action=masquerade chain=srcnat disabled=yes out-interface=all-ppp \
protocol=tcp src-address=188.120.240.0/21
/ip firewall raw
add action=drop chain=prerouting disabled=yes src-address=!192.160.0.0/24 \
src-address-list=ddos-attackers
add action=drop chain=prerouting src-address-list=Ban
/ip route
add disabled=no distance=1 dst-address=192.168.88.0/24 gateway=192.168.0.195 \
pref-src=0.0.0.0 routing-table=main scope=30 suppress-hw-offload=no \
target-scope=10
add disabled=no distance=1 dst-address=192.168.1.0/24 gateway=192.168.0.195 \
pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=10
add disabled=yes dst-address=0.0.0.0/0 gateway=192.168.0.195 routing-table=\
nout
add disabled=no distance=2 dst-address=192.168.100.0/24 gateway=192.168.0.196 \
pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=10
add disabled=no distance=2 dst-address=192.168.98.0/24 gateway=192.168.0.197 \
pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=10
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/ip smb
set allow-guests=no
/ip socks
set auth-method=password enabled=yes max-connections=300 port=18620 version=5
/ip socks access
add src-address=192.168.0.195
add disabled=yes src-address=0.0.0.0
/ip socks users
add name=torrent
/ip ssh
set allow-none-crypto=yes forwarding-enabled=remote
/ipv6 dhcp-client
add add-default-route=yes interface=ether1MTS request=address
/ipv6 firewall filter
add chain=forward
/ipv6 nd
set [ find default=yes ] advertise-dns=no
/lcd
set color-scheme=light enabled=no time-interval=daily touch-screen=disabled
/lcd interface pages
set 0 interfaces=wlan1
/ppp secret
add local-address=192.168.0.1 name=GatallD profile=default-encryption \
remote-address=192.168.0.195 routes=192.168.88.0/24
add name=ХХХХХХ
add disabled=yes name=itsm-admin remote-address=192.168.0.150
add local-address=192.168.0.1 name=GatallDD profile=default-encryption \
remote-address=192.168.1.2
add local-address=192.168.0.1 name=Golex profile=default-encryption \
remote-address=192.168.0.197 routes=192.168.98.0/24 service=l2tp
add local-address=192.168.0.1 name=FreeModem1 remote-address=192.168.0.196 \
routes=192.168.100.0/24
/system clock
set time-zone-name=Europe/Minsk
/system identity
set name=MTKGTLL
/system logging
add topics=ppp,debug,l2tp,ipsec,error
add topics=ipsec
add disabled=yes topics=wireless,!info
add disabled=yes topics=debug
add action=sandemail disabled=yes topics=firewall,info
add topics=ovpn,debug
add topics=debug,ipsec
/system ntp client
set enabled=yes
/system ntp client servers
add address=178.124.164.107
add address=178.124.134.106
/system routerboard settings
set cpu-frequency=700MHz
/system scheduler
add name=DDNS on-event="/system script run DDNS" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
start-time=startup
add interval=1d name=schedule1 on-event="/system script run DDNS" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
start-date=mar/09/2020 start-time=12:27:00
add name=schedule2 on-event="/system script run sysadmin" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
start-time=startup
/system script
add dont-require-permissions=no name=DDNS owner=admin policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="d\
elay 10;\r\
\n:global actualIP value=[/ip address get [find where interface=ether1MTS]\
\_value-name=address];\r\
\n:global actualIP value=[:pick \$actualIP -1 [:find \$actualIP \"/\" -1] \
];\r\
\n:if ([:len [/file find where name=ipstore.txt]] < 1 ) do={\r\
\n /file print file=ipstore.txt where name=ipstore.txt;\r\
\n /delay delay-time=2;\r\
\n /file set ipstore.txt contents=\"0.0.0.0\";\r\
\n};\r\
\n:global previousIP value=[/file get [find where name=ipstore.txt ] value\
-name=contents];\r\
\n:if (\$previousIP != \$actualIP) do={\r\
\n :log info message=(\"Try to Update DuckDNS with actual IP \".\$actualIP\
.\" - Previous IP are \".\$previousIP);\r\
\n /tool fetch mode=https keep-result=yes dst-path=duckdns-result.txt addr\
ess=[:resolve www.duckdns.org] port=443 host=www.duckdns.org src-path=(\"/\
update\?domains=gatall&token=ХХХХХХХХХХХХХХХХХХХХХХХХХХ&ip=\".\$\
actualIP);\r\
\n /delay delay-time=5;\r\
\n :global lastChange value=[/file get [find where name=duckdns-result.txt\
\_] value-name=contents];\r\
\n :global previousIP value=\$actualIP;\r\
\n /file set ipstore.txt contents=\$actualIP;\r\
\n :if (\$lastChange = \"OK\") do={:log warning message=(\"DuckDNS update \
successfull with IP \".\$actualIP);};\r\
\n :if (\$lastChange = \"KO\") do={:log error message=(\"Fail to update Du\
ckDNS with new IP \".\$actualIP);};\r\
\n};"
add dont-require-permissions=no name=/check owner=admin policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="/\
tool fetch url=\"https://api.telegram.org/bot{{{{{{{{{{{ ... ХХХХХХХХХХ\
UmbwIi2rIzOw5fGgc/sendMessage\\\?chat_id=-{{{{{{{{{{{{{{&text=DOWN\" keep-resul\
t=no"
add dont-require-permissions=no name=/2portoff owner=admin policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="/\
interface disable ether2\r\
\n/tool fetch url=\"https://api.telegram.org/bot5426303532:{{{{{{{{{{{{{{\
aWvUmbwIi2rIzOw5fGgc/sendMessage\\\?chat_id=-{{{{{{{{{{{{{{&text=ok-OFF\" keep-\
result=no"
add dont-require-permissions=no name=sysadmin owner=admin policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=":\
delay 15\r\
\n:global mtIdentity [/system identity get name];\r\
\n:global botID \"botrrrrrr:{{{{{{{{{{{{{{{{{{{\" ;\r\
\n:global myChatID \"-{{{{{{{{{{{{{{\" ;\r\
\n:local chatId 0;\r\
\n:local messageId 0;\r\
\n\r\
\n\r\
\n:local parse do={\r\
\n :local startLoc ([:find \$content \$variable -1] + [:len \$variable] +\
\_2);\r\
\n :local commaLoc ([:find \$content \",\" \$startLoc] - 1 + 1);\r\
\n :local braceLoc ([:find \$content \"}\" \$startLoc] - 1 + 1);\r\
\n :local endLoc \$commaLoc;\r\
\n :local startSymbol [:pick \$content \$startLoc]\r\
\n :if (\$braceLoc != 0 and (\$commaLoc = 0 or \$braceLoc < \$commaLoc)) \
do={\r\
\n :set endLoc \$braceLoc;\r\
\n };\r\
\n :if (\$startSymbol = \"{\") do={\r\
\n :set endLoc (\$braceLoc + 1);\r\
\n };\r\
\n :if (\$quotas = true) do={\r\
\n :set startLoc (\$startLoc + 1);\r\
\n :set endLoc (\$endLoc - 1);\r\
\n }\r\
\n :if (\$endLoc < \$startLoc) do={\r\
\n :set endLoc (\$startLoc + 1);\r\
\n };\r\
\n :local message [:pick \$content \$startLoc \$endLoc]\r\
\n #:log info \$message;\r\
\n :return \$message;\r\
\n}\r\
\n\r\
\n\r\
\n:while ( true ) do={\r\
\n :do {\r\
\n #:log info \"https://api.telegram.org/\$botID/getUpdates\\\?offset=\
\$messageId&limit=1&allowed_updates=message&timeout=60\";\r\
\n :tool fetch url=(\"https://api.telegram.org/\$botID/getUpdates\\\?of\
fset=\$messageId&limit=1&allowed_updates=message&timeout=60\") dst-path=\"\
getUpdates\";\r\
\n :local content [/file get [/file find name=getUpdates] contents] ;\r\
\n #:log info \$content;\r\
\n :if ([:len \$content] > 30) do={\r\
\n :set messageId ([\$parse content=\$content variable=\"update_id\"]\
\_+ 1)\r\
\n :local message [\$parse content=\$content variable=\"text\" quotas\
=true]\r\
\n :local chat [\$parse content=\$content variable=\"chat\"]\r\
\n :local chatId [\$parse content=\$chat variable=\"id\"] \r\
\n \r\
\n :if ((\$chatId = \$myChatID) and ([/system script find name=\$mess\
age] != \"\")) do={\r\
\n :system script run \$message;\r\
\n } else={\r\
\n :tool fetch url=(\"https://api.telegram.org/\$botID/sendmessage\
\\\?chat_id=\$chatId&text=\$mtIdentity: Unknown command: \$message\") keep\
-result=no\r\
\n }\r\
\n }\r\
\n } on-error={}\r\
\n};"
add dont-require-permissions=no name=/2porton owner=admin policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="/\
interface enable ether2\r\
\n/tool fetch url=\"https://api.telegram.org/bot{{{{{{{{{{{{{{{{{{{\
aWvUmbwIi2rIzOw5fGgc/sendMessage\\\?chat_id=-{{{{{{{{{{{{{{&text=ok-ON\" keep-r\
esult=no"
/system watchdog
set automatic-supout=no send-email-from=e@mailaddr send-email-to=\
e@mailaddr send-smtp-server=smtp.mail.ru watchdog-timer=no
/tool bandwidth-server
set authenticate=no
/tool e-mail
set address=smtp.mail.ru from=e@mailaddr port=465 tls=yes user=gatall
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
/tool netwatch
add disabled=yes down-script="tool e-mail send to=e@mailaddr subject=Remot\
eD_LOST body=Connection_LOST" host=192.168.88.1 interval=10m timeout=5s \
type=simple
add disabled=no down-script="/tool fetch url=\"https://api.telegram.org/]\
wwwwww:ХХХХХХХХХХХХХХХХUmbwIi2rIzOw5fGgc/sendMessage\\\?chat_id=-wwwwww5\
877&text=VPN-Remote DOWN\"" host=192.168.88.1 http-codes="" interval=1m \
test-script="" timeout=5s type=simple up-script="/tool fetch url=\"https:/\
/api.telegram.org/bot5426303532:ХХХХХХХХХХХХХХХХUmbwIi2rIzOw5fGgc/sendMe\
ssage\\\?chat_id=-{{{{{{{{{{{{{{&text=VPN-Remote UP\""
add disabled=no down-script="/tool fetch url=\"https://api.telegram.org/botwwww\
wwwwwwww:ХХХХХХХХХХХХХХХХUmbwIi2rIzOw5fGgc/sendMessage\\\?chat_id=-686005\
877&text=VPN-FREE DOWN\"" host=192.168.100.1 http-codes="" interval=1m \
test-script="" timeout=5s type=simple up-script="/tool fetch url=\"https:/\
/api.telegram.org/bot5426303532:ХХХХХХХХХХХХХХХХUmbwIi2rIzOw5fGgc/sendMe\
ssage\\\?chat_id=-{{{{{{{{{{{{{{&text=VPN-FREE UP\""


xvo
Сообщения: 3429
Зарегистрирован: 25 фев 2018, 22:41
Откуда: Москва

Вчера, 22:19

gmx писал(а):
Вчера, 17:16
Да добейтесь вы работы ноутбука напрямую с нужным вам ip. И тогда все получится. Поймёте как это раьотает. Поставите коммутатор до микротика и все.
Коммутатор "до" тут никак не поможет.
Провайдер маршрутизирует подсеть через адрес, который сам выдает.


Telegram: @thexvo

Дома: [CCR1009-7G-1C-1S+] [CRS112-8P-4S-IN] [wAP ac] [RB260GS]
Не дома: [RB4011iGS+] [CRS326-24G-2S+RM] [wAP 60ad] [cAP ac]...
...[hEX] [hAP ac²] [hAP ac lite] [hAP mini] [RB260GS]
gatall
Сообщения: 9
Зарегистрирован: 06 окт 2022, 21:47

Вчера, 22:23

gmx писал(а):
Вчера, 17:16
Да добейтесь вы работы ноутбука напрямую с нужным вам ip. И тогда все получится. Поймёте как это раьотает. Поставите коммутатор до микротика и все.
Ноут в проводе получит адрес который должен быть шлюзом для выделенной подсети, и то не факт так как есть время аренды на mac 1го порта, а адрес такой же. (Сейчас его получает 1й порт микротика). Сейчас этим адресом и пользуюсь. Пока времени нет колупать снова.

К провайдеру нужно ходить через свой же 1 шлюз. А за ним 4 ip. Если эти 4 ip будут напрямую стучаться в шлюз провайдера это ничего не даст, так как там маршрут до этих 4ip через мой 1й, выданный по dhcp. У меня в конфиге (выше кинул) где-то ошибка, поэтому и не работает.
Завтра попробую поставить коммутатор перед микротиком в него вставить ноут и на нем прописать шлюзом 1й порт микротика, перенаправит ли микрот на шлюз провайдера...


Ответить