ip dhcp-server lease (block-access=yes)

Обсуждение ПО и его настройки
Ответить
rusic
Сообщения: 2
Зарегистрирован: 01 янв 2017, 09:52

04 янв 2017, 16:09

Комрады, помогите на своять два скрипта на добавление и удаление настройки block-access=yes в конфиге ip dhcp-server lease
Сам конфиг:

Код: Выделить всё

/ip dhcp-server lease
add address=192.168.88.253 block-access=yes comment=Roman mac-address=BC:F5:AC:D3:05:56 server=defconf
add address=192.168.88.252 block-access=yes comment=Planshet mac-address=00:11:7F:2C:D1:B4 server=defconf
Детям нужно интервал выдать для wi-fi.
Заранее спасибо.


Аватара пользователя
Vlad-2
Модератор
Сообщения: 1819
Зарегистрирован: 08 апр 2016, 19:19
Откуда: Петропавловск-Камчатский (п-ов Камчатка)
Контактная информация:

04 янв 2017, 17:28

Не совсем понял задачу (в полном контексте),
но не проще пойти другим путём: не блокировать адрес(а), пусть адрес получают, а
использовать разрешающее правило в файрволле/NAT закладках, под каждый айпи/блоков айпи/адрес-лист и это правило(а) (внутри этого правила) применить
параметр времени и управлять так доступом ?
А вообще - для гостей/детей в рамках домашнего применения делаю обычно отдельную виртуальную точку, с отдельной адресацией (отдельный DHCP) и уже
ограничиваю эту адресацию по скорости, режимам, и т.д., не трогая основную сеть.



На работе(ах): 2xCCR1016-12G, RB3011UiAS и hAP lite (RB941)
Дома: CCR1016-12G, RBcAP2n (standalone), RB wAP LTE kit
Для тестов(под рукой): RB3011UiAS, hAP mini (RB931) и что-то ещё по мелочи
MTCNA
MTCRE
Аватара пользователя
podarok66
Модератор
Сообщения: 3188
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

04 янв 2017, 19:17

Оформите ТЗ вразумительно. Когда должен сработать скрипт, какие параметры должны быть соблюдены, по каким признакам отыскиваем нужные машины, почему именно в dhcp-server lease? Вполне возможно, уже существует готовое решение.


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
Аватара пользователя
Dragon_Knight
Модератор
Сообщения: 1602
Зарегистрирован: 26 мар 2012, 18:21
Откуда: МО, Мытищи
Контактная информация:

05 янв 2017, 01:05

Я понял что человеку нужно отрубать Wi-Fi для конкретных пользователей (детей), по текущему времени (когда спать пора).



Помощь в ремонте и настройке оборудования MikroTik, Мытищи, Москва.
Дома: [RouterBOARD CCR1009-8G-1S-1S+] + [RouterBOARD cAP 2n] + [RouterBOARD Groove A-2Hn-32] + [D-Link ANT24-0800];
Работа 1: [RouterBOARD RB493G] + [MikroTik R52H] + [MikroTik CA493] + [D-Link ANT24-0800] + [RouterBOARD SXT G-2HnD];
Работа 2: [RouterBOARD RB2011UiAS-IN];
Резерв: [RouterBOARD RB450G];
Аватара пользователя
podarok66
Модератор
Сообщения: 3188
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

05 янв 2017, 12:56

И при чем здесь скрипты в Lease? Есть правила фаервола, в них просто замечательный параметр Time. Используя адрес-листы можем управлять доступом по времени без какого-либо напряга. На форуме была тема, года два-три назад. В ней все расписано просто до последнего.
На скорую рука нашел совсем давнишний свой пост:
реализация с временем проста до нельзя, надо лишь подумать немного. Временные рамки позволяют срабатывать правилу в определенный период суток (подчеркиваю, одних суток) Следовательно написание периода от 19:00 до 03:00 некорректно, так как он захватывает двое суток сразу. Допустим, Вам нужно запретить адрес-листу Black list ходить в сеть в будни всегда кроме периода 19:00-23:00, а в выходные не ставить ограничения.
Всего два правила, первое для будней запрещает от 00:00 до 19:00, второе для будней запрещает от 23:00 до 23:59:59:

Код: Выделить всё
/ip firewall filter
add action=drop chain=forward comment=Aliens dst-address-list="Black list" time=0s-19h,mon,tue,wed,thu,fri
add action=drop chain=forward comment=Aliens dst-address-list="Black list" time=23h-23h59m59s,mon,tue,wed,thu,fri

Ставим их выше разрешительных и все должно сработать.


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
rusic
Сообщения: 2
Зарегистрирован: 01 янв 2017, 09:52

05 янв 2017, 13:27

Dragon_Knight писал(а):Я понял что человеку нужно отрубать Wi-Fi для конкретных пользователей (детей), по текущему времени (когда спать пора).

Совершенно верно, в шедуллер хотел скрипты поместить.
to: podarok66 Щас попробую Ваш способ, спасибо.


Аватара пользователя
podarok66
Модератор
Сообщения: 3188
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

05 янв 2017, 14:35

Так же можно использовать Access-list в разделе Wireless. Заносим МАС-адреса всех домашних устройств в Access-list,снимаем галку Default Authenticate на своём WiFi-интерфейсе. Теперь к беспроводной сети смогут подключится только устройства из списка. Далее там же в Access-list открываем МАС-адреса детских устройств и меняем параметр Time в нужном нам диапазоне. Но тут немного меньше возможностей. Адрес-листами фаервола можно очень гибко регулировать доступ, это предпочтительный путь.


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
Аватара пользователя
Dragon_Knight
Модератор
Сообщения: 1602
Зарегистрирован: 26 мар 2012, 18:21
Откуда: МО, Мытищи
Контактная информация:

05 янв 2017, 16:13

rusic, как сказал podarok66 есть много способов, однако я сейчас пишу систему управления маршрутизаторами через telegram. Т.е. можно будет взяв обычный телефон выполнять скрипты на роутрерах отправляя команды, например:
/run home wifioff - Выполнит скрипт wifioff... и так далее.
Думаю через несколько дней будет публичный бетатест.



Помощь в ремонте и настройке оборудования MikroTik, Мытищи, Москва.
Дома: [RouterBOARD CCR1009-8G-1S-1S+] + [RouterBOARD cAP 2n] + [RouterBOARD Groove A-2Hn-32] + [D-Link ANT24-0800];
Работа 1: [RouterBOARD RB493G] + [MikroTik R52H] + [MikroTik CA493] + [D-Link ANT24-0800] + [RouterBOARD SXT G-2HnD];
Работа 2: [RouterBOARD RB2011UiAS-IN];
Резерв: [RouterBOARD RB450G];
Hanebauer
Сообщения: 1
Зарегистрирован: 11 янв 2019, 11:23

11 янв 2019, 11:24

Доброго дня, а уже вышел бетатест?
Dragon_Knight писал(а):
05 янв 2017, 16:13
rusic, как сказал podarok66 есть много способов, однако я сейчас пишу систему управления маршрутизаторами через telegram. Т.е. можно будет взяв обычный телефон выполнять скрипты на роутрерах отправляя команды, например:
/run home wifioff - Выполнит скрипт wifioff... и так далее.
Думаю через несколько дней будет публичный бетатест.


Ответить