MESH сеть. Правила построения.

Обсуждение оборудования и его настройки
АлексейСПб
Сообщения: 49
Зарегистрирован: 16 фев 2013, 13:03

15 июн 2013, 12:34

Всем добрый день!
Прошу помощи.

Объясните мне, пожалуйста, правило построения MESH Сети.

Имеем:

Центральный узел: Mikrotik RB 951G 2Hnd

К нему подлючены два SXT.
После SXT, непосредственно в доме, стоят еще три штуки RB 951G 2Hnd. Все они объеденены в MESH.

Так вот, периодически, вся сеть в доме отваливается от центрального узла, и оживает только после перезагрузки принимающего SXT.

Чувствую я где-то накосячил в настройках.

Наверное, MESH должен быть созднан на центральном RB 951G 2Hnd, а все остальные железки должны являться клиентами? (В том числе, наверное, и SXT).

Вопрос:
Что настраивается на центральном узле?
И что настраивается на клиентах?

Сейчас на центральном настроено:
Ethernet 1 - WAN порт с статическим ИП от провайдера.
В бридж добавлены все остальные Ethernet порты и WLAN.
DHCP.
NAT.
Firewall.


gmx
Модератор
Сообщения: 2560
Зарегистрирован: 01 окт 2012, 14:48

15 июн 2013, 20:28

Я еще в прошлой вашей теме писал: SXT в MESH объединять точно не нужно.

Хотелось бы увидеть настройки обоих(!) SXT.

И самое простое: не может быть у вас петель? одинаковых IP? другого WiFi оборудования вещающего сеть с таким же именем?


АлексейСПб
Сообщения: 49
Зарегистрирован: 16 фев 2013, 13:03

16 июн 2013, 11:05

gmx писал(а):Я еще в прошлой вашей теме писал: SXT в MESH объединять точно не нужно.

Хотелось бы увидеть настройки обоих(!) SXT.

И самое простое: не может быть у вас петель? одинаковых IP? другого WiFi оборудования вещающего сеть с таким же именем?


Добрый день!

Да нет, петель нету, каждой железке присвоен свой IP.
В доме репитеров нет, стоят только три RB 951G 2Hnd, на них сеть естественно назывется одинаково :)
Последний раз редактировалось АлексейСПб 16 июн 2013, 11:41, всего редактировалось 1 раз.


АлексейСПб
Сообщения: 49
Зарегистрирован: 16 фев 2013, 13:03

16 июн 2013, 11:40

Передатчик.

# jan/03/1970 19:04:43 by RouterOS 5.25
# software id = Q8AQ-9GXL
#
/interface bridge
add l2mtu=1600 name=SXT_1_Out_Bridge protocol-mode=rstp
/interface wireless
set 0 band=5ghz-onlyn basic-rates-a/g="" channel-width=20/40mhz-ht-above \
disabled=no ht-rxchains=0,1 ht-txchains=0,1 hw-protection-mode=rts-cts \
hw-retries=15 l2mtu=2290 mode=bridge name=SXT_1_Out periodic-calibration=\
enabled periodic-calibration-interval=10 radio-name=SXT_1_Out rate-set=\
configured supported-rates-a/g="" tdma-period-size=1 wds-default-bridge=\
SXT_1_Out_Bridge wds-mode=dynamic-mesh wireless-protocol=nv2
/interface wireless nstreme
set SXT_1_Out disable-csma=yes enable-nstreme=yes framer-policy=dynamic-size
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/interface bridge port
add bridge=SXT_1_Out_Bridge interface=ether1
add bridge=SXT_1_Out_Bridge interface=SXT_1_Out
/ip address
add address=192.168.88.2/24 interface=ether1
/ip dhcp-client
add disabled=no interface=SXT_1_Out_Bridge
/ip dns
set max-udp-packet-size=512
/system identity
set name=SXT_1_Out
/system leds
set 0 interface=SXT_1_Out
/tool mac-server
add disabled=no


АлексейСПб
Сообщения: 49
Зарегистрирован: 16 фев 2013, 13:03

16 июн 2013, 11:40

Приемник.

# jan/03/1970 18:23:42 by RouterOS 5.25
# software id = 0E4Q-BK94
#
/interface bridge
add l2mtu=1600 name=bridge1 protocol-mode=rstp
/interface wireless
set 0 band=5ghz-onlyn basic-rates-a/g="" channel-width=20/40mhz-ht-above \
disabled=no ht-rxchains=0,1 ht-txchains=0,1 hw-protection-mode=rts-cts \
hw-retries=15 l2mtu=2290 mode=station-wds name=SXT_2_In \
periodic-calibration=enabled periodic-calibration-interval=10 rate-set=\
configured ssid=SXT_1_Out supported-rates-a/g="" wds-default-bridge=\
bridge1 wds-mode=dynamic-mesh wireless-protocol=nv2
/interface wireless nstreme
set SXT_2_In enable-nstreme=yes
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=SXT_2_In
/ip address
add address=192.168.88.3/24 interface=ether1
/ip dhcp-client
add disabled=no interface=bridge1
/ip route
add disabled=yes distance=1 gateway=192.168.88.1
/system identity
set name=SXT_2_In
/system leds
set 0 interface=SXT_2_In


АлексейСПб
Сообщения: 49
Зарегистрирован: 16 фев 2013, 13:03

16 июн 2013, 11:50

Это настройки центрального RB 951G.

# jan/02/1970 00:01:05 by RouterOS 5.25
# software id = FWC1-XL0L
#
/interface bridge
add l2mtu=1598 name=Bridge_Local
/interface wireless
set 0 band=2ghz-onlyn basic-rates-b="" disabled=no frequency=2422 \
frequency-mode=superchannel ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 \
mode=ap-bridge radio-name=Main_Wireless rate-set=configured ssid=\
Bublik_Outside supported-rates-b=""
/interface ethernet
set 0 comment=WAN
set 1 comment=LAN
set 2 master-port=ether2
set 3 master-port=ether2
set 4 master-port=ether2
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods=\
passthrough group-ciphers=tkip,aes-ccm mode=dynamic-keys \
supplicant-identity=MikroTik unicast-ciphers=tkip,aes-ccm \
wpa-pre-shared-key=******** wpa2-pre-shared-key=********
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/ip pool
add name=dhcp_pool1 ranges=192.168.88.2-192.168.88.254
add name=dhcp_pool2 ranges=192.168.88.2-192.168.88.254
add name=dhcp_pool3 ranges=192.168.88.2-192.168.88.254
add name=dhcp_pool4 ranges=192.168.88.2-192.168.88.254
add name=dhcp_pool5 ranges=192.168.88.7-192.168.88.254
add name=dhcp_pool6 ranges=192.168.88.2-192.168.88.254
/ip dhcp-server
add address-pool=dhcp_pool6 disabled=no interface=Bridge_Local name=dhcp1
/interface bridge port
add bridge=Bridge_Local interface=ether2
add bridge=Bridge_Local interface=wlan1
/ip address
add address=37.28.163.98/30 interface=ether1
add address=192.168.88.1/24 interface=Bridge_Local
/ip dhcp-server network
add address=192.168.88.0/24 gateway=192.168.88.1
/ip dns
set servers=83.149.6.4,83.149.6.12
/ip firewall nat
add action=masquerade chain=srcnat comment="Added by webbox" out-interface=\
ether1 to-addresses=0.0.0.0
/ip neighbor discovery
set wlan1 disabled=yes
/ip route
add check-gateway=ping distance=1 gateway=37.28.163.97
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
/ip upnp
set allow-disable-external-interface=no enabled=yes
/ip upnp interfaces
add interface=ether1 type=external
add interface=ether2 type=internal
add interface=ether3 type=internal
add interface=ether4 type=internal
add interface=ether5 type=internal
add interface=wlan1 type=internal
add interface=Bridge_Local type=internal
/system identity
set name=951G_OutSide
/system leds
set 0 interface=wlan1
Последний раз редактировалось АлексейСПб 16 июн 2013, 15:57, всего редактировалось 1 раз.


АлексейСПб
Сообщения: 49
Зарегистрирован: 16 фев 2013, 13:03

16 июн 2013, 11:53

Это один из RB 951 в доме, у них у всех конфиги одинаковые.

# jan/11/1970 01:14:58 by RouterOS 5.25
# software id = BTK0-Z17F
#
/interface mesh
add name=Mesh
/interface wireless
set 0 band=2ghz-onlyn basic-rates-b="" default-authentication=no disabled=no \
frequency=2422 ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=ap-bridge \
radio-name=Mesh_2 rate-set=configured ssid=Bublik supported-rates-b="" \
wds-default-bridge=Mesh wds-mode=static-mesh
/interface wireless wds
add master-interface=wlan1 name=wds1 wds-address=D4:CA:6D:6D:83:C7
add master-interface=wlan1 name=wds2 wds-address=D4:CA:6D:7C:D2:83
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods=\
passthrough group-ciphers=tkip,aes-ccm mode=dynamic-keys \
supplicant-identity=MikroTik unicast-ciphers=tkip,aes-ccm \
wpa-pre-shared-key=******** wpa2-pre-shared-key=********
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/interface mesh port
add interface=wlan1 mesh=Mesh
add interface=wds1 mesh=Mesh
add interface=wds2 mesh=Mesh
add interface=ether1 mesh=Mesh
add interface=ether2 mesh=Mesh
add interface=ether3 mesh=Mesh
add interface=ether4 mesh=Mesh
add interface=ether5 mesh=Mesh
/interface wireless access-list
add signal-range=-75
/interface wireless connect-list
add interface=wlan1 security-profile=default
/ip address
add address=192.168.88.6/24 interface=Mesh
/ip dns
set servers=192.168.88.1,83.149.6.4,83.149.6.12
/ip neighbor discovery
set wlan1 disabled=yes
/ip route
add distance=1 gateway=192.168.88.1
/system identity
set name=Main_BedRoom
/system leds
set 0 interface=wlan1
Последний раз редактировалось АлексейСПб 16 июн 2013, 15:57, всего редактировалось 1 раз.


АлексейСПб
Сообщения: 49
Зарегистрирован: 16 фев 2013, 13:03

16 июн 2013, 11:54

Те что стоят в доме соеденены кабелем, соответственно WDS сознан, но деактивирован.


gmx
Модератор
Сообщения: 2560
Зарегистрирован: 01 окт 2012, 14:48

16 июн 2013, 19:20

Предлагаю мост настроить вот так
http://www.lanmart.ru/blogs/mikrotik-sextant-bridge/

и еще, как часто все зависает???
может просто ватчдог настроить??? если не очень часто.

У меня два моста по инструкции выше работают неделями без перезагрузок.


АлексейСПб
Сообщения: 49
Зарегистрирован: 16 фев 2013, 13:03

16 июн 2013, 22:41

gmx писал(а):Предлагаю мост настроить вот так
http://www.lanmart.ru/blogs/mikrotik-sextant-bridge/

и еще, как часто все зависает???
может просто ватчдог настроить??? если не очень часто.

У меня два моста по инструкции выше работают неделями без перезагрузок.


Т.е. остальное настроено правильно?
Да в том-то и дело, что они не зависают, а отваливается вся сеть за SXT (приемником), и как только его перезапустишь, всё оживает.
Да нет, не часто, примерно раз в неделю, но блин неожиданно :)


Ответить