Выбор строк посредством find по маске

Обсуждение ПО и его настройки
Ответить
rstaganrog
Сообщения: 24
Зарегистрирован: 26 май 2013, 19:02

11 июн 2013, 12:51

Предположим имеются правила:

Код: Выделить всё

/queue type add kind=pcq name=GROUP-A-DL ...
/queue type add kind=pcq name=GROUP-B-DL ...


Можно удалить эти правила так:

Код: Выделить всё

foreach i in [/queue type find name="GROUP-A-DL"] do={[/queue type remove $i]}
foreach i in [/queue type find name="GROUP-B-DL"] do={[/queue type remove $i]}


А можно ли удалить правила по маске, что-то типа такого:

Код: Выделить всё

foreach i in [/queue type find name="GROUP-*-DL"] do={[/queue type remove $i]}

?


Аватара пользователя
simpl3x
Модератор
Сообщения: 1532
Зарегистрирован: 19 апр 2012, 14:03

11 июн 2013, 13:26

изучайте регулярные выражения:
http://wiki.mikrotik.com/wiki/Manual:Sc ... _Operators

“~”
binary operator that matches value against POSIX extended regular expression
Print all routes which gateway ends with 202

Код: Выделить всё

/ip route print where gateway~"^[0-9 \\.]*202"


rstaganrog
Сообщения: 24
Зарегистрирован: 26 май 2013, 19:02

14 июн 2013, 08:42

simpl3x писал(а):изучайте регулярные выражения

Спасибо.


Ответить