BR751U-2HnD и WiFi клиенты или бесконечное "подключение..."

Обсуждение ПО и его настройки
stslit
Сообщения: 10
Зарегистрирован: 22 сен 2012, 14:44

29 май 2013, 21:19

Доброго дня.

Роутер нормально работал пока не понадобился WiFi. На сайте много инструкций, да и на сторонних ресурсах их тоже не мало, но вот не задача.
При подключении девайса по WiFi спрашивает пароль, а после бесконечное состояние "подключение...".
Пробовал разные варианты. На ответа не нашел.
Прошу помогите разобраться с проблемой.


Аватара пользователя
simpl3x
Модератор
Сообщения: 1532
Зарегистрирован: 19 апр 2012, 14:03

29 май 2013, 21:23

ну показывайте настройки адресов, бриджа, dhcp сервера.


gmx
Сообщения: 2317
Зарегистрирован: 01 окт 2012, 14:48

30 май 2013, 07:37

А еще такая фигня на Win XP с некоторыми драйверами WiFi модулей происходит. При этом адрес получается и инет на компе есть, а в статусе постоянно светится "подключение". Помогает следующее: отключить WiFi и снова его включить средствами Win, не перезагружая комп. У меня дома нетбук старый так себя ведет со встроенным адаптером, а ставлю Tp-Link Nano со свежими драйверами и больше такого не наблюдается.


ЗЫ. Я бы еще на микротике посмотрел IP-DHCP Server-Leases. Вполне возможно, что комп там появляется.


stslit
Сообщения: 10
Зарегистрирован: 22 сен 2012, 14:44

30 май 2013, 07:38

Извиняюсь, надо было сразу догадаться:
interface export compact
 

Код: Выделить всё

# jan/02/1970 00:19:02 by RouterOS 6.0rc7
# software id = GEFU-ZLVY
#
/interface bridge
add l2mtu=1598 name=bridge1
/interface ethernet
set 0 l2mtu=1450 mtu=1450
/interface pptp-client
add add-default-route=yes connect-to=10.0.1.1 disabled=no name=pptp-out1 \
    password=***user=***
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods=\
    passthrough group-ciphers=tkip,aes-ccm unicast-ciphers=tkip,aes-ccm \
    wpa-pre-shared-key=***wpa2-pre-shared-key=***
add authentication-types=wpa-psk,wpa2-psk eap-methods=passthrough \
    group-ciphers=tkip,aes-ccm mode=dynamic-keys name=profile1 \
    supplicant-identity="" unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=\
    ***wpa2-pre-shared-key=***
/interface wireless
set 0 band=2ghz-b/g/n channel-width=20/40mhz-ht-below default-authentication=\
    no disabled=no frequency-mode=superchannel ht-rxchains=0,1 ht-txchains=\
    0,1 hw-protection-mode=rts-cts hw-retries=15 l2mtu=2290 mode=ap-bridge \
    periodic-calibration=enabled periodic-calibration-interval=10 radio-name=\
    "" security-profile=profile1 wds-default-bridge=bridge1 \
    wireless-protocol=802.11
/interface wireless nstreme
set wlan1 enable-polling=no
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan1
add bridge=bridge1 disabled=yes interface=ether1
/interface l2tp-server server
set max-mru=1450 max-mtu=1450
/interface pptp-server server
set max-mru=1450 max-mtu=1450

ip route print
 

Код: Выделить всё

 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADS  0.0.0.0/0                          176.113.8.1               1
 1 A S  10.0.0.0/8                         10.25.7.1                15
 2 ADC  10.25.7.0/24       10.25.7.10      ether1                    0
 3 A S  172.21.0.0/16                      10.25.7.1                10
 4 ADC  176.113.8.1/32     176.113.9.226   pptp-out1                 0
 5 ADC  192.168.0.0/24     192.168.0.1     bridge1                   0
 6 ADC  192.168.2.1/32     192.168.2.1     bridge1                   0


2 gmx
Железок под XP нет. Проверялось на андроиде 4, Amazon kindle, Win 7. Результат одинаковый.
В клиентах ничего не появляется
Последний раз редактировалось stslit 30 май 2013, 07:49, всего редактировалось 1 раз.


gmx
Сообщения: 2317
Зарегистрирован: 01 окт 2012, 14:48

30 май 2013, 07:43

Я бы начал с:

использовать для авторизации только PSK2
и метод AES, TKIP отключить


И где настройки DHCP в тех настройках, которые вы запостили???
И вообще DHCP Server настроен?


Аватара пользователя
simpl3x
Модератор
Сообщения: 1532
Зарегистрирован: 19 апр 2012, 14:03

30 май 2013, 07:51

а еще:

Код: Выделить всё

default-authentication=no

но при этом не вижу чтобы были какие то записи в access list, т.е. получается что к вашему вафай вообще никто не подключится.
вообще, хорошее правило, если не знаешь что тыкаешь, помни о том, что есть кнопка Reset Configuration в интерфейсе вафли.


stslit
Сообщения: 10
Зарегистрирован: 22 сен 2012, 14:44

30 май 2013, 08:24

DHCP включен, иначе проводные клиенты не подключались бы.

Код: Выделить всё

 #   NAME       INTERFACE      RELAY           AD
 0   dhcp1      bridge1                        dh


2 simpl3x
Пароль был отключен для проверки подключения.

Спасибо simpl3x, всё подключилось
помогла строка из мануала:

Код: Выделить всё

 
/interface wireless set wlan1 default-authentication=no


Но где это строка в интерфейсе? И почему пароль спрашивала и не подключалось?
Странно.

P.S.
И ещё странно, такое ощущение что кто то ломиться из вне на роутер:

Код: Выделить всё

jan/02/1970 00:57:00 system,error,critical login failure for user root from 112.65
.244.94 via ssh
jan/02/1970 00:57:03 system,error,critical login failure for user root from 112.65
.244.94 via ssh
jan/02/1970 00:57:05 system,error,critical login failure for user root from 112.65
.244.94 via ssh
jan/02/1970 00:57:09 system,error,critical login failure for user root from 112.65
.244.94 via ssh
jan/02/1970 00:57:16 system,error,critical login failure for user root from 112.65
.244.94 via ssh
Последний раз редактировалось stslit 30 май 2013, 08:45, всего редактировалось 1 раз.


Аватара пользователя
simpl3x
Модератор
Сообщения: 1532
Зарегистрирован: 19 апр 2012, 14:03

30 май 2013, 08:44

default-authentication (yes | no; Default: yes)
For AP mode, this is the value of authentication for clients that do not match any entry in the access-list. For station mode, this is the value of connect for APs that do not match any entry in the connect-list

опция никаким образом не связана с паролем. Если опция стоит в no, то клиент не подключится если его нет в access-list

еще, у вас настроены, n-режим, с 40 мгц полосы и chain=1,2 - у меня например при таких настройках мобильные устройства не хотят работать, только уже не помню, какой из этих параметров не нравится им. попробуйте выставить в b\g и 20 мгц.


stslit
Сообщения: 10
Зарегистрирован: 22 сен 2012, 14:44

30 май 2013, 10:22

Спасибо, поправлено.

simpl3x писал(а):default-authentication (yes | no; Default: yes)

Вопрос про то, где в графическом интерфейсе эта опция?


gmx
Сообщения: 2317
Зарегистрирован: 01 окт 2012, 14:48

30 май 2013, 10:58

stslit писал(а):P.S.
И ещё странно, такое ощущение что кто то ломиться из вне на роутер:

Код: Выделить всё

jan/02/1970 00:57:00 system,error,critical login failure for user root from 112.65
.244.94 via ssh
jan/02/1970 00:57:03 system,error,critical login failure for user root from 112.65
.244.94 via ssh
jan/02/1970 00:57:05 system,error,critical login failure for user root from 112.65
.244.94 via ssh
jan/02/1970 00:57:09 system,error,critical login failure for user root from 112.65
.244.94 via ssh
jan/02/1970 00:57:16 system,error,critical login failure for user root from 112.65
.244.94 via ssh


Все время ломятся. Пароль подлиннее и посложнее и отключить нежные сервисы в
IP-Services.


Ответить