2 Mikrotik и pptp

Обсуждение ПО и его настройки
Ответить
master2sid2
Сообщения: 9
Зарегистрирован: 01 фев 2013, 14:59

21 фев 2013, 15:24

Есть два офиса, в двух офисах стоят микротики RB750gl, на одном из них поднять pptp сервер и второй подключается к нему через pptp client. Соединение проходит нормально и роутеры между собой пингуються, но при попытке пропинговать сеть за роутером тонечего не пингуеться. На роутере с pptp сервером на LAN интерфейсе ARP указ proxy-arp
сеть на обоих роутерах 192.168.2.0/24, сеть для pptp 192.168.3.0/24.
Что нужно сделать чтоб пошли пинги между офисами?


Аватара пользователя
podarok66
Модератор
Сообщения: 3852
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

21 фев 2013, 21:03

Наверное, можно поднять EoIP туннель поверх PPTP и все должно заработать. Во всяком случае, у меня работает. На каждом роутере есть свой канал интернета, и поднят свой DHCP-server. Каждый из роутеров имеет свою часть адресов от сети 192.168.2.0/24 , ограниченную пулом. Скажем для одного роутера это пул 192.168.2.2-192.168.2.100 и DNS-server 192.168.2.1, а для другого пул 192.168.2.102-192.168.2.200 и DNS-server 192.168.2.101.
Роутер с сервером (предположительно, его адрес в рртр 192.168.3.1):
Вешаем на него EoIP:

Код: Выделить всё

/interface eoip add name=eoiptunnel remote-address=192.168.3.2 disabled=no

Засовываем его в бридж с нашей локалкой

Код: Выделить всё

/interface bridge port add bridge=bridge1 interface=eoiptunnel

Решаем проблему раздачи адресов, пусть юзеры адреса получают только от своего DHCP-сервера (нашел здесь, на форуме):

Код: Выделить всё

/interface bridge filter add action=drop chain=forward dst-port=67 ip-protocol=udp mac-protocol=ip disabled=no comment="Drop all DHCP requests over EoIP bridge"

Роутер с клиентом (предположительно, его адрес в рртр 192.168.3.2):
Вешаем на него EoIP:

Код: Выделить всё

/interface eoip add name=eoiptunnel remote-address=192.168.3.1 disabled=no

Засовываем его в бридж с нашей локалкой:

Код: Выделить всё

/interface bridge port add bridge=bridge1 interface=eoiptunnel

Решаем проблему раздачи адресов, пусть юзеры адреса получают только от своего DHCP-сервера:

Код: Выделить всё

/interface bridge filter add action=drop chain=forward dst-port=67 ip-protocol=udp mac-protocol=ip disabled=no comment="Drop all DHCP requests over EoIP bridge"

В итоге все компьютеры в сети видят друг друга в сетевом окружении, но получают адреса и ходят в интернет каждый через свой роутер.


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
master2sid2
Сообщения: 9
Зарегистрирован: 01 фев 2013, 14:59

22 фев 2013, 10:45

Огромное спасибо, EoIP поверх PPTP прокатило. :D


Ответить