Отвал портов после перезагрузки

Обсуждение ПО, его настройка и функционал
Ответить
N3RO
Сообщения: 8
Зарегистрирован: 12 июн 2018, 23:12

27 ноя 2021, 20:21

Доброго времени суток! Имеется Mikrotik RB4011iGS+

Проблема следующая: после перезагрузки вышеуказанного роутера (из за отключение электричества например или перезагрузки вручную) не поднимаются некоторые порты. Точнее поднимаются, но на скорости в 10 мегабит с заявлением о том, что автосогласование скорости не прошло. RX трафик на этих злополучных портах лежит в 0, а TX отправляется. Такое поведение у 3 портов из 10. Тобеж порты будто зависают и не отправляют RX трафик. Помогает лишь отключение\включение порта, после чего он отлично работает до следующей перезагрузки устройства...

Что было опробовано:
1. Меняли оборудование подключенное к этим портам
2. Меняли настройки портов, выставляя в ручную скорость и прочие параметры
3. Сбрасывали конфигурацию роутера
4. Отшивали роутер нетистиллом
5. Плясали с бубном и молились
Не помогает ничего!
Единственное решение, это после очередной перезагрузки роутера, руками тыкать по этим портам disable а затем enable. Тоесть выполнять банальное выключение и включение порта.

Есть ли кого какие идеи относительно моей проблемы?
Либо, может ли кто-нибудь написать банальный скрипт, который будет выключать и через секунду включать порт после перезагрузки Микротика (я нуб в скриптах, поэтому самостоятельно гуглил да недогуглил).

Заранее, весьма благодарен всем откликнувшимся на мою проблему!


Аватара пользователя
podarok66
Модератор
Сообщения: 4337
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

28 ноя 2021, 11:03

В шедулере выставляем параметр Start Time равным startup, в тело шедулера вписываем скрипт типа:

Код: Выделить всё

:delay 5; 
/interface ethernet set ether2 disabled=yes; 
:delay 5; 
/interface ethernet set ether2 disabled=no
Через 5 секунд после старта указанный интерфейс выключится, ещё через 5 включится.


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
N3RO
Сообщения: 8
Зарегистрирован: 12 июн 2018, 23:12

28 ноя 2021, 11:57

podarok66 писал(а):
28 ноя 2021, 11:03
В шедулере выставляем параметр Start Time равным startup, в тело шедулера вписываем скрипт типа:

Код: Выделить всё

:delay 5; 
/interface ethernet set ether2 disabled=yes; 
:delay 5; 
/interface ethernet set ether2 disabled=no
Через 5 секунд после старта указанный интерфейс выключится, ещё через 5 включится.
Спасибо! :-):


Mareritt
Сообщения: 1
Зарегистрирован: 21 окт 2023, 04:00

21 окт 2023, 04:27

Спасибо огромное, парни, очень помогли :3


Ответить