Как реализовать постоянную смену ip адресов клиентов?

Обсуждение оборудования и его настройки
vqd
Модератор
Сообщения: 3868
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

Re: Как реализовать постоянную смену ip адресов клиентов?

Сообщение vqd » 02 апр 2014, 16:51

создаете маршрут и маркируете его, в рулес говорите что нужные вам соединения отправлять только через маркированный маршрут
Есть интересная задача и бюджет? http://mikrotik.site
Аватара пользователя
pubuser
Сообщения: 73
Зарегистрирован: 14 мар 2014, 18:14

Re: Как реализовать постоянную смену ip адресов клиентов?

Сообщение pubuser » 02 апр 2014, 16:56

Чтож, попробую сделать так чтобы шлюз стучался только на нужный интерфейс. Поможет надеюсь.
Аватара пользователя
pubuser
Сообщения: 73
Зарегистрирован: 14 мар 2014, 18:14

Re: Как реализовать постоянную смену ip адресов клиентов?

Сообщение pubuser » 04 апр 2014, 13:16

Добавил в ip-Firewall-mangle правило Prerouting, для ip адреса шлюза. В роутах явно указал, через какой интерфейс доступен ip адрес sip сервера, routing mark указал правило прероутинга из Mangle. в Routes / Policy так же добавил правило. Результата нет, все равно после обрыва PPTP ошибка регистрации шлюза( Что можно еще предпринять, посоветуйте?
vqd
Модератор
Сообщения: 3868
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

Re: Как реализовать постоянную смену ip адресов клиентов?

Сообщение vqd » 04 апр 2014, 13:18

Правила покажите которые сделали
Есть интересная задача и бюджет? http://mikrotik.site
Аватара пользователя
pubuser
Сообщения: 73
Зарегистрирован: 14 мар 2014, 18:14

Re: Как реализовать постоянную смену ip адресов клиентов?

Сообщение pubuser » 05 апр 2014, 12:10

Сперва сделал так:

/ip firewall mangle add chain=prerouting src-address=192.168.2.50 action=mark-routing \
new-routing-mark=sip passthrough=no

192.168.2.50 это ip голосового шлюза.

далее в ip/routes руками добавил правило, чтобы трафик с голосового шлюза уходил на ip адрес sip сервера согласно routing mark,

/ip route add dst-address=192.168.5.18 gateway=pptp-out routing mark=sip

В роутах была всего 1 статичная запись, для всей сетки 192.168.5.0/24 со шлюзом pptp-out, чтобы все хосты этой подсети были доступны. В /ip route Rules добавил правило: src-address=192.168.2.30 dst-address=192.168.5.18 routing mark=sip interface=pptp-out action=lookup table=sip

Ничего из этого не помогло, может где то ошибку допустил?
vqd
Модератор
Сообщения: 3868
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

Re: Как реализовать постоянную смену ip адресов клиентов?

Сообщение vqd » 06 апр 2014, 08:33

Прочитайте внимательно то что я вам написал, а потом прочитайте ваши правила и вы поймете в чем ошибки
Есть интересная задача и бюджет? http://mikrotik.site

Вернуться в «MikroTik RouterBOARD»

Кто сейчас на конференции

Сейчас этот форум просматривают: andreyD, Erik_U и 1 гость