no route to host 8.8.8.8

Обсуждение оборудования и его настройки
Ответить
madvovik
Сообщения: 1
Зарегистрирован: 26 июн 2017, 22:52

22 янв 2023, 17:04

Привет, всем есть проблема с гугловским днс 8.8.8.8 и только им, немного предистории, переезжали на новій ДЦ, перенесли все настройки со страого, из изменений только шлюз провайдера, 3 внешних адреса на одном порту с одним шлюзом, есть манглы что бы пакеты маркировались по айпишнику, была изначально проблема что не работали некотоыре сайты, долго курил проблему, на одном из форумов вычитал что есть у некоторых провайдеров проблема с MTU, провайдер сказал в свою очередь что проблема у вас не у нас, пришлось фиксить на своей стороне таким образом

Код: Выделить всё

17    ;;; fix trouble with opening some sites
      chain=forward action=change-mss new-mss=clamp-to-pmtu passthrough=no 
      tcp-flags=syn protocol=tcp out-interface=ether1 tcp-mss=1300-65535 log=no 
      log-prefix="" 

18    ;;; fix trouble with opening some sites
      chain=forward action=change-mss new-mss=clamp-to-pmtu passthrough=no 
      tcp-flags=syn protocol=tcp in-interface=ether1 tcp-mss=1300-65535 log=no 
      log-prefix="" 
проблема ушла, после чего начал решать проблему с днс 8.8.8.8, она біла и до фикса MTU и после, все время пишет при пингах и трассировке no route to host, при том что 8.8.4.4 и 1.1.1.1 работают без проблем, вроде ничего критичного но не понятно какого лешего, техподдержка провайдера пробовала затестить 1 наш айпи на своем оборудовании и у них таких проблем нет, следовательно что-то в микроте, но что именно не так вкурить не могу, по роутам кидаю листинг

Код: Выделить всё

/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=45.154.хх.хх pref-src="" routing-table=main scope=30 \
    suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=yes distance=1 dst-address=77.88.хх.хх/24 gateway=172.16.10.1 pref-src="" \
    routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=no distance=1 dst-address=192.168.3.0/24 gateway=10.0.49.11 \
    routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=no distance=1 dst-address=192.168.6.0/24 gateway=10.0.49.14 \
    routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=no distance=1 dst-address=192.168.7.0/24 gateway=10.0.49.15 \
    routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=no distance=1 dst-address=192.168.8.0/24 gateway=10.0.49.16 \
    routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=no distance=1 dst-address=192.168.9.0/24 gateway=10.0.49.17 \
    routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=no distance=1 dst-address=192.168.10.0/24 gateway=10.0.49.18 \
    routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=no distance=1 dst-address=192.168.12.0/24 gateway=10.0.49.20 \
    routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=no distance=1 dst-address=192.168.13.0/24 gateway=\
    192.168.5.172 pref-src=0.0.0.0 routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment="*********" disabled=no distance=1 dst-address=192.168.15.0/24 gateway=\
    172.22.22.2 pref-src="" routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=yes distance=1 dst-address=213.180.хх.хх/32 gateway=\
    172.16.10.1 pref-src="" routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=yes distance=1 dst-address=213.180.204.242/32 gateway=\
    172.16.10.1 pref-src="" routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=45.154.хх.хх pref-src="" \
    routing-table=ISP1-Route scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=45.154.хх.хх pref-src="" \
    routing-table=ISP2-Route scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=45.154.хх.хх pref-src="" \
    routing-table=ISP3-Route scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=172.16.10.1 pref-src="" \
    routing-table=Yandex-Route scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=yes distance=1 dst-address=5.255.хх.хх/24 gateway=\
    172.16.10.1 pref-src="" routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=yes distance=1 dst-address=77.88.хх.хх/24 gateway=\
    172.16.10.1 pref-src="" routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=no distance=1 dst-address=192.168.88.0/24 gateway=172.22.23.2 \
    pref-src="" routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=no distance=1 dst-address=192.168.2.0/24 gateway=10.0.49.12 \
    pref-src="" routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping comment=********* disabled=yes distance=1 dst-address=193.200.хх.хх/32 gateway=45.154.хх.хх \
    pref-src=45.154.116.xx routing-table=main scope=30 suppress-hw-offload=no target-scope=10


Ответить