Настройка отправки Email

Обсуждение оборудования и его настройки
Ответить
1aleks23
Сообщения: 19
Зарегистрирован: 18 сен 2018, 05:48

12 фев 2019, 08:10

Добрый день!

Настраиваю резервирования интернет канала(когда отваливается основной, переключаются на резерв). Проблема с настройко отправки письма на личгую почту, о том что канал переключился. Ошибка после запуска скрипта одна "timeout occured".
Сам скрипт:

Код: Выделить всё

/ip dns cache flush;
:local smtpserv [:resolve "smtp.yandex.ru"];

/tool e-mail send server=$smtpserv port=465 user= microtiKKMIAC@yandex.ru password=***** to="***** cc=("*****", "******") start-tls=yes from="MIKROTIK" \
subject="MikroTik: $[/system clock get date], $[/system clock get time]" \
body="Switching to the MAIN channel\nDate: $[/system clock get date]\nTime: $[/system clock get time]";
помогите разобраться, все уже перелазил ни чего не помогает.


KARaS'b
Сообщения: 852
Зарегистрирован: 29 сен 2011, 09:16

12 фев 2019, 10:28

Лично у меня яндекс работает по 587 порту


1aleks23
Сообщения: 19
Зарегистрирован: 18 сен 2018, 05:48

12 фев 2019, 11:08

KARaS'b писал(а):
12 фев 2019, 10:28
Лично у меня яндекс работает по 587 порту
Поставил порт 587 выдал ошибку "invalid from addres"


KARaS'b
Сообщения: 852
Зарегистрирован: 29 сен 2011, 09:16

12 фев 2019, 13:02

Сначала я настраивал саму возможность слать мыла в тулз

Код: Выделить всё

/tool e-mail
set address=smtp.yandex.ru from="Mikrotik RB4011 <mail@yandex.ru>" password=password port=587 start-tls=yes user=user
А потом уже отправляю письма вот таким примерно способом

Код: Выделить всё

/tool e-mail send to=mail@mail.ru subject="Gateway changed" body="Gateway changed to beeline"
И у меня все работает.
З.Ы. user должен быть без собаки, а from насколько я понял, обязательно содержать мыло отправителя.


1aleks23
Сообщения: 19
Зарегистрирован: 18 сен 2018, 05:48

12 фев 2019, 13:20

KARaS'b писал(а):
12 фев 2019, 13:02

Код: Выделить всё

/tool e-mail send to=mail@mail.ru subject="Gateway changed" body="Gateway changed to beeline"
И у меня все работает.
З.Ы. user должен быть без собаки, а from насколько я понял, обязательно содержать мыло отправителя.
subject и body это текст письма который будет отправляться в письме?

Попробовал поставил твой скрипт, результат тот же "timeout occured"


KARaS'b
Сообщения: 852
Зарегистрирован: 29 сен 2011, 09:16

12 фев 2019, 13:27

"Ну вы блин даете..."(с) Сабжект это тема письма, боди текст письма.
Для начала пробуйте на письмах без ваших изысканных переменных, просто что либо отправить, и без вот этого ":local smtpserv [:resolve "smtp.yandex.ru"];" которое должно быть просто забито в настройках e-mail как явное.


1aleks23
Сообщения: 19
Зарегистрирован: 18 сен 2018, 05:48

13 фев 2019, 04:26

KARaS'b писал(а):
12 фев 2019, 13:27
"Ну вы блин даете..."(с) Сабжект это тема письма, боди текст письма.
Для начала пробуйте на письмах без ваших изысканных переменных, просто что либо отправить, и без вот этого ":local smtpserv [:resolve "smtp.yandex.ru"];" которое должно быть просто забито в настройках e-mail как явное.
Как я понимаю проблема не в том что я как-то не правильно заполняю письмо, а в том что у меня микротик просто не может с сервером yandex связаться, поэтому и выдает ошибку в логах "timeout occured".


1aleks23
Сообщения: 19
Зарегистрирован: 18 сен 2018, 05:48

13 фев 2019, 08:27

Вообщем решил я свою проблему настройкой через gmail. Просто сменил почту.


Ответить