Use Access List (ACL) включение и выключение командой

Тут размещаем отчеты о готовых работающих решениях на оборудовании Mikrotik
Ответить
izhhome
Сообщения: 9
Зарегистрирован: 04 мар 2018, 19:33

26 авг 2018, 11:41

Всем добрый день
хочу сделать Scheduler включения и выключения доступа для wifi по ACL
посмотрел документацию https://wiki.mikrotik.com/wiki/Manual:I ... ccess_List
но так и не понял как с помощью команды включать и выключать ACL для wifi
плиз помогите разобраться


xvo
Сообщения: 236
Зарегистрирован: 25 фев 2018, 22:41

26 авг 2018, 12:18

Отдельной специальной команды "включающей" ACL нет: можно либо включать/выключать все правила в нем, либо повесить первым правило которое всё всем разрешает (или запрещает, в зависимости от задачи) и включать/выключать только его.


[CCR1009-7G-1C-1S+] [hEX] [wAP ac] [hAP ac²] [hAP mini]
izhhome
Сообщения: 9
Зарегистрирован: 04 мар 2018, 19:33

30 авг 2018, 19:54

а как включать/выключать все правила?


xvo
Сообщения: 236
Зарегистрирован: 25 фев 2018, 22:41

30 авг 2018, 20:24

izhhome писал(а):
30 авг 2018, 19:54
а как включать/выключать все правила?
Пишете скрипт, который по очереди начиная с 0 для всех записей проставляет disabled=yes/no.

Но мне все-таки больше нравится вариант с одним верхним правилом - и скрипт в одну строчку и для роутера количество действий не зависит от величины access list'а.


[CCR1009-7G-1C-1S+] [hEX] [wAP ac] [hAP ac²] [hAP mini]
izhhome
Сообщения: 9
Зарегистрирован: 04 мар 2018, 19:33

30 авг 2018, 20:36

не, задача такая:
днем - доступ всем
ночью - только избранным


izhhome
Сообщения: 9
Зарегистрирован: 04 мар 2018, 19:33

30 авг 2018, 20:41

Изображение
вот эту чалочку включать выключать командой можно?


xvo
Сообщения: 236
Зарегистрирован: 25 фев 2018, 22:41

30 авг 2018, 20:57

izhhome писал(а):
30 авг 2018, 20:41
Изображение
вот эту чалочку включать выключать командой можно?
Просто добавьте верхней записью в access list запись, которая разрешает все и всем с комментарием "allow all".

В один scheduler:

Код: Выделить всё

/interface wireless access-list set [find comment="allow all"] disabled=yes
Во второй соответственно:

Код: Выделить всё

/interface wireless access-list set [find comment="allow all"] disabled=no
Найдете, как ваша галочка выглядит в конфигурации - сделайте по аналогии.


[CCR1009-7G-1C-1S+] [hEX] [wAP ac] [hAP ac²] [hAP mini]
izhhome
Сообщения: 9
Зарегистрирован: 04 мар 2018, 19:33

30 авг 2018, 21:32

да, точно, я нашел в конфигурации как это сделать

Код: Выделить всё

/interface wireless set [ find default-name=wlan1 ] default-authentication=no

Код: Выделить всё

/interface wireless set [ find default-name=wlan1 ] default-authentication=yes
большое спасибо!


Ответить