скрипты. удалить пробелы?

Раздел для тех, кто начинает знакомиться с MikroTik
Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку "Действия до настройки роутера".
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там export. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.
Ответить
poppy
Сообщения: 17
Зарегистрирован: 17 ноя 2017, 11:42

14 янв 2018, 18:16

С налету не нашел описания функций работы со строками. Гдето это есть?

скрипт

Код: Выделить всё

:local info1 [/system identity get name];
:local info2 [/system routerboard get model];
:local info3 [/system routerboard get serial-number];
:local url1 "MT"
:set url1 ($url1."_".$info1."_".$info2."_".$info3);
:log info "$url1"


выдает строку, которая содержит пробел из-за RouterBOARD 941-2nD
как убрать пробеды из строковой переменной?


Аватара пользователя
Dragon_Knight
Модератор
Сообщения: 1531
Зарегистрирован: 26 мар 2012, 18:21
Откуда: МО, Мытищи
Контактная информация:

14 янв 2018, 20:01

Пройтись циклом по строке и заменить все пробелы..

Код: Выделить всё

:local inputStr "";
:local outputStr "";
:for i from=0 to=([:len $inputStr] - 1) do={
   :local char [:pick $inputStr $i];
   :if ($char = " ") do={:set $char "%20";};
   :if ($char = "-") do={:set $char "%2D";};
   :set outputStr ($outputStr . $char);
};



Помощь в ремонте и настройке оборудования MikroTik, Мытищи, Москва.
Дома: [RouterBOARD CCR1009-8G-1S-1S+] + [RouterBOARD cAP 2n] + [RouterBOARD Groove A-2Hn-32] + [D-Link ANT24-0800];
Работа 1: [RouterBOARD RB493G] + [MikroTik R52H] + [MikroTik CA493] + [D-Link ANT24-0800] + [RouterBOARD SXT G-2HnD];
Работа 2: [RouterBOARD RB2011UiAS-IN];
Резерв: [RouterBOARD RB450G];
poppy
Сообщения: 17
Зарегистрирован: 17 ноя 2017, 11:42

14 янв 2018, 23:12

спасибо. переделал на

Код: Выделить всё

:local url2 "";
:for i from=0 to=([:len $url1] - 1) do={
   :local char [:pick $url1 $i];
   :if ($char = " ") do={:set $char "_";};
   :set url2 ($url2 . $char);
};


Ответить