L2TP без IPSEC "не поднимается"

раздел для тех, кто начинает знакомиться с mikrotik
Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку "Действия до настройки роутера".
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там export. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.
Nagosh
Сообщения: 3
Зарегистрирован: 09 ноя 2017, 11:07

L2TP без IPSEC "не поднимается"

Сообщение Nagosh » 09 ноя 2017, 13:06

Добрый день!
Я в микротиках новичек, так что не ругайтесь, если мои вопросы покажутся глупыми...
Есть 2 микротика 951G-2HnD, прошивка 3.40.4, оба настроены и раздают/получают интернет от двух разных провайдеров с публичными IP адресами. Встал вопрос о настройке VPN тоннеля между двумя офисами, использующими эти самые микротики. Пробовал настраивать вот по этой инструкции: http://mikrotik.vetriks.ru/wiki/VPN:L2TP_site-to-site_(%D0%BE%D0%B1%D1%8A%D0%B5%D0%B4%D0%B8%D0%BD%D0%B5%D0%BD%D0%B8%D0%B5_%D0%BE%D1%84%D0%B8%D1%81%D0%BE%D0%B2)#.D0.A1.D1.85.D0.B5.D0.BC.D0.B0_.D1.81.D0.B5.D1.82.D0.B8
Все настроил, но тоннель не поднимается. В логах "сервера" есть только одна строка, связанная с VPN: first l2tp UDP packet received from, xx.xxx.xxx.xx, сам тоннель не переходит в статус running.
При этом ситуация такая:
1. Серверный микротик имеет белый IP x.x.x.1 и далее раздает интернет в локальную сеть y.y.y.0/16
2. Клиентский микротик подключаю к этой локальной сети так, что он имеет на порту(WAN) адрес y.y.y.100 (из локальной сети серверного микротика), и далее раздает интернет в сеть z.z.z.0/16
3. На клиентском микротике в качестве L2TP сервера указываю белый IP первого микротика x.x.x.1 - тоннель поднимается и работает.
4. Тот же клиентский микротик выдергиваю из сети серверного и подключаю к WAN порту другого провайдера, прописываю на WAN адреса от провайдера и маршрут по умолчанию через него же. Интернет появляется, а вот тоннель не поднимается. В логах сервера то самое сообщение: first l2tp UDP packet received from, xx.xxx.xxx.xx, клиент висит в статусе connecting.
Никаких правил firewall не настроено (или все правила отключены), провайдеры (оба) никакие порты не закрывают. Не могу понять, в чем дело. Натыкался на обсуждение здесь же: https://forummikrotik.ru/viewtopic.php?t=5033 , но чтение мануала мне не помогло, не могу понять проблему.
L2TP нужен без IPSEC, т.к. шифрование не нужно, а вот ресурсы маршрутизатора хочется экономить, т.к. предполагается в будущем несколько таких тоннелей.
Помогите, пожалуйста, разобраться с ситуацией. Если нужна какая-то дополнительная информация - предоставлю, только пишите, пожалуйста, чуть подробнее, как ее достать из микротика, т.к. я пока только начал с ним разбираться.
Nagosh
Сообщения: 3
Зарегистрирован: 09 ноя 2017, 11:07

Re: L2TP без IPSEC "не поднимается"

Сообщение Nagosh » 10 ноя 2017, 18:24

Включил лог l2tp, судя по всему на клиенте не получаю пакетов от сервера, не могу понять из-за чего. Есть пакеты sent, как я понимаю, должны быть еще packet rcvd, которых нет.

17:27:53 l2tp,ppp,info l2tp-out1: initializing...
17:27:53 l2tp,ppp,info l2tp-out1: connecting...
17:27:53 l2tp,debug tunnel 1 entering state: wait-ctl-reply
17:27:53 l2tp,debug,packet sent control message to xxx.xxx.xxx.xxx:1701 from 0.0.0.0:
1701
17:27:53 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0
17:27:53 l2tp,debug,packet (M) Message-Type=SCCRQ
17:27:53 l2tp,debug,packet (M) Protocol-Version=0x01:00
17:27:53 l2tp,debug,packet (M) Framing-Capabilities=0x1
17:27:53 l2tp,debug,packet (M) Bearer-Capabilities=0x0
17:27:53 l2tp,debug,packet Firmware-Revision=0x1
17:27:53 l2tp,debug,packet (M) Host-Name="MikroTik"
17:27:53 l2tp,debug,packet Vendor-Name="MikroTik"
17:27:53 l2tp,debug,packet (M) Assigned-Tunnel-ID=1
17:27:53 l2tp,debug,packet (M) Receive-Window-Size=4
17:27:54 l2tp,debug,packet sent control message to xxx.xxx.xxx.xxx:1701 from 0.0.0.0:
1701
17:27:54 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0
17:27:54 l2tp,debug,packet (M) Message-Type=SCCRQ
17:27:54 l2tp,debug,packet (M) Protocol-Version=0x01:00
17:27:54 l2tp,debug,packet (M) Framing-Capabilities=0x1
17:27:54 l2tp,debug,packet (M) Bearer-Capabilities=0x0
17:27:54 l2tp,debug,packet Firmware-Revision=0x1
17:27:54 l2tp,debug,packet (M) Host-Name="MikroTik"
17:27:54 l2tp,debug,packet Vendor-Name="MikroTik"
17:27:54 l2tp,debug,packet (M) Assigned-Tunnel-ID=1
17:27:54 l2tp,debug,packet (M) Receive-Window-Size=4
17:27:55 l2tp,debug,packet sent control message to xxx.xxx.xxx.xxx:1701 from 0.0.0.0:
1701
17:27:55 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0
17:27:55 l2tp,debug,packet (M) Message-Type=SCCRQ
17:27:55 l2tp,debug,packet (M) Protocol-Version=0x01:00
17:27:55 l2tp,debug,packet (M) Framing-Capabilities=0x1
17:27:55 l2tp,debug,packet (M) Bearer-Capabilities=0x0
17:27:55 l2tp,debug,packet Firmware-Revision=0x1
17:27:55 l2tp,debug,packet (M) Host-Name="MikroTik"
17:27:55 l2tp,debug,packet Vendor-Name="MikroTik"
17:27:55 l2tp,debug,packet (M) Assigned-Tunnel-ID=1
17:27:55 l2tp,debug,packet (M) Receive-Window-Size=4
17:27:57 l2tp,debug,packet sent control message to xxx.xxx.xxx.xxx:1701 from 0.0.0.0:
1701
17:27:57 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0
17:27:57 l2tp,debug,packet (M) Message-Type=SCCRQ
17:27:57 l2tp,debug,packet (M) Protocol-Version=0x01:00
17:27:57 l2tp,debug,packet (M) Framing-Capabilities=0x1
17:27:57 l2tp,debug,packet (M) Bearer-Capabilities=0x0
17:27:57 l2tp,debug,packet Firmware-Revision=0x1
17:27:57 l2tp,debug,packet (M) Host-Name="MikroTik"
17:27:57 l2tp,debug,packet Vendor-Name="MikroTik"
17:27:57 l2tp,debug,packet (M) Assigned-Tunnel-ID=1
17:27:57 l2tp,debug,packet (M) Receive-Window-Size=4
17:27:58 l2tp,ppp,info l2tp-out1: terminating...
17:27:58 l2tp,debug session 1 entering state: stopping
17:27:58 l2tp,ppp,debug l2tp-out1: LCP lowerdown
17:27:58 l2tp,ppp,debug l2tp-out1: LCP down event in initial state
17:27:58 l2tp,ppp,info l2tp-out1: disconnected
17:27:58 l2tp,ppp,info l2tp-out1: initializing...
17:27:58 l2tp,ppp,info l2tp-out1: connecting...
17:28:01 l2tp,debug,packet sent control message to xxx.xxx.xxx.xxx:1701 from 0.0.0.0:
1701
Nagosh
Сообщения: 3
Зарегистрирован: 09 ноя 2017, 11:07

Re: L2TP без IPSEC "не поднимается"

Сообщение Nagosh » 13 ноя 2017, 14:33

Разобрался с проблемой, всем спасибо!

Вернуться в «FAQ (Для начинающих)»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость