закрыть социальные сети

раздел для тех, кто начинает знакомиться с mikrotik
Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку "Действия до настройки роутера".
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там export. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.
asotel
Сообщения: 33
Зарегистрирован: 03 июн 2012, 08:12

закрыть социальные сети

Сообщение asotel » 31 окт 2017, 17:46

Добрый день

подскажите как на Mikrotik RB2011 закрыть доступ в социальные сети (одноклассники, фейсбук, контакте,...)

Спасибо.
mafijs
Сообщения: 144
Зарегистрирован: 03 сен 2017, 03:08
Откуда: Marienburga

Re: закрыть социальные сети

Сообщение mafijs » 31 окт 2017, 18:01

asotel писал(а):Добрый день
подскажите как на Mikrotik RB2011 закрыть доступ в социальные сети (одноклассники, фейсбук, контакте,...)
Спасибо.

Использовать Firewall cовместно с layer7
/ip firewall layer7-protocols
gmx
Сообщения: 2576
Зарегистрирован: 01 окт 2012, 14:48

Re: закрыть социальные сети

Сообщение gmx » 31 окт 2017, 20:58

mafijs писал(а):Использовать Firewall cовместно с layer7
/ip firewall layer7-protocols


И обнаружить, что это не помогает, почитать форум и выяснить, что адрес листы микротика поддерживают доменные имена. И с этого момента задача перестает быть сложной и решается в два клика.

К тщательному прочтению viewtopic.php?f=1&t=6599
mafijs
Сообщения: 144
Зарегистрирован: 03 сен 2017, 03:08
Откуда: Marienburga

Re: закрыть социальные сети

Сообщение mafijs » 31 окт 2017, 22:08

gmx писал(а):И обнаружить, что это не помогает

Работает, работает. Также как с адрес листами.
gmx
Сообщения: 2576
Зарегистрирован: 01 окт 2012, 14:48

Re: закрыть социальные сети

Сообщение gmx » 31 окт 2017, 22:16

И на https тоже работает? Вы уверены? Вы пробовали?

Может поделитесь готовыми строчками конфига?
mafijs
Сообщения: 144
Зарегистрирован: 03 сен 2017, 03:08
Откуда: Marienburga

Re: закрыть социальные сети

Сообщение mafijs » 31 окт 2017, 22:20

Именно для https и делал Layer7

Код: Выделить всё

/ip firewall layer7-protocol
add name=layer-7 regexp="^.+(facebook.com|ok.ru|youtube.com|www.youtube.com|frype.com|vk.com|odnoklassniki.ru|twitter.com).*\$"

/ip firewall filter
add action=drop chain=forward comment="drop layer 7" layer7-protocol=layer-7 src-address=192.168.xxx.0/24
gmx
Сообщения: 2576
Зарегистрирован: 01 окт 2012, 14:48

Re: закрыть социальные сети

Сообщение gmx » 01 ноя 2017, 09:01

Да, спасибо, но это уже проходили.

Блочится, например, и book.ru, и vovk.com, и так далее. А еще в вышеупонятутой теме есть сообщения о проблемах в работе ватсапа. И это только навскидку...

Ваш пример - это, решение, но неоднозначное. В самый неподходящий момент, выяснится, что не открывается очень нужный сайт, или перестала работать очень важная программа, только потому, что в ней баннер ссылается на vk.com и так далее.
mafijs
Сообщения: 144
Зарегистрирован: 03 сен 2017, 03:08
Откуда: Marienburga

Re: закрыть социальные сети

Сообщение mafijs » 01 ноя 2017, 14:28

gmx писал(а):Да, спасибо, но это уже проходили.
Блочится, например, и book.ru, и vovk.com, и так далее. А еще в вышеупонятутой теме есть сообщения о проблемах в работе ватсапа. И это только навскидку...
Ваш пример - это, решение, но неоднозначное. В самый неподходящий момент, выяснится, что не открывается очень нужный сайт


Без разници. Специально проверил один такой сайт - задержка с открыванием и с адрес листами что и с Layer7.
Mozilla "думает дольше, Chrome быстрее. И вся разница.
gmx
Сообщения: 2576
Зарегистрирован: 01 окт 2012, 14:48

Re: закрыть социальные сети

Сообщение gmx » 01 ноя 2017, 15:34

Вы что-то не правильно поняли, я пишу про то, что вместе с ок.ru и ok.com доступ блокируется и к book.ru и к mybook.com ну и так далее.

Решение, предложенное вами не может быть окончательным так как, доступ блокируется не только к сайтам из списка, но и к некоторым другим.
А значит - это не совсем правильное решение.

Да все это обсуждалось по вышеуказанной ссылке.
q2ker
Сообщения: 21
Зарегистрирован: 11 янв 2016, 17:05

Re: закрыть социальные сети

Сообщение q2ker » 02 ноя 2017, 10:11

gmx писал(а):И обнаружить, что это не помогает, почитать форум и выяснить, что адрес листы микротика поддерживают доменные имена. И с этого момента задача перестает быть сложной и решается в два клика.

если я добавляю DNS имя, миктотик сам добавляет IP адреса для этого домена. А эти адреса динамически обновляются сами?

Вернуться в «FAQ (Для начинающих)»

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и 1 гость