А посоветуйте задачки на скрипты

Раздел для тех, кто начинает знакомиться с MikroTik
Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку "Действия до настройки роутера".
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там export. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.
vqd
Модератор
Сообщения: 3359
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

10 ноя 2016, 04:56

Время не тратьте, микротик аплоад поддерживает исключительно по FTP

Хотите задачку. Ну нате вам нетривиальную. Сделайте рандом в диапазоне от 0 до 10 например или получите день недели

Более простое. Например сделайте скрипт который шлет письмо когда какой то пользователь заходит на микротик. Например когда тот же админ подключается.
Если хотите усложнить данную задачу (зависит от метода вашего решения) то можете добавить еще уведомление об отключении ползователя


Есть интересная задача и бюджет? http://mikrotik.site
gmx
Сообщения: 2015
Зарегистрирован: 01 окт 2012, 14:48

10 ноя 2016, 08:33

vqd писал(а):Время не тратьте, микротик аплоад поддерживает исключительно по FTP


Так никто и не сомневался. ТС просит задачу - ему подкинули... :hi_hi_hi:


EdkiyGluk
Сообщения: 241
Зарегистрирован: 21 сен 2014, 08:34
Откуда: 34
Контактная информация:

10 ноя 2016, 13:19

1) Cкрипт сканирует арпТаблицу на предмет адресов во внутренней сети
2) Сравнивает их с DHCP Leases
3) Если адресов нет в лизах, делает им статическую запись, дабы DHCP не раздал тот адрес, что забит статикой
===========================
1) Скрипт смены логина\пароля PPP сервера в зависимости от числа месяца...
2) Аналогичный скрипт будет работать и на клиенте PPP....
(повышаем секурность своих VPN-ов)
==========================
1) Скрипт сканирует попытки подбора пароля из внутренней локальной сети... И... САМОУТИЧТОЖАЕТ КОНФИГ... МХАХАХАХАХА,......(а почему бы и нет... в случае похищения девайса)
==========================
*и тут Остапа понесло................. (с)


Аватара пользователя
podarok66
Модератор
Сообщения: 2889
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

10 ноя 2016, 13:21

Про день недели в сети есть неплохие решения. Мне нравится такое:
 Старт компа по рабочим дням

Код: Выделить всё

:local date [/system clock get date]

:local result ""
:local months [:toarray "jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec"]
:local monthtbl [:toarray "0,3,3,6,1,4,6,2,5,0,3,5"]
:local daytbl [:toarray "sun,mon,tue,wed,thu,fri,sat"]

:local month [:pick $date 0 3]
:local day [:pick $date 4 6]
:local dayc [:pick $date 5 6]
:local century [:pick $date 7 9]
:local year [:pick $date 9 11]
:local yearc [:pick $date 10 11]

:if ([:pick $date 4 5] = 0) do={ :set day ($dayc)}
:if ([:pick $date 9 10] = 0) do={:set year ($yearc)}

:local sum 0
:set sum ($sum + (2 * (3 - ($century - (($century / 4) * 4)))))
:set sum ($sum + ($year / 4))
:set sum ($sum + $year + $day)
:for mindex from=0 to=[:len $months] do={
  :if ([:pick $months $mindex] = $month) do={:set sum ($sum + [:pick $monthtbl $mindex]) }
}
:set sum ($sum - (($sum / 7) * 7))
:set result [:pick $daytbl $sum]

:local workday [:toarray "mon,tue,wed,thu,fri"]
:if ($workday ~ $result) do={
:tool wol interface=ether2-master mac=xx:xx:xx:xx:xx:xx
/log warning "Start DQ67SW"
}

Брал отсюда

EdkiyGluk писал(а):1) Скрипт сканирует попытки подбора пароля из внутренней локальной сети... И... САМОУТИЧТОЖАЕТ КОНФИГ... МХАХАХАХАХА,......(а почему бы и нет... в случае похищения девайса)

Ну это уже перепаранойя, по-моему. Остальные задачи в чем-то интересны и вполне себе реализуемы...
Вот тут я решал что-то похожее на первую из ваших задач.


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
Аватара пользователя
podarok66
Модератор
Сообщения: 2889
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

10 ноя 2016, 19:42

Не могу не поделиться, нашел в сети просто отличное решение для генерации пароля. Правда генерирует с внешнего ресурса, но мне понравилось))

Код: Выделить всё

{
:global RandomOrg "";
/tool fetch url="https://www.random.org/passwords/\?num=1&len=10&format=plain&rnd=new" keep-result=yes dst-path="pass.txt";
delay 3;
:global RandomOrg [/file get pass.txt contents];
/file remove pass.txt;
:put $RandomOrg
}


Кстати, это и генерация рандомного числа:

Код: Выделить всё

{
:global RandomOrg "";
/tool fetch url="https://www.random.org/strings/\?num=1&len=1&digits=on&unique=on&format=plain&rnd=new" keep-result=yes dst-path="pass.txt";
delay 3;
:global RandomOrg [/file get pass.txt contents];
/file remove pass.txt;
:put $RandomOrg
}


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
Ответить