Нет пинга с клиентов после переключения на резервный канал

Раздел для тех, кто начинает знакомиться с MikroTik
Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку "Действия до настройки роутера".
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там export. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.
Ответить
orzon
Сообщения: 0
Зарегистрирован: 25 дек 2014, 17:38

25 дек 2014, 17:52

Добрый день!
Есть Mikrotik RB951Ui-2HnD и 2 провайдера: основной проводной и резервный 3G. Необходимо настроить резервирование основного канала.
Настроил проводной канал:
 Основной проводной провайдер
/interface ethernet
set 0 name=wan
set 1 master-port=none name=ether2-master-local
set 2 master-port=ether2-master-local name=ether3-slave-local
set 3 master-port=ether2-master-local name=ether4-slave-local
set 4 master-port=ether2-master-local name=ether5-slave-local

/interface bridge add name=bridge-local auto-mac=no protocol-mode=rstp admin-mac=[/interface ethernet get ether2-master-local mac-address]
/interface ethernet switch set 0 mirror-source=none mirror-target=none name=switch1
/interface bridge port add bridge=bridge-local interface=ether2-master-local
/interface bridge settings set use-ip-firewall=no use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=no

/ip address
add address=192.168.100.1/24 disabled=no interface=bridge-local network=192.168.100.0
add address=192.168.2.1/24 disabled=no interface=wan network=192.168.2.0

/ip route add dst-address=0.0.0.0/0 gateway=192.168.2.181 distance=2 comment="isp"

/ip dns set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip dns static add address=192.168.100.1 name=router

/ip firewall address-list
add address=192.168.100.0/24 disabled=no list=inet

/ip firewall filter
add action=accept chain=input comment=icmp disabled=no protocol=icmp

add action=accept chain=input comment=established connection-state=established disabled=no
add action=accept chain=input comment=related connection-state=related disabled=no

add action=accept chain=input comment=manage disabled=no in-interface=bridge-local

add action=drop chain=input comment="all other drop" disabled=no in-interface=wan

add action=drop chain=forward comment="Drop invalid connection packets" connection-state=invalid disabled=no

add action=accept chain=forward comment="Allow established connections" connection-state=established disabled=no
add action=accept chain=forward comment="Allow related connections" connection-state=related disabled=no

add action=accept chain=forward comment="Allow acess to internet" disabled=no in-interface=bridge-local

out-interface=wan src-address-list=inet

add action=drop chain=forward comment="All other drop" disabled=no

/ip firewall nat add action=masquerade chain=srcnat out-interface=wan

Настроил инет по 3G модем:
 Резервный провайдер 3G
/interface ppp-client
print

set 0 name=ppp-3G dial-on-demand=no use-peer-dns=no

/ip firewall address-list
add address=192.168.100.0/24 disabled=no list=inet2

/ip firewall filter
add place-before=9 action=accept chain=forward comment="acess to internet via 3G" disabled=no in-interface=bridge-local out-interface=ppp-3G src-address-list=inet2

/ip firewall nat add action=masquerade chain=srcnat out-interface=ppp-3G

/ip route add comment="always via ISP1" disabled=no dst-address=8.8.4.4/32 gateway=192.168.2.181

Создал скрипт:
 Скрипт переключения каналов
/system script
add name=backup3G policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive \
source="#Name: backup3G\r\
\n#Version: 1.0\r\
\n#Created: Gerasimov A.\r\
\n#Web: http://papa-admin.ru\r\
\n#Date: 01.2014\r\
\n#Description: failover for 3G modem\r\
\n#\r\
\n:local PingCount 3;\r\
\n\r\
\n:local InterfaceWan wan;\r\
\n:local Interface3G ppp-3G;\r\
\n:local CheckIp 8.8.4.4;\r\
\n:local Use3G false;\r\
\n\r\
\n:local WANstatus [/interface get [/interface find name=\"\$InterfaceWan\
\"] running];\r\
\n:if (\$WANstatus=false) do={\r\
\n\t:set Use3G true;\r\
\n} else {\r\
\n\t:local CheckMainISP [/ping \$CheckIp count=\$PingCount interface=\$InterfaceWan];\r\
\n\t:if (\$CheckMainISP=3) do={\r\
\n\t\t:set Use3G false;\r\
\n\t} else {\r\
\n\t\t:set Use3G true;\r\
\n\t}\r\
\n}\r\
\n:local 3Gstatus [/interface get [/interface find name=\"\$Interface3G\"]\
\_running];\r\
\n:if (\$Use3G=true) do={\r\
\n\tif (\$3Gstatus=false) do={\r\
\n\t\t/interface enable [find name=\"\$Interface3G\"];\r\
\n\t\t:log warning \"Set routes to 3G ISP\";\r\
\n\t}\r\
\n} else {\r\
\n\t:if (\$3Gstatus=true) do={\r\
\n\t\t/interface disable [find name=\"\$Interface3G\"];\r\
\n\t\t:log warning \"Set routes to Main ISP\";\r\
\n\t}\r\
\n}\r\
\n"

/system scheduler add interval=10s name=checkISP1 on-event=backup3G


Все работает хорошо, но почему-то после переключения на резервный канал 3G пропадает пинг (icmp) в интернет с клиентов, хотя на сайты они заходить могут. На самом микротике пинги проходят нормально при переключении на резервный канал 3G. NAT на интерфейсе ppp-3G прописан. В чем может быть дело? Что сделать, чтобы пинги шли с клиентов при переключении на резервный канал? Прошивка на роутере стоит последняя.


Ответить