MPLS и поиск ответа на вопрос "почему"

Раздел для тех, кто начинает знакомиться с MikroTik
Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку "Действия до настройки роутера".
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там export. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.
Ответить
Аватара пользователя
podarok66
Модератор
Сообщения: 3230
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

21 окт 2014, 09:01

Заранее прошу прощение за многословие, но так уж у меня выходит.
Один из моих близких, очень и очень дорогой мне человек обратился ко мне с просьбой. У него стоит дома роутер RB751U-2HnD, подаренный мною и при моем участии настроенный. До последнего времени все всех устраивало, железка работала, мой друг пользовался сетью и никто никого не трогал. Но в последние недели провайдер что-то сменил у себя в настройках и роутер стал выдавать кратковременные дисконнекты по 1-2 секунды. Практически обрыв с дальнейшим моментальным переподключением. На деле это означало как правило новый туннель до провайдера и новый IP-адрес, выданный провайдером же. А так как мой дружище заядлый и вполне себе продвинутый геймер, то это его очень обеспокоило, если не сказать больше. Сессии обрывались, игры требовали переподключения.
Включили дебаг в логах, стали смотреть. Надо сказать мусора там в этом дебаге немерено. Вплоть до попыток поиска сервера соседским роутером, включенным в тот же провайдерский свич. Ну да ладно. При разрыве видим такую строку:
Изображение
Лезу в конфиг, благо он пустой почти (геймеры не терпят трат ресурсов на посторонние процессы, скорость отклика дороже всего):
 конфиг

Код: Выделить всё

/interface bridge
add l2mtu=1598 name=bridge1 protocol-mode=none
/interface ethernet
set [ find default-name=ether2 ] speed=1Gbps
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no  l2mtu=2290 mode=ap-bridge tx-power=18 wireless-protocol=unspecified
/ip pool
add name=dhcp ranges=192.168.100.194-192.168.100.222
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge1 name=DHCP1
/ppp profile
set 0 only-one=yes use-mpls=required
/interface pppoe-client
add ac-name="" add-default-route=yes allow=pap,chap,mschap1,mschap2 default-route-distance=1 dial-on-demand=no disabled=no interface=ether1 keepalive-timeout=60 max-mru=\
    1480 max-mtu=1480 mrru=disabled name=SOUTH password=207935 profile=default service-name="" use-peer-dns=yes user=stepynin
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan1
/ip address
add address=192.168.100.193/27 interface=ether2 network=192.168.100.192
/ip dhcp-server network
add address=192.168.100.192/27 dns-server=192.168.100.193 domain=home gateway=192.168.100.193 netmask=27
/ip dns
set allow-remote-requests=yes servers=77.73.88.83,77.73.91.91
/ip firewall nat
add action=masquerade chain=srcnat src-address=192.168.100.0/24
/ip upnp
set allow-disable-external-interface=no enabled=yes
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 comment=Upstream interface=ether1 upstream=yes
add comment=Downstream interface=bridge1

Обращаю внимание на строку:

Код: Выделить всё

/ppp profile
set 0 only-one=yes use-mpls=required

Меняю на

Код: Выделить всё

/ppp profile
set 0 only-one=yes use-mpls=default

Получаю опять разрывы с логами:
Изображение
Еще раз меняю

Код: Выделить всё

/ppp profile
set 0 only-one=yes use-mpls=no

Ура, разрывов нет, всё работает как и раньше.
Делаем выводы (вполне возможно, что ошибочные), что провайдер крутит что-то там у себя с MPLS, но простых пользователей не извещает (что естественно и объяснимо). Общение с техподдержкой, кстати, результатов не давало, дальше второго уровня нам пробиться не удалось.
Ну, казалось бы, ладно, сделал и забыл. Но меня мучат не переставая вопросы. Как MPLS метки могли приводить к обрыву сессии. И вообще, каким образом меченные пакеты попадали в локалку. Вроде бы метки меняются после прохождения маршрутизаторов очередного уровня и в локалку попадать меченные пакеты не должны.
Если у кого-то об этом есть понятие, объясните на пальцах, потому как мне еще нужно всё потом пересказать приятелю, дабы утолить его жажду гнева и негодования. Только не надо отсылать к первоисточникам, в них я копался, но там столько воды... Мне нужно просто и и понятно, чтобы я смог пересказать, не слишком путаясь.


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
ReadMe
Сообщения: 12
Зарегистрирован: 29 окт 2014, 21:31

30 окт 2014, 15:35

столкнулся с такой же ошибкой, прийду домой проверю.


Ответить