Создание HotSpot с разными диапазонами ip с роумингом wifi

раздел для тех, кто начинает знакомиться с mikrotik
Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку "Действия до настройки роутера".
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там export. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.
Ответить
Ezhikoff
Сообщения: 0
Зарегистрирован: 14 авг 2013, 08:05

14 авг 2013, 08:10

Доброго времени суток.
Имеется 2 роутера Mikrotik RB751U-2HnD

Цель: создать на базе 2 роутеров хотспот с двумя или тремя ssid с разными ip и обеспечения бесшовного роуминга

1ssid например 192.168.0.0 для бесплатного доступа
2 ssid с 192.168.10.0 с повременным доступом

Все настройки были сделаны вот по этой инструкции: http://www.lanmart.ru/blogs/mikrotik-rb ... irtual_ap/


используя данную инструкцию, собрал, проверил, работает, добавил в master роутер bridge2, добавил адрес 192.168.10.0 создал virtual ap 2 , добавил dhcp, все тоже кроме dhcp проделал на 2ом роутере slave. Результат при подключении к Master все работает, клиент подключаясь к 1ому ssid получает 192.168.0.3 а к ssid 2 192.168.10.243. Но при включении slave роутера и попытке подключиться через него к ssid 1 я получаю нужный ip, а к ssid 2 я подключиться не могу. Вопрос: как правильно настроить хот-спот с 2умя ssid с разными диапазонами ip с расширением зоны покрытия и обеспечения бесшовного роуминга. Соединить роутеры кабелем возможности нет.
Вообщем необходимо, что бы был еще бесшовный роуминг . Вообщем как в инструкции 1 роутер (master)
2ой (slave) если пользователь находится далеко от master роутера, то он подключается к slave и на оборот.
Интернет подключен только к master роутеру. Читал много инструкций с использованием WDS, MESH. Но чем больше читал, тем больше запутался.
Подскажите пожалуйста ка все это дело настроить.

P/S: Вообщем, если короче, то мне нужно используя инструкцию с lanmart'a добавить еще один ssid с другим диапазоном ip

Попробовал сделать с vlan, но результат тот же :)
Вот конфигурация роутеров:

Master

Код: Выделить всё

/interface bridge
add l2mtu=1598 name=bridge1
add name=bridge2
/interface wireless
set 0 band=2ghz-b/g/n disabled=no frequency-mode=superchannel ht-rxchains=0,1 \
    ht-txchains=0,1 hw-protection-mode=rts-cts hw-retries=15 l2mtu=2290 mode=\
    ap-bridge periodic-calibration=enabled periodic-calibration-interval=10 \
    radio-name=Master ssid=WDS tx-power=18 tx-power-mode=card-rates \
    wds-default-bridge=bridge1 wds-mode=dynamic wireless-protocol=802.11
add disabled=no l2mtu=2290 mac-address=D6:CA:6D:7D:5F:BD master-interface=wlan1 \
    name=wlan2 ssid=Test1 wds-cost-range=0 wds-default-bridge=bridge1 \
    wds-default-cost=0 wds-mode=dynamic
add disabled=no l2mtu=2290 mac-address=D6:CA:6D:7D:5F:BE master-interface=wlan1 \
    name=wlan3 ssid=Test2 wds-cost-range=0 wds-default-bridge=bridge1 \
    wds-default-cost=0 wds-mode=dynamic
/interface lte
set 0 apn="" mac-address=0C:00:0E:00:C0:0D modem-init="" name=lte1 \
    network-mode=auto password="" pin="" user=""
/interface wireless nstreme
set wlan1 enable-polling=no
/interface vlan
add interface=bridge2 l2mtu=65531 name=vlan1 vlan-id=1
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods=\
    passthrough group-ciphers=tkip,aes-ccm mode=dynamic-keys \
    supplicant-identity=MikroTik unicast-ciphers=tkip,aes-ccm \
    wpa-pre-shared-key=******** wpa2-pre-shared-key=********
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/ip pool
add name=dhcp_pool1 ranges=192.168.0.2-192.168.0.254
add name=dhcp_pool2 ranges=192.168.10.2-192.168.10.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge1 name=dhcp1
add address-pool=dhcp_pool2 disabled=no interface=bridge2 name=dhcp2
/tool user-manager customer
add backup-allowed=yes disabled=no login=admin password="" \
    paypal-accept-pending=no paypal-allowed=no paypal-secure-response=no \
    permissions=owner signup-allowed=no time-zone=-00:00
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=wlan2
add bridge=bridge2 interface=wlan3
/interface wireless access-list
add interface=wlan2 signal-range=-75
add interface=wlan3 signal-range=-75
/ip address
add address=192.168.0.1/24 interface=bridge1
add address=192.168.10.1/24 interface=bridge2
/ip dhcp-client
add disabled=no interface=lte1
/ip dhcp-server network
add address=192.168.0.0/24 dns-server=192.168.0.1 gateway=192.168.0.1
add address=192.168.10.0/24 dns-server=192.168.0.1 gateway=192.168.10.1
/ip dns
set allow-remote-requests=yes
/ip firewall nat
add action=masquerade chain=srcnat src-address=192.168.0.0/24
add action=masquerade chain=srcnat out-interface=lte1 to-addresses=0.0.0.0
/ip neighbor discovery
set wlan1 disabled=yes
set lte1 disabled=yes
set vlan1 disabled=yes
set wlan2 disabled=yes
set wlan3 disabled=yes
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
/system identity
set name=Master
/system leds
set 0 interface=wlan1


Slave

Код: Выделить всё

/interface bridge
add l2mtu=1598 name=bridge1
add l2mtu=2290 name=bridge2
/interface wireless
set 0 band=2ghz-b/g/n disabled=no ht-rxchains=0,1 ht-txchains=0,1 \
    hw-protection-mode=rts-cts hw-retries=15 l2mtu=2290 mode=wds-slave \
    periodic-calibration=disabled periodic-calibration-interval=10 \
    radio-name=Slave ssid=WDS tx-power=18 tx-power-mode=card-rates \
    wds-default-bridge=bridge1 wds-mode=dynamic wireless-protocol=802.11
add default-authentication=no disabled=no l2mtu=2290 mac-address=\
    D6:CA:6D:7D:5F:63 master-interface=wlan1 name=wlan2 ssid=Teast1 \
    wds-cost-range=0 wds-default-bridge=bridge1 wds-default-cost=0 wds-mode=\
    dynamic
add default-authentication=no disabled=no l2mtu=2290 mac-address=\
    D6:CA:6D:7D:5F:64 master-interface=wlan1 name=wlan3 ssid=Test2 \
    wds-cost-range=0 wds-default-bridge=bridge1 wds-default-cost=0 wds-mode=\
    dynamic
/interface vlan
add interface=bridge2 l2mtu=2286 name=vlan1 vlan-id=1
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods=\
    passthrough group-ciphers=tkip,aes-ccm mode=dynamic-keys \
    supplicant-identity=MikroTik unicast-ciphers=tkip,aes-ccm \
    wpa-pre-shared-key=******** wpa2-pre-shared-key=*********
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=wlan2
add bridge=bridge2 interface=wlan3
/interface wireless access-list
add interface=wlan2 signal-range=-75
add interface=wlan3 signal-range=-75
/ip address
add address=192.168.0.2/24 interface=bridge1
add address=192.168.10.2/24 interface=bridge2
/ip dhcp-client
add default-route-distance=0 disabled=no interface=bridge1
/ip neighbor discovery
set wlan1 disabled=yes
set wlan2 disabled=yes
set vlan1 disabled=yes
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
/system identity
set name=Slave
/system leds
set 0 interface=wlan1


Ответить