два провайдера - отказоустойчиловость и чистка сесии.. запутался.

Раздел для тех, кто начинает знакомиться с MikroTik
Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку "Действия до настройки роутера".
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там export. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.
Ответить
anad
Сообщения: 39
Зарегистрирован: 24 ноя 2016, 21:14

11 окт 2018, 13:24

Постановка задачи:
1 есть проводной провайдер, который любит падать ( причем частично, то есть может отпасть все кроме MSK-IX, или один из аплинков перестать работать.. ), есть страховочная SIM воткнутая в проводной роутер. Надо проверять внешние ресурсы и чистить SIP сессии.

Непонятки:
1 везде сказано просто выделите два ресурса для пинга с разных хвостов и вешайте NETWATCH. Микротик же, если упала физика ( и такое бывает с проводным), перестраивает маршруты можно ли его убедить не делать этого более человечно, чем маршрут в блекхол в метрикой 2 . То есть сейчас сделано. так
 ip route print
/ip route print
dst-address=77.88.8.1/32 gateway=192.168.0.1 gateway-status=192.168.0.1 reachable via Wan_MEGAFON check-gateway=ping distance=1 scope=30 target-scope=10
dst-address=77.88.8.1/32 type=blackhole distance=2
dst-address=77.88.8.8/32 gateway=X.X.X.X gateway-status=x.x.x.x reachable via WAN_PROVIDER distance=1 scope=30 target-scope=10
dst-address=77.88.8.8/32 type=blackhole distance=2
- не нравится, но работает .
2 как таки почистить сессии пробовалось все что нашлось в интернете/ придумалось то есть максимальная комбинация выглядела вот так ( сорри по памяти, может быть где-то чуть ошибся с синтаксисом порты точно 5060 и 9060 - других нет, sip service port это 4 и описано оба порта)
 чистка сессий
/ip firewall service-port disable 4
/ip firewall connection tracking set enabled=no
:delay 10
/ip firewall connection remove [find dst-address="~:9060"]
/ip firewall connection remove [find dst-address="~:5060"]
/ip firewall connection remove [/ip firewall connection find where connection-type=sip]
/ip firewall connection tracking set enabled=yes
/ip firewall service-port disable 4
в скрипт оно точно приходит ( счетчик дергается в лог пишется warn из скрипта), ошибок вида ( не нашло что удалить - в логе нет) . Пробовал без disable tracking и без ip firewall service-port disable , менял их местами, чистил не только SIP а все. ... КАК ?? ( delay 120 расставлял в самых неожиданных местах) . При этом если руками запустить скрипт - все работает - устройства регятся заново.


anad
Сообщения: 39
Зарегистрирован: 24 ноя 2016, 21:14

12 окт 2018, 12:11

anad писал(а):
11 окт 2018, 13:24
Постановка задачи:
Непонятки:
1 везде сказано просто выделите два ресурса для пинга с разных хвостов и вешайте NETWATCH. Микротик же, если упала физика ( и такое бывает с проводным), перестраивает маршруты можно ли его убедить не делать этого более человечно, чем маршрут в блекхол в метрикой
по вопросу 1 - сам дурак: то что оно автоматом ставит check gateway не значит что его нельзя отключить

Код: Выделить всё

/ip route unset  value-name=check-gateway  2

со вторым - так и не понимаю чего они не чистятся


Ответить