добавить все порты в bridge

Здесь выкладываем скрипты
Ответить
voler
Сообщения: 103
Зарегистрирован: 13 апр 2012, 12:33

03 авг 2018, 17:04

Добрый день.

Есть вот такой вариант команды, который выводить все интерфейсы
:local interfaces [/interface find]; :foreach interface in=$interfaces do={ :put (. [/interface get $interface name]); };

Получим список:
ether1
ether2
ether3
ether4
ether5
wlan1

Нужно добавить все кроме ether1 и sfp1 в Local.
Подскажите как правильнее сделать?


tmp
Сообщения: 5
Зарегистрирован: 09 ноя 2018, 22:14

09 ноя 2018, 22:47

Через терминал открываем сразу
/interface bridge port
Потом скопированный текст
add bridge=Local="ether2"
add bridge=Local="ether3"
add bridge=Local="ether4"
add bridge=Local="ether5"
add bridge=Local="wlan1"

Ctrl+V и Enter.
Готово!


tmp
Сообщения: 5
Зарегистрирован: 09 ноя 2018, 22:14

09 ноя 2018, 22:49

Забыл упомянуть, что бридж уже должен быть
Просто через терминал
/interface bridge add auto-mac=yes name=Local


vqd
Модератор
Сообщения: 3604
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

13 ноя 2018, 19:31

voler писал(а):
03 авг 2018, 17:04
Добрый день.

Есть вот такой вариант команды, который выводить все интерфейсы
:local interfaces [/interface find]; :foreach interface in=$interfaces do={ :put (. [/interface get $interface name]); };

Получим список:
ether1
ether2
ether3
ether4
ether5
wlan1

Нужно добавить все кроме ether1 и sfp1 в Local.
Подскажите как правильнее сделать?
ну конкретно по вашему ТЗ например так

по ТЗ добавляем в бридж
/interface
:foreach i in [find (!(name~".1") and !(name~"bridge"))] do={bridge port add bridge=bridge1 interface=[/interface get $i name]}

по ТЗ просто получаем список имен
/interface
:foreach i in [find (!(name~".1"))] do={:put [get $i name]}]


Есть интересная задача и бюджет? http://mikrotik.site
Ответить