Нужна помощь перенаписания скрипта для CAPsMAN

Здесь выкладываем скрипты
Ответить
rbmikrotik
Сообщения: 2
Зарегистрирован: 09 ноя 2018, 13:26
Откуда: Ukraine, Kiev
Контактная информация:

18 мар 2019, 15:08

Всем добрый день!
Нашел на этом форуме скрипт который добавляет и блокирует MAC в ACL. Но он работает только для интерфейса встроеного wireless.

:local pop 4
:local mac
:local wifi [/log find message~"disconnected, unicast key exchange timeout"]

foreach i in=$wifi do={
:set mac [:pick [/log get $i message ] 0 ([:len [/log get $i message ]]-50)]
#:log warning $mac
if ([:len [/log find message~($mac . "@wlan1: disconnected, unicast key exchange timeout")] ] >= $pop) do={
if ([/interface wireless access-list find mac-address=$mac] = "" ) do={
/interface wireless access-list add mac-address=$mac authentication=no interface=all
}
}
}
#:log warning "FINISH"

Может кто помочь, переделать его так что бы он работал для CAPsMAN, так как вместо wlan1, там много разных интерфейсов + вместо текста disconnected, unicast key exchange timeout выдается другой текст в логах CAPsMAN - disconnected, 4-way handshake timeout.
Спасибо если кто то откликнется!


vqd
Модератор
Сообщения: 3586
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

22 мар 2019, 19:51

ну надо так перепишем. Правда я предпочитаю под ТЗ писать а не переписывать. В общем баннер наверху


Есть интересная задача и бюджет? http://mikrotik.site
Ответить