Вопрос по скрипту.

Здесь выкладываем скрипты
Ответить
ivan.losev
Сообщения: 3
Зарегистрирован: 28 фев 2019, 13:20

06 мар 2019, 13:19

Мне надо сделать так, чтобы на микротике выполнялась проверка 1 раз в день (запускаемая планировщиком) на предмет пришедших смс. Если смс в inbox нету то запускать скрипт /tool fetch url="http://192.168.0.101/cmd.cgi cmd=REL,2,1,2,"
Если смс в inbox есть, то ничего не делать. Помогите прошу! :smu:sche_nie:


Sertik
Сообщения: 628
Зарегистрирован: 15 сен 2017, 09:03

06 мар 2019, 14:03

Что-то типа такого пишите:

:local messageSMS "INVERSE REL";
:local phoneSMS "+79999999999";

:local countMSG [/tool sms inbox print count-only where message=$messageSMS phone=$phoneSMS];
:if ($countMSG = 0) do={
/tool sms inbox remove [find];
} else={ /tool sms inbox remove $messageSMS;
# тут вставляете команду запуска Вашего устройства на орбиту Марса
}

Это очень простой грубый пример, без обработки ошибок, без анализа входящих SMS, без сохранения других СМС в хранилище, без проверки не висит ли Ваш модем и т д ...

Настраиваете у себя /tool SMS для приема сообщений;

Скрипт вставляйте в Планировщик с нужным интервалом выполнения.

Посылаете с номера указанного в phoneSMS команду INVERSE REL (можете назвать по своему).

Хороший скрипт писать нужно Вам самому (или на заказ) :-)


Чего не знаем то нагуглим
ivan.losev
Сообщения: 3
Зарегистрирован: 28 фев 2019, 13:20

06 мар 2019, 14:34

Sertik писал(а):
06 мар 2019, 14:03
Что-то типа такого пишите:

:local messageSMS "INVERSE REL";
:local phoneSMS "+79999999999";

:local countMSG [/tool sms inbox print count-only where message=$messageSMS phone=$phoneSMS];
:if ($countMSG = 0) do={
/tool sms inbox remove [find];
} else={ /tool sms inbox remove $messageSMS;
# тут вставляете команду запуска Вашего устройства на орбиту Марса
}

Это очень простой грубый пример, без обработки ошибок, без анализа входящих SMS, без сохранения других СМС в хранилище, без проверки не висит ли Ваш модем и т д ...

Настраиваете у себя /tool SMS для приема сообщений;

Скрипт вставляйте в Планировщик с нужным интервалом выполнения.

Посылаете с номера указанного в phoneSMS команду INVERSE REL (можете назвать по своему).

Хороший скрипт писать нужно Вам самому (или на заказ) :-)
Такая конструкция гуляет по гуглу, но к сожалению не совсем понимаю как ее адаптировать все таки под мою задачу


Sertik
Сообщения: 628
Зарегистрирован: 15 сен 2017, 09:03

06 мар 2019, 19:18

А чего не понятно то, Иван ?

Я же Вам практически рабочий скрипт дал. Конструкцию да, взял готовую из Инета, для примера просто. Ну вставьте туда вместо решетки Вашу команду
/tool fetch url="http://192.168.0.101/cmd.cgi cmd=REL,2,1,2," и всё ! Проверьте синтаксис скрипта в терминале (я же не отлаживал).
Потом поместите скрипт в Шедуллер и запускайте с нужным интервалом.

Ну, а полный вариант хорошего скрипта "под ключ" делается не на скорую руку ... Могу написать на заказ но "дорого" будет. :-)

На форуме дают направления, а не дарят готовые коммерческие продукты.


Чего не знаем то нагуглим
Ответить