Простой скрипт отправки в телеграм изменившегося wan адреса

Здесь выкладываем скрипты
Ответить
Evghenii
Сообщения: 3
Зарегистрирован: 05 июн 2018, 17:34

05 июн 2018, 17:40

Код: Выделить всё

:global routername [/system resource get board-name]
:global sendToTele "https://api.telegram.org/botxxxxxxxxxx:yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy/sendmessage\?chat_id=zzzzzzzzzzz&text=";
:global oldIP
:global newIP [:resolve myip.opendns.com server=208.67.222.222];

if ($newIP=$oldIP) do={} else={
/tool fetch url="$sendToTele $routername%0Aold IP:$oldIP %F0%9F%8C%8D - new IP:$newIP %f0%9f%8c%8f" keep-result=no} 

set oldIP $newIP
скрипт в шедулер на выполнение как часто необходимо


remvord
Сообщения: 2
Зарегистрирован: 06 июл 2018, 07:36

06 июл 2018, 07:49

Что нужно писать вместо всех этих xxxxxxxx yyyyyyyyy zzzzzzx?


Evghenii
Сообщения: 3
Зарегистрирован: 05 июн 2018, 17:34

06 июл 2018, 11:42

id token бота и chat id


remvord
Сообщения: 2
Зарегистрирован: 06 июл 2018, 07:36

06 июл 2018, 19:27

ok
можете прояснить где мы определили переменную oldIP как mikrotik понимает какой ip сейчас на wan?


Аватара пользователя
podarok66
Модератор
Сообщения: 2946
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

06 июл 2018, 23:27

Третья строка - заявка на использование переменной в скрипте, так сказать. (Если переменная имеет значение, оно и будет, если переменной не существует, значит появится пустая)
Последняя строка - переменной присваивается новое значение.
Четвертая строка - объявление переменной, значение которой будет внешний адрес Тика.
Рекомендую использовать знаки препинания, мы же не пятиклассники в школьном чате...


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
Ответить