И снова про автоматическую конфигурацию

Здесь выкладываем скрипты
Ответить
vqd
Модератор
Сообщения: 3359
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

13 апр 2018, 08:46

Пришлось тут ковырять кучу микротиков которые были подключены к головному. Конфиг везде однотипный и делалось все удаленно.

Заходить на каждый не хотелось но было стойкое желание придумать механизм которых бы выполнял на этих всех железках нужные мне команды для осуществления базовой настройки.

Код: Выделить всё

{
:local adr
:local com
:foreach i in [/ip neighbor find] do={
:set adr [/ip neighbor get $i address]
:set name [/ip neighbor get $i interface]
:set com ("/ip firewall nat add action=masquerade chain=srcnat out-interface=ppp-out1")
:put $adr
:put $name
:put $com

/system ssh address=$adr user=admin command=$com
} 
}
Скрипт тупо бегает по листу neighbor , собирает там нужные данные, по SSH подключается к каждой железке и выполняет команду. Естественно скрипт на ходу правится под нужные команды. Из скрипта не заработает, только из консоли и только если на той стороне не стоит пароль.

Вобщем как инструмент по разворачиванию однотипного конфига на новых железках пойдет


Есть интересная задача и бюджет? http://mikrotik.site
Ответить