Backup на Email

Обсуждение ПО и его настройки
tester123
Сообщения: 5
Зарегистрирован: 29 окт 2013, 20:46

12 мар 2014, 20:42

Данный скрипт успешно работает на 6.10(powerpc) но не работает на 6.6(mipsbe)
Пожалуйста кто силен в этом скажите в чем дело?!

Код: Выделить всё

{
:log info "Starting Backup Script...";
:local sysname [/system identity get name];
:local sysver [/system package get system version];
:log info "Flushing DNS cache...";
/ip dns cache flush;
:delay 2;
:log info "Deleting last Backups...";
:foreach i in=[/file find] do={:if ([:typeof [:find [/file get $i name] \
"$sysname-backup-"]]!="nil") do={/file remove $i}};
:delay 2;
:local smtpserv [:resolve "smtpxxxxx.ua"];
:local Eaccount "xxxloginxxx";
:local pass "xxxpassxxx";
:local backupfile ("$sysname-backup-" . \
[:pick [/system clock get date] 7 11] . [:pick [/system \
clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup");
:log info "Creating new Full Backup file...";
/system backup save name=$backupfile;
:delay 2;
:log info "Sending Full Backup file via E-mail...";
/tool e-mail send from="<$Eaccount>" to=$Eaccount server=$smtpserv \
port=25 user=$Eaccount password=$pass file=$backupfile \
subject=("$sysname Sm Full Backup (" . [/system clock get date] . ")") \
body=("$sysname full Backup file see in attachment.\nRouterOS version: \
$sysver\nTime and Date stamp: " . [/system clock get time] . " " . \
[/system clock get date]);
:delay 5;
:local exportfile ("$sysname-backup-" . \
[:pick [/system clock get date] 7 11] . [:pick [/system \
clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".rsc");
:log info "Creating new Setup Script file...";
/export file=$exportfile;
:delay 2;
:log info "Sending Setup Script file via E-mail...";
/tool e-mail send from="<$Eaccount>" to=$Eaccount server=$smtpserv \
port=587 user=$Eaccount password=$pass file=$exportfile \
subject=("$sysname Setup Script Backup (" . [/system clock get date] . \
")") body=("$sysname Setup Script file see in attachment.\nRouterOS \
version: $sysver\nTime and Date stamp: " . [/system clock get time] . " \
" . [/system clock get date]);
:delay 5;
:log info "All System Backups emailed successfully.\nBackuping completed.";
}


Аватара пользователя
podarok66
Модератор
Сообщения: 2946
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

13 мар 2014, 14:48

Что-то я менял в нем после перехода на новую версию, сейчас уж и не припомню. Вроде бы вот тут, но не факт:

Код: Выделить всё

/tool e-mail send from="<$Eaccount>" to=$Eaccount server=$smtpserv port=587 user=$Eaccount password=$pass start-tls=yes file=$exportfile subject=("$sysname Setup Script Backup (" . [/system clock get date] . ")") body=("$sysname Setup Script file see in attachment.
RouterOS version: $sysver
Time and Date stamp: " . [/system clock get time] . " " . [/system clock get date]);

Попробуйте. Если не выйдет, завтра попаду домой вечерком, погляжу повнимательнее.


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
Аватара пользователя
pubuser
Сообщения: 62
Зарегистрирован: 14 мар 2014, 18:14

15 мар 2014, 06:50

Могу если нужно выложить рабочий скрипт который на 6.10 версии успешно отрабатывает.


Аватара пользователя
podarok66
Модератор
Сообщения: 2946
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

15 мар 2014, 11:03

Да ТС пропал. Значит не столь необходимо было ему этот скрипт запустить.
У меня успешно работает этот скрипт с небольшими дополнениями (забирает по ftp еще с одного роутера бэкапы и отсылает туда же)


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
tester123
Сообщения: 5
Зарегистрирован: 29 окт 2013, 20:46

15 мар 2014, 13:24

podarok66 писал(а):Что-то я менял в нем после перехода на новую версию, сейчас уж и не припомню. Вроде бы вот тут, но не факт:

Код: Выделить всё

/tool e-mail send from="<$Eaccount>" to=$Eaccount server=$smtpserv port=587 user=$Eaccount password=$pass start-tls=yes file=$exportfile subject=("$sysname Setup Script Backup (" . [/system clock get date] . ")") body=("$sysname Setup Script file see in attachment.
RouterOS version: $sysver
Time and Date stamp: " . [/system clock get time] . " " . [/system clock get date]);

Попробуйте. Если не выйдет, завтра попаду домой вечерком, погляжу повнимательнее.

Нет, просто был очень занят, мне очень все еще актуальный рабочий пример, может я сильно ошибаюсь но вот как я попробовал использовать ваш код, при запуске ошибок нет, но результат тот же.

Код: Выделить всё

{
:log info "Starting Backup Script...";
:local sysname [/system identity get name];
:local sysver [/system package get system version];
:log info "Flushing DNS cache...";
/ip dns cache flush;
:delay 2;
:log info "Deleting last Backups...";
:foreach i in=[/file find] do={:if ([:typeof [:find [/file get $i name] \
"$sysname-backup-"]]!="nil") do={/file remove $i}};
:delay 2;
:local smtpserv [:resolve "smtp.xxxx.ru"];
:local Eaccount "username";
:local pass "pass";
:local backupfile ("$sysname-backup-" . \
[:pick [/system clock get date] 7 11] . [:pick [/system \
clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup");
:log info "Creating new Full Backup file...";
/system backup save name=$backupfile;
:delay 2;
:log info "Sending Full Backup file via E-mail...";
/tool e-mail send from="<$Eaccount>" to=$Eaccount server=$smtpserv port=587 user=$Eaccount password=$pass start-tls=yes file=$backupfile subject=("$sysname Setup Script Backup (" . [/system clock get date] . ")") body=("$sysname Setup Script file see in attachment.
RouterOS version: $sysver
Time and Date stamp: " . [/system clock get time] . " " . [/system clock get date]);
:delay 5;
:local exportfile ("$sysname-backup-" . \
[:pick [/system clock get date] 7 11] . [:pick [/system \
clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".rsc");
:log info "Creating new Setup Script file...";
/export file=$exportfile;
:delay 2;
:log info "Sending Setup Script file via E-mail...";
/tool e-mail send from="<$Eaccount>" to=$Eaccount server=$smtpserv port=587 user=$Eaccount password=$pass start-tls=yes file=$backupfile subject=("$sysname Setup Script Backup (" . [/system clock get date] . ")") body=("$sysname Setup Script file see in attachment.
RouterOS version: $sysver
Time and Date stamp: " . [/system clock get time] . " " . [/system clock get date]);
:delay 5;
:log info "All System Backups emailed successfully.\nBackuping completed.";
}


Аватара пользователя
podarok66
Модератор
Сообщения: 2946
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

15 мар 2014, 14:53

Ща дам прямо с рабочей машины, под себя переберете сами, у уж устал его каждому комментировать.

Код: Выделить всё

{
:log info "Starting Backup Script...";

:local sysname [/system identity get name];
:local sysver [/system package get system version];

:log info "Flushing DNS cache...";

/ip dns cache flush;
:delay 2;

:log info "Deleting last Backups...";

:foreach i in=[/file find] do={:if ([:typeof [:find [/file get $i name] "$sysname-backup-"]]!="nil") do={/file remove $i}};

:delay 2;

:local smtpserv [:resolve "smtp.gmail.com"];

:local Eaccount "E-mail вставишь сам";
:local pass "**************";

:local backupfile ("$sysname-backup-" . [:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup");
:log info "Creating new Full Backup file...";
/system backup save name=$backupfile;
:delay 5;
:log info "Sending Full Backup file via E-mail...";

/tool e-mail send from="<$Eaccount>" to=$Eaccount server=$smtpserv port=587 user=$Eaccount password=$pass start-tls=yes file=$backupfile subject=("$sysname Full Backup (" . [/system clock get date] . ")") body=("$sysname full Backup file see in attachment.
RouterOS version: $sysver
Time and Date stamp: " . [/system clock get time] . " " . [/system clock get date]);

:delay 30;

:local exportfile ("$sysname-backup-" . [:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".rsc");
:log info "Creating new Setup Script file...";
/export file=$exportfile;

:delay 5;

:log info "Sending Setup Script file via E-mail...";

/tool e-mail send from="<$Eaccount>" to=$Eaccount server=$smtpserv port=587 user=$Eaccount password=$pass start-tls=yes file=$exportfile subject=("$sysname Setup Script Backup (" . [/system clock get date] . ")") body=("$sysname Setup Script file see in attachment.
RouterOS version: $sysver
Time and Date stamp: " . [/system clock get time] . " " . [/system clock get date]);

:delay 30;
:log info "All System Backups emailed successfully.
Backuping completed.";

}

Там у меня дальше идет вторая часть, Вам она ни к чему. Ставьте и проверяйте


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
tester123
Сообщения: 5
Зарегистрирован: 29 окт 2013, 20:46

15 мар 2014, 16:50

Вписал в ваш пример свои данные авторизации:

Код: Выделить всё

:local smtpserv [:resolve "smtp.gmail.com"];
:local Eaccount "E-mail вставишь сам";
:local pass "**************";


но опять ничего не работает, странно что вывод скрипта у меня только:

Код: Выделить всё

[admin@MikroTik] /system script> run backup
Saving system configuration
Configuration backup saved


Скажите свидетельствует это о том что остальная часть кода просто не выполняется? как можно его запустить в режиме отладки(если есть такая функция или ей подобная)?


Аватара пользователя
podarok66
Модератор
Сообщения: 2946
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

15 мар 2014, 17:11

Логируйте нужный Вам шаги и потом читайте эти самые логи.
Скрипт точно рабочий, только утром архивировал ночную рассылку.


Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
tester123
Сообщения: 5
Зарегистрирован: 29 окт 2013, 20:46

16 мар 2014, 19:44

Данный скрипт успешно работает через smtp gmail, но через smtp сервере моего хостинг провайдера он работать отказывается:

В логах выпрыгивает вот такая вот ошибка:

Код: Выделить всё

18:23:53 system,e-mail,error Error sending e-mail <MikroTik Full Backup (mar/16/2014)>: error connecting to server


Можно было бы списать все на smtp сервак! но самое интересное что на другом микротике этот самый скрипт удачно работает! а на этом на котором я пробую его запустить он перестал работать по не понятным мне причинам!


vqd
Модератор
Сообщения: 3375
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

16 мар 2014, 20:19

Ну причина же написана, ищите по какой причине микрот не может подключится к смтп серверу


Есть интересная задача и бюджет? http://mikrotik.site
Ответить