помогите со скриптом, отслеживать подключение к wi-fi

Обсуждение ПО и его настройки
tr0y
Сообщения: 6
Зарегистрирован: 04 фев 2014, 13:45

04 фев 2014, 14:03

Здравствуйте
гуру, помогите в написании скрипта

если к wi-fi подключен клиент с МАКом из списка то выполнить скрипт

в наличии RB951G-2HnD 5.25


vqd
Модератор
Сообщения: 3593
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

04 фев 2014, 14:21

Код: Выделить всё

if ([/interface wireless registration-table find mac-address=00:81:85:41:95:18] != "") do={/log warning "123" }


Есть интересная задача и бюджет? http://mikrotik.site
tr0y
Сообщения: 6
Зарегистрирован: 04 фев 2014, 13:45

04 фев 2014, 14:34

vqd
спасибо

ну скажем я в планировщике задаю интервал запуска скрипта 3 минуты
тогда каждые 3 минуты он мне будет писать сообщение в лог
а как сделать так что бы в лог писалось только изменённое состояние
что то вроде подключен или отключен


vqd
Модератор
Сообщения: 3593
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

04 фев 2014, 14:37

То есть если МАК не найден то считать его отключенным?


Есть интересная задача и бюджет? http://mikrotik.site
tr0y
Сообщения: 6
Зарегистрирован: 04 фев 2014, 13:45

04 фев 2014, 14:40

vqd писал(а):То есть если МАК не найден то считать его отключенным?

да


vqd
Модератор
Сообщения: 3593
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

04 фев 2014, 14:41

Код: Выделить всё

 if ([/interface wireless registration-table find mac-address=00:81:85:41:95:18] != "") do={/log warning "ON" } else={/log warning "OFF"}


Есть интересная задача и бюджет? http://mikrotik.site
tr0y
Сообщения: 6
Зарегистрирован: 04 фев 2014, 13:45

04 фев 2014, 14:48

спасибо

но, все равно в лог пишется каждый раз при запуска скрипта
а хотелось бы что бы записи появлялись только при изменении с On на Off и обратно


vqd
Модератор
Сообщения: 3593
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

04 фев 2014, 14:50

Ну сделайте флаг и проверяйте его


Есть интересная задача и бюджет? http://mikrotik.site
tr0y
Сообщения: 6
Зарегистрирован: 04 фев 2014, 13:45

04 фев 2014, 14:51

vqd писал(а):Ну сделайте флаг и проверяйте его


так за этим я и пришёл
подскажите как?


vqd
Модератор
Сообщения: 3593
Зарегистрирован: 26 сен 2013, 14:20
Откуда: НСК
Контактная информация:

04 фев 2014, 15:26

Код: Выделить всё

:global mac "00:81:85:41:95:18"
:global OldChek
:global chek
if ([/interface wireless registration-table find mac-address=$mac] != "") do={set chek true} else={set chek false}

if (($chek != $OldChek) and ($chek = true)) do={
/log warning  ($mac . " -ON")
}

if (($chek != $OldChek) and ($chek = false)) do={
/log warning  ($mac . " -OFF")
}

set OldChek $chek


Со списком уже сами :-):


Есть интересная задача и бюджет? http://mikrotik.site
Ответить