IPTV не работает

Обсуждение ПО и его настройки
alliaigo
Сообщения: 17
Зарегистрирован: 13 окт 2013, 12:56

26 ноя 2013, 13:37

Неправильно вам провайдер сказал.

если проще то ставьте 0.0.0.0/0
если не проще то в MFC надо смотреть IP который генерирует 230.200.201.0/24

 Цитирует первый пост полностью, зачем не знаю.
Kazanova2311 писал(а):производил настройку по следующему мануалу:

Как настроить IPTV на MikroTik
08.11.2012

Установка модуля multicast
Настройка IPTV

Установка модуля multicast

Чтобы настроить IPTV на роутерах MikroTik, сначала необходимо установить дополнительный модуль multicast. Для этого выполните следующее:

Перейдите на сайт MikroTik по ссылке http://www.mikrotik.com/download;
Выберите, к какой серии относится ваш роутер;
Выберите версию операционной системы RouterOS, установленную на вашем роутере. Если в списке нет нужной версии, вам потребуется обновить операционную систему роутера до необходимой версии. Как это сделать можно прочитать в инструкции Как обновить MikroTik RouterOS;
Нажмите на ссылку All packages, чтобы скачать дополнительные модули;

Дополнительные модули MikroTik

Распакуйте скаченный архив с модулями;
Откройте в Winbox меню Files;



MikroTik - Меню Files

Перетащите из распакованной папки файл multicast-x.xx-mipsbe.npk в Winbox окно File List.

MikroTik - Скопировать модуль multicast
Откройте меню System - Packages и перетащите файл multicast-x.xx-mipsbe.npk из окна File List в окно Packages List;

MikroTik - Установить модуль multicast
Перезагрузите роутер через меню System - Reboot или через терминал командой system reboot.

После перезагрузки в System - Packages должен появиться модуль multicast.

Модуль multicast в MikroTik


Настройка IPTV

Выполним настройку IPTV на MikroTik.

Откройте меню Routing - IGMP Proxy и нажмите красный плюсик, чтобы указать на какой порт приходит IPTV.

MikroTik - Настройка IPTV multicast

В выпадающем списке Interface выберите WAN порт, к которому подключен кабель интернет провайдера и поставьте галочку Upstream.

В поле Alternative Subnets укажите подсеть стриммеров. Если вы не знаете данные подсети, то попробуйте указать: 10.0.0.0/8, 172.16.0.0/12 и 192.168.0.0/16. Я настраивал IPTV для Maxnet, и у меня все заработало c Alternative Subnets 0.0.0.0/0.

После ввода параметров нажмите кнопку OK.

MikroTik - Настройка входящего WAN порта IPTV

Еще раз нажмите красный плюсик, чтобы указать на какие порты передавать IPTV.

Add

В выпадающем списке Interface выберите порты, на которые нужно пробросить IPTV, поставьте галочку Querier и нажмите кнопку OK. В Interface желательно указывать один конкретный порт, чтобы не было проблем с производительностью роутера.

MikroTik - Настройка исходящих портов IPTV

На этом настройка IPTV на MikroTik окончена. Если вы все правильно настроили, то на вкладке MFC должны пойти пакеты.


У своего провайдера запросил данные по Alternative Subnets. Сказали смотреть в плей листе
часть из этого плейлиста:
#EXTM3U
#EXTINF:0,1Канал
udp://@230.200.201.10:1234
#EXTINF:0,2x2
udp://@230.200.201.222:1234
#EXTINF:0,365 дней
udp://@230.200.201.49:1234
#EXTINF:0,41 Домашний
udp://@230.200.201.185:1234
#EXTINF:0,5 канал
udp://@230.200.201.23:1234
#EXTINF:0,Amazing Life
udp://@230.200.201.16:1234
#EXTINF:0,A-ONE
udp://@230.200.201.241:1234
#EXTINF:0,Bridge TV
udp://@230.200.201.242:1234
#EXTINF:0,Comedy TV
udp://@230.200.201.167:1234
#EXTINF:0,Euronews
udp://@230.200.201.187:1234
#EXTINF:0,Europa Plus
udp://@230.200.201.188:1234
#EXTINF:0,Eurosport
udp://@230.200.201.80:1234
#EXTINF:0,Eurosport2
udp://@230.200.201.36:1234
#EXTINF:0,FOX
udp://@230.200.201.127:1234
#EXTINF:0,Fox Life
udp://@230.200.201.126:1234
#EXTINF:0,Music Box Ru
udp://@230.200.201.194:1234
#EXTINF:0,Nat Geo
udp://@230.200.201.46:1234
#EXTINF:0,Nat Geo Wild
udp://@230.200.201.47:1234
#EXTINF:0,Russian Extreme
udp://@230.200.201.34:1234
#EXTINF:0,Ru TV
udp://@230.200.201.159:1234
#EXTINF:0,STV
udp://@230.200.201.150:1234
#EXTINF:0,АвтоПлюс
udp://@230.200.201.33:1234
#EXTINF:0,Боец
udp://@230.200.201.170:1234
#EXTINF:0,ДТВ (Перец)
udp://@230.200.201.223:1234
#EXTINF:0,Звезда
udp://@230.200.201.13:1234
#EXTINF:0,Знание
udp://@230.200.201.30:1234
#EXTINF:0,Индия ТВ
udp://@230.200.201.151:1234
#EXTINF:0,Интересное ТВ
udp://@230.200.201.29:1234
#EXTINF:0,Карусель
udp://@230.200.201.4:1234
#EXTINF:0,Кино Плюс
udp://@230.200.201.197:1234
#EXTINF:0,КомедияТВ
udp://@230.200.201.8:1234
#EXTINF:0,КухняТВ
udp://@230.200.201.18:1234
#EXTINF:0,КХЛ
udp://@230.200.201.125:1234
#EXTINF:0,Ностальгия
udp://@230.200.201.166:1234
#EXTINF:0,НТВ
udp://@230.200.201.12:1234
#EXTINF:0,ОТВ
udp://@230.200.201.19:1234
#EXTINF:0,ОТР
udp://@230.200.201.205:1234
#EXTINF:0,Охота и рыбалка


Подсеть стримеров взял 230.200.201.0/24 но на вкладке MFC пакеты не идут из правил фаерволла маскарад в локалку. Больше ни каких правил нет. Сеть через бридж(порт Wi-Fi). В чем может быть проблема???

Автора поста прошу впредь без причины не цитировать такие огромные куски кода без спойлера. С уважением, podarok66


Kazanova2311
Сообщения: 16
Зарегистрирован: 14 ноя 2013, 05:15

26 ноя 2013, 15:16

[evgen@MikroTik] > system package print
Flags: X - disabled
# NAME VERSION SCHEDULED
0 X ipv6 6.6
1 multicast 6.6
2 wireless 6.6
3 system 6.6
4 ntp 6.6
5 ppp 6.6
6 hotspot 6.6
7 security 6.6
8 dhcp 6.6
9 advanced-tools 6.6
10 mpls 6.6
11 routeros-mipsbe 6.6
12 routing 6.6


Kazanova2311
Сообщения: 16
Зарегистрирован: 14 ноя 2013, 05:15

26 ноя 2013, 15:19

alliaigo писал(а):Неправильно вам провайдер сказал.

если проще то ставьте 0.0.0.0/0
если не проще то в MFC надо смотреть IP который генерирует 230.200.201.0/24


Пробывал и так 0.0.0.0/0 тоже ничего в MFC не бежит


Аватара пользователя
simpl3x
Модератор
Сообщения: 1532
Зарегистрирован: 19 апр 2012, 14:03

26 ноя 2013, 17:20

Код: Выделить всё

/ip firewall filter export 
сделайте и тут покажите


Kazanova2311
Сообщения: 16
Зарегистрирован: 14 ноя 2013, 05:15

26 ноя 2013, 17:29

[evgen@MikroTik] > /ip firewall filter export
# nov/26/2013 08:31:03 by RouterOS 6.6
# software id = GNAV-KZY9
#
/ip firewall filter
add chain=forward comment="Allow IPTV" in-interface=ether2 protocol=igmp
[evgen@MikroTik] >


Аватара пользователя
simpl3x
Модератор
Сообщения: 1532
Зарегистрирован: 19 апр 2012, 14:03

26 ноя 2013, 18:39

Хм. А /routing igmp-proxy export


Kazanova2311
Сообщения: 16
Зарегистрирован: 14 ноя 2013, 05:15

26 ноя 2013, 18:56

/routing igmp-proxy
set query-interval=1m quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 comment=Upstream interface=ether2 upstream=yes
add comment=Downstream interface=bridge-local
[evgen@MikroTik] >


Аватара пользователя
simpl3x
Модератор
Сообщения: 1532
Зарегистрирован: 19 апр 2012, 14:03

26 ноя 2013, 19:03

тогда еще и /ip address export


Kazanova2311
Сообщения: 16
Зарегистрирован: 14 ноя 2013, 05:15

26 ноя 2013, 19:21

[evgen@MikroTik] > /ip address export
# nov/26/2013 10:23:43 by RouterOS 6.6
# software id = GNAV-KZY9
#
/ip address
add address=212.104.65.42/24 interface=ether2 network=212.104.65.0
add address=192.168.0.1/24 interface=bridge-local network=192.168.0.0


Аватара пользователя
simpl3x
Модератор
Сообщения: 1532
Зарегистрирован: 19 апр 2012, 14:03

26 ноя 2013, 19:58

ну конфиг должен работать.
а включите лог в /system logging там укажите топик igmp-proxy, назначением сделайте файл и попробуйте подписаться на какой нибудь канал. потом гляньте что набежало в файлик.


Ответить