TFTP-server

Обсуждение ОС и пр.
NBAHOB
Сообщения: 1
Зарегистрирован: 28 ноя 2012, 05:28

Re: TFTP-server

Сообщение NBAHOB » 28 ноя 2012, 05:53

Доброго времени суток!
Господа, установил в сеть wtware сервер (192.168.9.8)... указал в настройках DHCP server (он на микротике) next server 192.168.9.8 добавил options name=mytftp code=66 volume=0x0809A8C0,
name=option1 code=67 volume=\5.1.20\wtware.pxe (менял слеши, эффекта нет)
Терминальные станции получают ip, но не могут загрузить TFTP файл....
Как проверить где затык... в микротике или на серваке wtware?
Добавлял name=mytftp1 code=150 volume=0x0809A8C0 нет эффекта
Barvinok
Сообщения: 147
Зарегистрирован: 28 фев 2012, 23:21

Re: TFTP-server

Сообщение Barvinok » 17 дек 2012, 20:00

1. Что это за "volume"?
Если ты задаёшь параметры DHCP-сервера, то там пишешь примерно так:

Код: Выделить всё

/ip dhcp-server option
add code=66 name=TFTP_Server_Name value=0x18C0A80201
add code=67 name=Bootfile-Name value=wtware.pxe

2. Уже в параметрах TFTP пишешь реальный путь к файлу:

Код: Выделить всё

/ip tftp
add allow=yes allow-rollover=no disabled=no ip-addresses=192.168.2.0/24 \
    read-only=yes real-filename=/usb1/tftproot/wtware.pxe req-filename=wtware.pxe

Внимательно прочитай мои предыдущие сообщения и пройдись по ссылкам на Wiki.
Barvinok
Сообщения: 147
Зарегистрирован: 28 фев 2012, 23:21

Re: TFTP-server

Сообщение Barvinok » 17 дек 2012, 21:42

Вот у меня похуже дело - не получает имя файла загрузки по DHCP!
Главное, на домашнем Микротике вроде всё опробировал, а на офисном - в отказ. Настройки через export/import передавал - всё один в один! Но потом и руками перебивал - никакого воздействия.

Код: Выделить всё

/ip dhcp-server option> print                 
 # NAME                                 CODE VALUE                               
 0 BootServer                             66 0x18C0A80301                       
 1 FileName                               67 pxelinux.0

В логах:

Код: Выделить всё

20:45:39 dhcp,warning dhcp1 offering lease 192.168.3.54 for 00:19:DB:D4:XX:XX without success

На экране загружаемого компьютера:

Код: Выделить всё

PXE-E53: No boot filename received

Один и тот-же компьютер дома грузится, а в офисе - нет!
Различие только одно: дома прошивка 5.21, а в офисе - 5.22.
Неужели сломали?
Barvinok
Сообщения: 147
Зарегистрирован: 28 фев 2012, 23:21

Re: TFTP-server

Сообщение Barvinok » 18 дек 2012, 19:54

Позор, позор...
В саппорте меня ткнули носом в параметры next-server и boot-file-name.

Делать нужно примерно так:
/ip dhcp-server network add next-server=192.168.3.1
/ip dhcp-server network add boot-file-name="pxelinux.0"
Barvinok
Сообщения: 147
Зарегистрирован: 28 фев 2012, 23:21

Re: TFTP-server

Сообщение Barvinok » 22 авг 2013, 23:31

NBAHOB писал(а):Господа, установил в сеть wtware сервер (192.168.9.8)... указал в настройках DHCP server (он на микротике) next server 192.168.9.8 добавил options name=mytftp code=66 volume=0x0809A8C0,
name=option1 code=67 volume=\5.1.20\wtware.pxe (менял слеши, эффекта нет)
Терминальные станции получают ip, но не могут загрузить TFTP файл....
Как проверить где затык... в микротике или на серваке wtware?

Кажись, могу твоему горю пособить.
1. Скачиваешь tftpd32 в архиве и запускаешь его на своём сервере (предварительно останавливаешь "Сервер служб развёртывания Windows", если он у тебя запущен).
2. Запускаешь и в настройках выключаешь всё, кроме TFTP Server и Syslog server
3. На Микротике создаёшь параметр для файла загрузки:

Код: Выделить всё

/ip dhcp-server option
add code=67 name=BootFilename value="'WTWare\\5.1.18\\wtware.pxe'"

4. Включаешь свой терминал и смотришь Log View.
Я, к примеру, увидел следующее:
Mikrotik_TFTP_v.png
(36.57 КБ) 0 скачиваний

Потом подгоняешь реальное название файла к тому, что запрашивает у тебя терминал и вуаля!
В общем, всё просто ;)

Вернуться в «MikroTik RouterOS»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость