Приоритеты

Обсуждение ОС и пр.
KARaS'b
Сообщения: 378
Зарегистрирован: 29 сен 2011, 09:16

Приоритеты

Сообщение KARaS'b » 12 дек 2011, 12:34

Не знаю на кого, или что грешить но столкнулся с проблемой - есть rb750gl (роутерос5.9), пара-тройка людей которых он выпускает в инет и файловый сервер который качает и раздает торренты, а самое главное доступ до этого файлового сервера извне(рдп, и два вэбинтерфейса). Все вроде бы работало пока дело не дошло до дела: скорость закачки и отдачи была установлена непосредственно в уторренте и практика показала что при этом по каким то причинам через неопределенное время переставал работать DDNS, если быть точным, то при наличии нескольких закачек, особенно большого объема(канал всего 3,5-4,5 мегабита), а соответственно и времени, скрипт дднса(взят из вики) почему то не обновлял внешний IP в текстовом файле на тике и как результат DDNS не работал. Методом тыка было было установлено что если ограничить скорость файловому серверу непосредственно на тике, а не в уторренте, то проблема отпадает. Как я понимаю из за плотного трафика дднс просто не мог передать данные?(хотя почему тогда в текстовом файле на тике не обновлялся ip, даже при повторном ручном запуске и даже если удалить файлик он заного создавался только при перезагрузке тика или если выдернуть "хвост" из ван порта)
В обще скорость ограничил и столкнулся с проблемой новой - при нескольких активных закачках, начиная примерно от 2х и более закачек, извне невозможно достучаться до "файлопомйки", торренты настолько забивают заданный(ограниченный) канал что на любые попытки хоть как то попасть на файлопомойку просто ничего не происходит. Замучив гугл понял что надо приоритезировать трафик, но не нашел ни одной статьи где отдельно решался бы этот вопрос, везде за компанию начинают резать и делить скорость и момент непосредственной разметки и приоритезации мне уловить не удалось.
Посему очень прошу помощи здесь!
И к слову так много воды написал в надежде на то что может проблемы с DDNSом можно решить иным способом
Вот сам скрипт которым воспользовался
# Set needed variables
:local username "davidsoundeffects"
:local password "tyler2468"
:local hostname "gordonnewport.dyndns.org"

:global dyndnsForce
:global previousIP

# print some debug info
:log info ("UpdateDynDNS: username = $username")
:log info ("UpdateDynDNS: password = $password")
:log info ("UpdateDynDNS: hostname = $hostname")
:log info ("UpdateDynDNS: previousIP = $previousIP")

# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:local result [/file get dyndns.checkip.html contents]

# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "</body>" -1]
:local currentIP [:pick $result $startLoc $endLoc]
:log info "UpdateDynDNS: currentIP = $currentIP"

# Remove the # on next line to force an update every single time - useful for debugging,
# but you could end up getting blacklisted by DynDNS!

#:set dyndnsForce true

# Determine if dyndns update is needed
# more dyndns updater request details http://www.dyndns.com/developers/specs/syntax.html

:if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
:set dyndnsForce false
:set previousIP $currentIP
:log info "$currentIP or $previousIP"
/tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
src-path="nic/update?system=dyndns&hostname=$hostname&myip=$currentIP&wildcard=no" \
dst-path="/dyndns.txt"
:local result [/file get dyndns.txt contents]
:log info ("UpdateDynDNS: Dyndns update needed")
:log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
:put ("Dyndns Update Result: ".$result)
} else={
:log info ("UpdateDynDNS: No dyndns update needed")
}

/system scheduler add name=dynDNS interval=00:01 on-event="/system script run dynDns\r\n"
KARaS'b
Сообщения: 378
Зарегистрирован: 29 сен 2011, 09:16

Re: Приоритеты

Сообщение KARaS'b » 13 дек 2011, 09:03

В принципе нашел много интересного и более понятного чем на просторах тырнета в вики по тику. Но если поможете выдать максимальный приоритет трафику на портах 3389, 9091, ну и 80, то буду крайне признателен!
iSupport
Сообщения: 2439
Зарегистрирован: 06 фев 2011, 20:44

Re: Приоритеты

Сообщение iSupport » 13 дек 2011, 11:40

советую обратиться к этой http://wiki.mikrotik.com/wiki/%D0%97%D0 ... 0%B7%D0%B8 статье

там описано про несколько вариантов реализации приоритетов


Я бы посоветовал режим simple queue
либо PCQ http://wiki.mikrotik.com/wiki/%D0%A0%D1 ... 0%B8_-_PCQ


Еще можно почитать http://wiki.mikrotik.com/images/8/8d/Qo ... v.2%29.pdf это русский перевод семинара по QoS
Граждане, сколько раз просил =) чем понятнее и точнее сформулирован вопрос - тем понятнее и точнее будет на него ответ.
Я просматриваю ВСЕ темы форума и стараюсь помочь в каждой из них
Поэтому, НА ЛС отвечаю в последнюю очередь

Вернуться в «MikroTik RouterOS»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость