Скрипты, ошибка?

Обсуждение оборудования и его настройки
trikachuka
Сообщения: 2
Зарегистрирован: 10 сен 2012, 15:57

Скрипты, ошибка?

Сообщение trikachuka » 10 сен 2012, 16:06

Всем привет!

:local j;
:local L2TPNAME;
:local listADDRESS;

:foreach j in=[/interface l2tp-server find] do={
:set L2TPNAME [/interface l2tp-server get $j name];
:if ([/interface l2tp-server get $j running]=false) do={
:set listADDRESS [/ip firewall address-list get [find list=$L2TPNAME] address];
:if ($listADDRESS!=0.0.0.0) do={
/ip firewall address-list set [find list=$L2TPNAME] address=0.0.0.0;
};
};
};

Скрипт ищет интерфейсы ВПН пользователей l2tp-server,
если интерфейс в дауне, юзер отключен, то обнуляем список.
Проблема в том, что не находит "половину интерфейсов l2tp-server"
ПОЧЕМУ?
trikachuka
Сообщения: 2
Зарегистрирован: 10 сен 2012, 15:57

Re: Скрипты, ошибка?

Сообщение trikachuka » 11 сен 2012, 08:02

Исправленный скрипт:

:local j;
:local i;
:local L2TPNAME;
:local listADDRESS;

:foreach j in=[/interface l2tp-server find] do={
:set L2TPNAME [/interface l2tp-server get $j name];
:if ([/interface l2tp-server get $j running] = false) do={
:foreach i in=[/ip firewall address-list find list=$L2TPNAME] do={ <---------------------------------
:set listADDRESS [/ip firewall address-list get $i address]; <---------------------------------
};
:if ($listADDRESS!=0.0.0.0) do={
/ip firewall address-list set [find list=$L2TPNAME] address=0.0.0.0;
};
};
};

[q]:set listADDRESS [/ip firewall address-list *****get [find list=$L2TPNAME] address];*****
:if ($listADDRESS!=0.0.0.0) do={
/ip firewall address-list set [find list=$L2TPNAME] address=0.0.0.0;[/q]


get find сбивал SID почемуто

Вернуться в «MikroTik RouterBOARD»

Кто сейчас на конференции

Сейчас этот форум просматривают: dima1208 и 1 гость