Настройка двух 3G и другие грабли..

Обсуждение ОС и пр.
nordik
Сообщения: 8
Зарегистрирован: 06 июн 2012, 09:15

Настройка двух 3G и другие грабли..

Сообщение nordik » 06 сен 2012, 17:08

Добрый день!
Имеем 2 RouterBOARD 433UAH и 2 usb соска мегофона
Задачи : чтоб к одной из железок приходил интет , и она раздовала этот инет в локалку через свич - реализовано
во второй микротик прошивка 6.0 вставлены 2 usb соска и он должен раздавать инет только 6 компам (по 3 пользывателя на сосок , привязаны жёстко ) а уеростальных была только локалка
переключение будет происходить физическим переключением свича из одного микротика в другой .
настройки микротика с сосками:
Изображение
Изображение
на 2 интерфейсе настроен dhcp дл подключения свича
Проблемы:
В начале хотел прописать на компах статику в пределах dhcp
но как только менял на статику прекращялся обмен между компами и микротиком .
пытался через arp таблицу прописать ip , запись сохранялась но выдавался дуругой ip

забил пока на это болт
пытался прописать правила как в скрине то не ходят компы в инет , но если пописываю в 1 из правил !перед ip то все компы ходят в инет не зависимо от ip
мб конечно дело в новой прошике , но скорее всего в моих кривых руках....
буду рад реальным советом а не отправкой на поиск - (искал )
iSupport
Сообщения: 2439
Зарегистрирован: 06 фев 2011, 20:44

Re: Настройка двух 3G и другие грабли..

Сообщение iSupport » 07 сен 2012, 09:42

смотрите

ip dhcp-server - leases

там можно сделать статические записи чтоб компам раздавался ип с жжесткой привязкой

затем сделайте 2 группы ip - адресов

ip firewall adress list

Route_USB1

и

Route_USB2

в первой 3 айпишника и во второй 3 айпишника
---------


правила файерволла на mascarade

chain input src-adress-list = Route_USB1 action mascarade

chain input src-adress-list = Route_USB2 action mascarade

правила файрвола на роутинг

add chain=prerouting src-address-list=Route_USB 1action=mark-routing new-routing-mark=route_USB1 passthrough=no
add chain=prerouting src-address-list=Route_USB2 action=mark-routing new-routing-mark=route_USB2 passthrough=no


правила в ip route
add dst-address=0.0.0.0/0 gateway=ppp1 scope=255 target-scope=10 routing-mark=route_USB1
add dst-address=0.0.0.0/0 gateway=ppp2 scope=255 target-scope=10 routing-mark=rroute_USB1


таким образом ходить в интернет будут только те кто в листах

Идея и основа взята отсюда http://mikrotik.axiom-pro.ru/scripts/balancerv1.php
Граждане, сколько раз просил =) чем понятнее и точнее сформулирован вопрос - тем понятнее и точнее будет на него ответ.
Я просматриваю ВСЕ темы форума и стараюсь помочь в каждой из них
Поэтому, НА ЛС отвечаю в последнюю очередь
nordik
Сообщения: 8
Зарегистрирован: 06 июн 2012, 09:15

Re: Настройка двух 3G и другие грабли..

Сообщение nordik » 07 сен 2012, 09:54

спс
буду пробывать
nordik
Сообщения: 8
Зарегистрирован: 06 июн 2012, 09:15

Re: Настройка двух 3G и другие грабли..

Сообщение nordik » 07 сен 2012, 10:31

затем сделайте 2 группы ip - адресов

ip firewall adress list

Route_USB1

и

Route_USB2

в первой 3 айпишника и во второй 3 айпишника


сделал


правила файерволла на mascarade

chain input src-adress-list = Route_USB1 action mascarade

chain input src-adress-list = Route_USB2 action mascarade


с этим не понял

Изображение


правила файрвола на роутинг

add chain=prerouting src-address-list=Route_USB 1action=mark-routing new-routing-mark=route_USB1 passthrough=no
add chain=prerouting src-address-list=Route_USB2 action=mark-routing new-routing-mark=route_USB2 passthrough=no


правила в ip route
add dst-address=0.0.0.0/0 gateway=ppp1 scope=255 target-scope=10 routing-mark=route_USB1
add dst-address=0.0.0.0/0 gateway=ppp2 scope=255 target-scope=10 routing-mark=rroute_USB1



дальше не понял , где это прописывать (в каких меню )
p.s. работаю через винбокс
podarok66
Модератор
Сообщения: 2865
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Re: Настройка двух 3G и другие грабли..

Сообщение podarok66 » 07 сен 2012, 22:53

с этим не понял

В IP=> Firewall вкладка NAT, а не Filter Rules. "Маскарадить" именно там...

Дальше там два правила вам советуют, их на вкладке Mangle

И последние два правила IP=>Routes

А вообще, с терминалом в таких случаях проще работать, просто пишите подсказанное правило в терминале, подставляя свои имена и все сразу прописывается по местам... Впрочем, кому как удобнее.
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
iSupport
Сообщения: 2439
Зарегистрирован: 06 фев 2011, 20:44

Re: Настройка двух 3G и другие грабли..

Сообщение iSupport » 08 сен 2012, 12:14

Момент в том, что я писал ответ с андроид-планшета, поэтому мог немного накосячить в синтаксисе

Поэтому правила эти всетаки лучше создавать через винбокс

Разделы Вам подсказали верно
Граждане, сколько раз просил =) чем понятнее и точнее сформулирован вопрос - тем понятнее и точнее будет на него ответ.
Я просматриваю ВСЕ темы форума и стараюсь помочь в каждой из них
Поэтому, НА ЛС отвечаю в последнюю очередь
nordik
Сообщения: 8
Зарегистрирован: 06 июн 2012, 09:15

Re: Настройка двух 3G и другие грабли..

Сообщение nordik » 08 сен 2012, 13:04

спс , щяс попробую
nordik
Сообщения: 8
Зарегистрирован: 06 июн 2012, 09:15

Re: Настройка двух 3G и другие грабли..

Сообщение nordik » 10 сен 2012, 14:23

не идёт...



[admin@MikroTik] /ip firewall mangle> print
Flags: X - disabled, I - invalid, D - dynamic
0 X chain=src-adress-list action=accept src-address-list=usb1

1 X chain=src-adress-list action=accept src-address-list=usb2

2 chain=prerouting action=mark-routing new-routing-mark=usb1 passthrough=no
src-address-list=usb1

3 chain=prerouting action=mark-routing new-routing-mark=usb2 passthrough=no
src-address-list=usb2


________________________________

[admin@MikroTik] /ip firewall address-list> print
Flags: X - disabled, D - dynamic
# LIST ADDRESS
0 usb1 192.168.3.10
1 usb2 192.168.3.12

________________________________


[admin@MikroTik] /ip firewall nat> print
Flags: X - disabled, I - invalid, D - dynamic
0 chain=srcnat action=masquerade src-address-list=usb1

1 chain=srcnat action=masquerade src-address-list=usb2
[admin@MikroTik] /ip firewall nat>


________________________________

[admin@MikroTik] /ip route> print
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 A S 0.0.0.0/0 ppp-out1 1
1 A S 0.0.0.0/0 ppp-out2 1
2 ADS 0.0.0.0/0 10.112.112.122 1
3 DS 0.0.0.0/0 10.112.112.123 1
4 ADC 10.112.112.122/32 10.106.33.141 ppp-out1 0
5 ADC 10.112.112.123/32 172.29.91.63 ppp-out2 0
6 ADC 192.168.3.0/24 192.168.3.1 ether2 0


________________________________


[admin@MikroTik] /interface> print
Flags: D - dynamic, X - disabled, R - running, S - slave
# NAME TYPE MTU L2MTU MAX-L2MTU
0 X wlan1 wlan 1500
1 R ether1 ether 1500 1526 1526
2 R ether2 ether 1500 1522 1522
3 ether3 ether 1500 1522 1522
4 R ppp-out1 ppp-out 1500
5 R ppp-out2 ppp-out
[admin@MikroTik] /interface>



________________________________



Подскажите что подкрутить плз
nordik
Сообщения: 8
Зарегистрирован: 06 июн 2012, 09:15

Re: Настройка двух 3G и другие грабли..

Сообщение nordik » 10 сен 2012, 16:45

есть удалёнка на терминал где висит микротик
iSupport
Сообщения: 2439
Зарегистрирован: 06 фев 2011, 20:44

Re: Настройка двух 3G и другие грабли..

Сообщение iSupport » 12 сен 2012, 13:24

Киньте мне в ЛС данные по удаленке, сегодня после 20-00 посмотрю
Граждане, сколько раз просил =) чем понятнее и точнее сформулирован вопрос - тем понятнее и точнее будет на него ответ.
Я просматриваю ВСЕ темы форума и стараюсь помочь в каждой из них
Поэтому, НА ЛС отвечаю в последнюю очередь

Вернуться в «MikroTik RouterOS»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость