Скрипт динамической смены пароля

Обсуждение оборудования и его настройки
M1chA
Сообщения: 153
Зарегистрирован: 05 мар 2012, 11:35

Скрипт динамической смены пароля

Сообщение M1chA » 22 авг 2012, 14:49

На торговой точке планируется поставить Rb751.
Продаваец должен закачивать в телефоны покупателям всякий софт, но не хочется чтобы все кому не лень пользовались нашим Интернетом. Поэтому хочу создать скрипт который раз в день будет брать пароль из файлика "passwd" который будет лежать в "files" Формат файла будет такой: ОДИН ПАРОЛЬ ОДНА СТРОКА. Возможно это реализовать? Если да, то в какую сторону копать?
Аватара пользователя
DeN_238
Сообщения: 287
Зарегистрирован: 19 фев 2012, 16:42
Откуда: Тольятти

Re: Скрипт динамической смены пароля

Сообщение DeN_238 » 22 авг 2012, 15:13

Возможно, по аналогии с http://wiki.mikrotik.com/wiki/Manual:Sc ... pp_secrets
2011UAS-2HnD-IN | v. 6.37.1 | FW 3.33
mAP 2n | v. 6.36.3 | FW 3.24
M1chA
Сообщения: 153
Зарегистрирован: 05 мар 2012, 11:35

Re: Скрипт динамической смены пароля

Сообщение M1chA » 22 авг 2012, 15:40

DeN_238 писал(а):Возможно, по аналогии с http://wiki.mikrotik.com/wiki/Manual:Sc ... pp_secrets


ХЗ, что-то непонятно,как и откуда скрипт перебор делает...
Аватара пользователя
DeN_238
Сообщения: 287
Зарегистрирован: 19 фев 2012, 16:42
Откуда: Тольятти

Re: Скрипт динамической смены пароля

Сообщение DeN_238 » 22 авг 2012, 16:09

Что там не понятного? Или вам нужно готовое решение под вашу задачу?
Парсинг текстовика там предельно ясно описан. В любом случае, основа та.
2011UAS-2HnD-IN | v. 6.37.1 | FW 3.33
mAP 2n | v. 6.36.3 | FW 3.24
podarok66
Модератор
Сообщения: 2859
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Re: Скрипт динамической смены пароля

Сообщение podarok66 » 22 авг 2012, 22:35

ХЗ, что-то непонятно,как и откуда скрипт перебор делает...

Так вот вроде все понятно:

Код: Выделить всё

:global content [/file get [/file find name=test.txt] contents] ;
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
M1chA
Сообщения: 153
Зарегистрирован: 05 мар 2012, 11:35

Re: Скрипт динамической смены пароля

Сообщение M1chA » 23 авг 2012, 10:16

DeN_238 писал(а):Что там не понятного? Или вам нужно готовое решение под вашу задачу?
Парсинг текстовика там предельно ясно описан. В любом случае, основа та.


А что, есть готовое решение :D ?

Код: Выделить всё

:global content [/file get [/file find name=test.txt] contents] ;


Это понятно,находим файл с именем test.txt

Нам на данном примере нужно вставить пароль (janis,123,1.1.1.1,2.2.2.1,ppp_profile,myService) 123 в ppp соединение.


Объявляем локальную переменную Array[/code]

Код: Выделить всё

  :local tmpArray [:toarray $line] ;
   :if ( [:pick $tmpArray 0] != "" ) do={
   :put $tmpArray;


Открываем соединение ppp

Код: Выделить всё

 /ppp secret add name=[:pick $tmpArray 0] password=[:pick $tmpArray 1] \
             local-address=[:pick $tmpArray 2] remote-address=[:pick $tmpArray 3] \
             profile=[:pick $tmpArray 4] service=[:pick $tmpArray 5];


Откуда скрипт знает что нужно куда подставлять?
Аватара пользователя
DeN_238
Сообщения: 287
Зарегистрирован: 19 фев 2012, 16:42
Откуда: Тольятти

Re: Скрипт динамической смены пароля

Сообщение DeN_238 » 23 авг 2012, 13:33

Эммм, ну как бы
password=[:pick $tmpArray 1]
намекает :-)
Вы попробуйте, а там видно будет :-)
2011UAS-2HnD-IN | v. 6.37.1 | FW 3.33
mAP 2n | v. 6.36.3 | FW 3.24
podarok66
Модератор
Сообщения: 2859
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Re: Скрипт динамической смены пароля

Сообщение podarok66 » 23 авг 2012, 18:35

janis,123,1.1.1.1,2.2.2.1,ppp_profile,myService

Код: Выделить всё

name=[:pick $tmpArray 0] password=[:pick $tmpArray 1] \
             local-address=[:pick $tmpArray 2] remote-address=[:pick $tmpArray 3] \
             profile=[:pick $tmpArray 4] service=[:pick $tmpArray 5]


Смотрите, запятая в текстовом файле используется как разделитель. Нумерация начинается с 0, как это обычно в Linux. То есть

Код: Выделить всё

local-address=[:pick $tmpArray 2]
это третья позиция в строке...
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
iSupport
Сообщения: 2439
Зарегистрирован: 06 фев 2011, 20:44

Re: Скрипт динамической смены пароля

Сообщение iSupport » 23 авг 2012, 22:45

Я бы писал на рнр а потом по SSH или через ip заливал бы пароль в микротик
Граждане, сколько раз просил =) чем понятнее и точнее сформулирован вопрос - тем понятнее и точнее будет на него ответ.
Я просматриваю ВСЕ темы форума и стараюсь помочь в каждой из них
Поэтому, НА ЛС отвечаю в последнюю очередь

Вернуться в «MikroTik RouterBOARD»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей