Настройка IPTV на MikroTik RB751G-2HnD

Обсуждение оборудования и его настройки
antkamidiv
Сообщения: 123
Зарегистрирован: 22 мар 2012, 18:28
Контактная информация:

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение antkamidiv » 14 авг 2012, 01:15

Значит нужно прописать 239.1.1.0/24. Это следует из представленного списка каналов.
Повторюсь с учетом новой инфы:

Забиваем в терминале...
1. /routing igmp-proxy interface add alternative-subnets="239.1.1.0/24" comment="Upstream" disabled=no interface="имя WAN интерфейса" threshold=1 upstream=yes
2. /routing igmp-proxy interface add alternative-subnets="" comment="Downstream" disabled=no interface="имя LAN интерфейса" threshold=1 upstream=no
3. Разрешить протокол igmp в firewall, если блочишь его. Правило должно идти раньше блокирующего.
/ip firewall filter add chain=input action=accept protocol=igmp in-interface="имя WAN интерфейса" comment="Allow IGMP"
sirota
Сообщения: 16
Зарегистрирован: 09 авг 2012, 14:06

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение sirota » 14 авг 2012, 10:01

во втором пункте так и должно быть две кавычки (alternative-subnets="" comment)? А то я исправил.
Я так понял в Winbox в routing/ igmp-proxy должно появится две записи и одна на вкладке firewall,
а можно узнать какие записи должны появится и какие должны стоять отметки.
Подскажите, пожалуйста, потому-что "239.1.1.0/24" я уже пробовал ставить, но ничего не получилось.
Вот что я забивал в Winbox
на первый порт приходит кабель провайдера, на второй подключен стационарный комп.
1. /routing igmp-proxy interface add alternative-subnets="239.1.1.0/24" comment="Upstream" disabled=no interface="ether1" threshold=1 upstream=yes

2. /routing igmp-proxy interface add alternative-subnets=" comment="downstream" disabled=no interface="ether2" threshold=1 upstream=no

3. /ip firewall filter add chain=input action=accept protocol=igmp in-interface="ether1" comment="allow IGMP"
antkamidiv
Сообщения: 123
Зарегистрирован: 22 мар 2012, 18:28
Контактная информация:

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение antkamidiv » 14 авг 2012, 12:05

Удалите все строчки, появившиеся в IGMP Proxy (Winbox -> Routing -> IGMP Proxy), и правило фаервола с комментарием allow IGMP
Далее так:
1. /routing igmp-proxy interface add alternative-subnets=239.1.1.0/24 comment=Upstream disabled=no interface=ether1 threshold=1 upstream=yes
2. /routing igmp-proxy interface add comment=Downstream disabled=no interface=ether2 threshold=1 upstream=no
3. /ip firewall filter add chain=input action=accept protocol=igmp in-interface=ether1 comment=Allow IGMP
sirota
Сообщения: 16
Зарегистрирован: 09 авг 2012, 14:06

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение sirota » 15 авг 2012, 08:28

Спасибо Вам за помощь, но настроить работу IPTV мне не удалось
После вбивания в роутер указанных Вами в последнем сообщении команд в Route - IGMP Proxy – появилось 2 записи
п. 3. - /ip firewall filter add chain=input action=accept protocol=igmp in-interface=ether1 comment=Allow IGMP не проходит, пишет ошибку expected end of command (line 1 column 99)
Я вбил предыдущий вариант, на вкладке IP-Firewall появилась разрешающая запись, но IPTV не работает
В сети нашёл рекомендации по настройке IPTV, но они краткие и я не могу разобраться, посмотрите пожалуйста.
непонятен п.3,5. Какие IP вбивать в п.3 (приложение к сообщению)
Первоначальные настройки роутера я производил согласно сайта http://www.technotrade.com.ua/Articles/ ... wall_setup
Вот какие рекомендации мне удалось найти:
1-2. Route - IGMP Proxy - 2 записи.
3. IP-Route - добавляем маршрут на локалку
4. IP-Firewall-Filter - разрешающее правило на локалку. Или пока все отключить.
5. IP-Firewal-NAT - Out Interface пустой
6. WiFi - WMM support включить
Вложения
настройка IPTV.jpg
настройка IPTV.jpg (78.51 КБ) 211 просмотров
antkamidiv
Сообщения: 123
Зарегистрирован: 22 мар 2012, 18:28
Контактная информация:

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение antkamidiv » 15 авг 2012, 08:47

По п.3
Простите. В пылу затирания ковычек стер нужные :D Правильно так
/ip firewall filter add chain=input action=accept protocol=igmp in-interface=ether1 comment="Allow IGMP"

Только давайте вообще все запрещающие правила в фаерволе уберите.
antkamidiv
Сообщения: 123
Зарегистрирован: 22 мар 2012, 18:28
Контактная информация:

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение antkamidiv » 15 авг 2012, 08:55

И если не выйдет, то в первой строке IGMP Proxy замените 239.1.1.0/24 на 0.0.0.0/0
sirota
Сообщения: 16
Зарегистрирован: 09 авг 2012, 14:06

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение sirota » 15 авг 2012, 12:17

Выполнить указанное Вами я смогу позже, отпишусь.
А сейчас я хотел сказать, что на вкладке IP-Firewall-Filter записи есть, но слово IGMP нигде не просматривается.
Стоит ли убирать все записи, потом не поставлю.
Выше какой записи тогда должна стоять разрешающая запись, потому что команда указанная Вами в п.3 прописывается в самом низу.
Вечером скину экранку с вкладки IP-Firewall-Filter может посмотрите?
И вот ещё посмотрите пожалуйста ссылку, может ещё чего надо добавить, чтобы IPTV заработало.
http://aboutmikrotik.info/publ/avtorski ... n/7-1-0-68
sirota
Сообщения: 16
Зарегистрирован: 09 авг 2012, 14:06

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение sirota » 16 авг 2012, 08:20

Ваши рекомендации не помогли.
Изменял IP адрес на 0.0.0.0/0 и удалял все правила в Firewall, разрешал UDP, IGMP.
Не работает!
Вот скрины, посмотрите пожалуйста.
Вложения
firewall.jpg
(146.52 КБ) 30 скачиваний
IGMP Proxy.jpg
(89.54 КБ) 30 скачиваний
antkamidiv
Сообщения: 123
Зарегистрирован: 22 мар 2012, 18:28
Контактная информация:

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение antkamidiv » 16 авг 2012, 09:33

Последнее правило Allow IGMP (номер 8) должно стоять до правила номер 3.
antkamidiv
Сообщения: 123
Зарегистрирован: 22 мар 2012, 18:28
Контактная информация:

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение antkamidiv » 16 авг 2012, 09:34

и что за правило forward? номер 4

Вернуться в «MikroTik RouterBOARD»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость