Настройка IPTV на MikroTik RB751G-2HnD

Обсуждение оборудования и его настройки
sirota
Сообщения: 16
Зарегистрирован: 09 авг 2012, 14:06

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение sirota » 13 авг 2012, 00:41

antkamidiv
ты где? я всё обновил! Хочу настроить IPTV, помоги пожалуйста.
antkamidiv
Сообщения: 123
Зарегистрирован: 22 мар 2012, 18:28
Контактная информация:

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение antkamidiv » 13 авг 2012, 09:55

Здесь я :D
Забиваем в терминале...
1. /routing igmp-proxy interface add alternative-subnets="сети провайдера для вещания(пример записи 231.23.110.0/24)" comment="Upstream" disabled=no interface="имя WAN интерфейса" threshold=1 upstream=yes
2. /routing igmp-proxy interface add alternative-subnets="" comment="Downstream" disabled=no interface="имя LAN интерфейса" threshold=1 upstream=no
3. Разрешить протокол igmp в firewall, если блочишь его. Правило должно идти раньше блокирующего.
/ip firewall filter add chain=input action=accept protocol=igmp in-interface="имя WAN интерфейса" comment="Allow IGMP"
sirota
Сообщения: 16
Зарегистрирован: 09 авг 2012, 14:06

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение sirota » 13 авг 2012, 10:52

Забиваем в терминале это вносим в командную строку New Terminal команду указанную в п.1 и 2?
В п.2 "имя LAN интерфейса", какой пример внесения информации? :?
Тоже по п.3, куда вносить информацию можно поподробней.
antkamidiv
Сообщения: 123
Зарегистрирован: 22 мар 2012, 18:28
Контактная информация:

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение antkamidiv » 13 авг 2012, 13:26

1. Запускаем winbox
2. Там открываем New Terminal
3. Копируем каждую команду, там редактируем под свои параметры и нажимаем Enter

По умолчанию LAN интерфейс носит название ether2-local-master

Смотрите имена интерфейсов в пункте Interface в Winbox.
sirota
Сообщения: 16
Зарегистрирован: 09 авг 2012, 14:06

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение sirota » 13 авг 2012, 14:45

в п.1 "сети провайдера для вещания(пример записи 231.23.110.0/24)"
Я открыл файл программы вещания vega.m3u и там увидел IP адреса вещания каналов 239.1.1.1/34
будет ли правильно?
Можно ли вместо 34 поставить например 54, чтобы видеть появление новых каналов?
antkamidiv
Сообщения: 123
Зарегистрирован: 22 мар 2012, 18:28
Контактная информация:

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение antkamidiv » 13 авг 2012, 15:14

34 быть не может!!! Максимальное значение маски 32. Так что и значение 54 отпадает.
Маска подсети 32 включает один ip адрес. Соответственно это один канал.
О сетях вещания надо узнать у провайдера!!!
Аватара пользователя
Dragon_Knight
Модератор
Сообщения: 1195
Зарегистрирован: 26 мар 2012, 18:21
Откуда: МО, Мытищи
Контактная информация:

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение Dragon_Knight » 13 авг 2012, 15:38

Если IP одинаковый у всех каналов, то вероятнее всего 34 это что-то типа точки монтирования.
В таком случае добавить нужно тока 1 IP 239.1.1.1/32.


ps. А лучше киньте сюда плейлист :)

Помощь в настройке оборудования MikroTik, Мытищи, Москва.
Дома: [RouterBOARD CCR1009-8G-1S-1S+] + [RouterBOARD cAP 2n] + [RouterBOARD Groove A-2Hn-32] + [D-Link ANT24-0800];
Работа 1: [RouterBOARD RB493G] + [MikroTik R52H] + [MikroTik CA493] + [D-Link ANT24-0800] + [RouterBOARD SXT G-2HnD];
Работа 2: [RouterBOARD RB2011UiAS-IN];
Резерв: [RouterBOARD RB450G];
antkamidiv
Сообщения: 123
Зарегистрирован: 22 мар 2012, 18:28
Контактная информация:

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение antkamidiv » 13 авг 2012, 15:40

Dragon_Knight прав. Точно может быть один ip. А вот каналы по портам разбросаны. :)
Просто добавьте 239.1.1.1/32.
sirota
Сообщения: 16
Зарегистрирован: 09 авг 2012, 14:06

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение sirota » 14 авг 2012, 00:08

Указанное выше не помогло, не работает.
адрес каналов IpTV обозначается от "239.1.1.1:1234" ...до "239.1.1.34:1234"
Я посмотрел в igmp-proxy interface так там после ввода команды alternative-subnets прописывается как "239.1.1.1" и всё, а /32 не прописывается.
sirota
Сообщения: 16
Зарегистрирован: 09 авг 2012, 14:06

Re: Настройка IPTV на MikroTik RB751G-2HnD

Сообщение sirota » 14 авг 2012, 00:35

Вот плейлист
#EXTM3U url-tvg="http://213.227.207.87/jtv_utc2.zip" m3uautoload=1 cache=1000 deinterlace=1 tvg-shift=0

#EXTINF:-1 tvg-name="Канал 2+2",2+2
udp://@239.1.1.1:1234
#EXTINF:-1 tvg-name="УТ-1",УТ-1
udp://@239.1.1.2:1234
#EXTINF:-1 tvg-name="ТЕТ",ТЕТ
udp://@239.1.1.3:1234
#EXTINF:-1 tvg-name="NewsOne",News One
udp://@239.1.1.4:1234
#EXTINF:-1 tvg-name="Первый Автомобильный",Первый Автомобильный
udp://@239.1.1.5:1234
#EXTINF:-1 tvg-name="RU music",RU music
udp://@239.1.1.6:1234
#EXTINF:-1 tvg-name="5 канал",5 канал
udp://@239.1.1.7:1234
#EXTINF:-1 tvg-name="Канал 1+1",1+1
udp://@239.1.1.8:1234
#EXTINF:-1 tvg-name="Интер",Интер
udp://@239.1.1.10:1234
#EXTINF:-1 tvg-name="Новый канал",Новый канал
udp://@239.1.1.12:1234
#EXTINF:-1 tvg-name="СТБ",СТБ
udp://@239.1.1.13:1234
#EXTINF:-1 tvg-name="НТН",НТН
udp://@239.1.1.14:1234
#EXTINF:-1 tvg-name="К1",К1
udp://@239.1.1.15:1234
#EXTINF:-1 tvg-name="М-1",М-1
udp://@239.1.1.16:1234
#EXTINF:-1 tvg-name="Тонис",Тонис
udp://@239.1.1.17:1234
#EXTINF:-1 tvg-name="Мега",Мега
udp://@239.1.1.18:1234
#EXTINF:-1 tvg-name="MTV-Украина",MTV-Украина
udp://@239.1.1.19:1234
#EXTINF:-1 tvg-name="К2",К2
udp://@239.1.1.20:1234
#EXTINF:-1 tvg-name="Первый Деловой",Первый Деловой
udp://@239.1.1.21:1234
#EXTINF:-1 tvg-name="СИТИ",СИТИ
udp://@239.1.1.22:1234
#EXTINF:-1 tvg-name="Канал 24",Канал 24
udp://@239.1.1.23:1234
#EXTINF:-1 tvg-name="ТВi",ТВi
udp://@239.1.1.24:1234
#EXTINF:-1 tvg-name="Music Box UA",Music Box UA
udp://@239.1.1.25:1234
#EXTINF:-1 tvg-name="Меню ТВ",Меню ТВ
udp://@239.1.1.26:1234
#EXTINF:-1 tvg-name="Гумор ТВ",Гумор ТВ
udp://@239.1.1.27:1234
#EXTINF:-1 tvg-name="Гамма",Гамма
udp://@239.1.1.28:1234
#EXTINF:-1 tvg-name="УБР",УБР
udp://@239.1.1.32:1234
#EXTINF:-1 tvg-name="Enter-фильм",Enter-фильм
udp://@239.1.1.33:1234
#EXTINF:-1 tvg-name="Enter",Enter
udp://@239.1.1.34:1234
#EXTINF:-1 tvg-name="Погода ТВ",Погода ТВ
udp://@239.1.1.31:1234
#EXTINF:-1 tvg-name="O-TV",OTV
udp://@239.1.1.9:1234
#EXTINF:-1 tvg-name="ICTV",ICTV
udp://@239.1.1.11:1234

Вернуться в «MikroTik RouterBOARD»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей