Backup на FTP

Здесь выкладываем скрипты
zvaol
Сообщения: 25
Зарегистрирован: 09 апр 2012, 17:58

Backup на FTP

Сообщение zvaol » 26 июл 2012, 12:36

{
:log info "Starting Backup Script...";
:local sysname [/system identity get name];
:local sysver [/system package get system version];
:log info "Deleting last Backups...";
:foreach i in=[/file find] do={:if ([:typeof [:find [/file get $i name] \
"$sysname-"]]!="nil") do={/file remove $i}};
:delay 5;
:local backupfile ("$sysname-" . \
[:pick [/system clock get date] 7 11] . [:pick [/system \
clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup");
:log info "Creating new Full Backup file...";
/system backup save name=$backupfile;
:delay 5;
:local exportfile ("$sysname-" . \
[:pick [/system clock get date] 7 11] . [:pick [/system \
clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".rsc");
:log info "Creating new Setup Script file...";
/export file=$exportfile;
:delay 5;
/tool fetch user=username password=password upload=yes address=1.2.3.4 src-path=$backupfile mode=ftp dst-path=$backupfile;
:delay 5;
/tool fetch user=username password=password upload=yes address=1.2.3.4 src-path=$exportfile mode=ftp dst-path=$exportfile;
:log info "Backuping completed.";
}

соотв-но, заменить username , password и айпишник.

альтернатива:
можно сделать по типу ssh без пароля и одним скриптом с сервера собирать со всех..
alliaigo
Сообщения: 17
Зарегистрирован: 13 окт 2013, 12:56

Re: Backup на FTP

Сообщение alliaigo » 13 окт 2013, 13:17

Привет! хотел прокомментировать скрипт
на фтп без проблем летают файлы но трабл с микротами по вопросу бэкапа
файл появляется но 0Кб
иногда пролетает и все нормально
в чем может быть проблема
вот лог сервака:

(000012)13.10.2013 14:08:22 - (not logged in) (10.50.0.8)> 220 Привет
(000012)13.10.2013 14:08:22 - (not logged in) (10.50.0.8)> USER mktk8
(000012)13.10.2013 14:08:22 - (not logged in) (10.50.0.8)> 331 Password required for mktk8
(000012)13.10.2013 14:08:22 - (not logged in) (10.50.0.8)> PASS **************
(000012)13.10.2013 14:08:22 - mktk8 (10.50.0.8)> 230 Logged on
(000012)13.10.2013 14:08:22 - mktk8 (10.50.0.8)> TYPE I
(000012)13.10.2013 14:08:22 - mktk8 (10.50.0.8)> 200 Type set to I
(000012)13.10.2013 14:08:22 - mktk8 (10.50.0.8)> PASV
(000012)13.10.2013 14:08:22 - mktk8 (10.50.0.8)> 227 Entering Passive Mode (10,50,0,6,253,229)
(000012)13.10.2013 14:09:25 - mktk8 (10.50.0.8)> PORT 10,50,0,8,170,111
(000012)13.10.2013 14:09:25 - mktk8 (10.50.0.8)> 200 Port command successful
(000012)13.10.2013 14:09:25 - mktk8 (10.50.0.8)> STOR 10-50-0-8-2013oct13.backup
(000012)13.10.2013 14:09:25 - mktk8 (10.50.0.8)> 150 Opening data channel for file transfer.
(000012)13.10.2013 14:11:26 - mktk8 (10.50.0.8)> 426 Connection timed out, aborting transfer
(000012)13.10.2013 14:11:26 - mktk8 (10.50.0.8)> 421 Connection timed out.
(000012)13.10.2013 14:11:26 - mktk8 (10.50.0.8)> disconnected.
podarok66
Модератор
Сообщения: 2861
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Re: Backup на FTP

Сообщение podarok66 » 13 окт 2013, 19:26

alliaigo писал(а):трабл с микротами по вопросу бэкапа
файл появляется но 0Кб
иногда пролетает и все нормально
в чем может быть проблема

В логах у Вас там такого накидано, видимо Вы пытались как-то отследить, но со стороны немного непонятно. Как предположение - система может не успевать отработать бэкап, получая следующую команду от скрипта. Попробуйте после

Код: Выделить всё

/system backup save name=$backupfile;

следующую строку сделать:

Код: Выделить всё

:delay 10;

Скрипт немного побольше будет ожидать выполнения предыдущей команды, глядишь и всё наладится.
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
alliaigo
Сообщения: 17
Зарегистрирован: 13 окт 2013, 12:56

Re: Backup на FTP

Сообщение alliaigo » 08 ноя 2013, 14:24

СПС))

трабл решился путем переноса FTP сервера в административный влан и убрал правила файрвола и тп...заработал... видимо трабл действительно был с задержкой... затем просто поднял фтп на ubuntu...10 дней полет нормальный
likul
Сообщения: 5
Зарегистрирован: 16 окт 2015, 13:35

Re: Backup на FTP

Сообщение likul » 21 окт 2015, 17:03

Как указать определенный каталог ftp? Ведь не будешь же давать root права для backup'в микротика

Вернуться в «Готовые скрипты Mikrotik»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей