Proxy-сервер

Обсуждение оборудования и его настройки
Galeoner
Сообщения: 9
Зарегистрирован: 11 июл 2012, 14:27

Proxy-сервер

Сообщение Galeoner » 11 июл 2012, 17:44

Здравствуйте! Существует ли мануал по настройке прозрачного proxy-сервера на основе самого роутера с логированием на usb? Обыскался - делал - настраивал - не работает Помогите пожалуйста пошагово настроить!
Буду благодрен как морально так и материально!!!

PS хочу реализовать логирование трафика с учетом времени ссессии по сайтам(айпи и/или лучше по доменным именам). С привязкой по мак адресу (в идеальном решеии) или IP.
antkamidiv
Сообщения: 123
Зарегистрирован: 22 мар 2012, 18:28
Контактная информация:

Re: Proxy-сервер

Сообщение antkamidiv » 11 июл 2012, 18:57

Вся прозрачность в одном правиле /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080.
Оно должно стоять до правила маскарадинга (masquerade) на внешнем интерфейсе.
А вот логирование трафика для чего не скажете?
Galeoner
Сообщения: 9
Зарегистрирован: 11 июл 2012, 14:27

Re: Proxy-сервер

Сообщение Galeoner » 11 июл 2012, 20:33

Логирование для руководства. Есть группа объектов с разными провайдерами и разными условиями интернет тарифов. Логирование нужно для определения какой комп когда куда ходил. Чтобы можно было определить какую смену штрафовать за превышение трафика.
antkamidiv
Сообщения: 123
Зарегистрирован: 22 мар 2012, 18:28
Контактная информация:

Re: Proxy-сервер

Сообщение antkamidiv » 11 июл 2012, 22:52

Настраиваем в system -> stores -> disks диск с именем usb1:
1. Не забываем вставить флешку
2. Нажимаем Format Drive

Далее
Если не включен прокси, то /ip proxy set enabled=yes
Если не включен редирект на порт прокси, то /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action redirect to-ports=8080
Настраиваем логи прокси на флешку:
/system logging action add target=disk disk-file-name=usb1/log disk-file-count=5 disk-lines-per-file=1000 name=WebProxyLogging
/system logging add action=WebProxyLogging topics=web-proxy

Вернуться в «MikroTik RouterBOARD»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость