настройка VPN клиентов на разные каналы

Обсуждение оборудования и его настройки
servikoze
Сообщения: 2
Зарегистрирован: 18 июн 2012, 23:00

настройка VPN клиентов на разные каналы

Сообщение servikoze » 18 июн 2012, 23:40

Есть RB: первый(один из интерфейсов) интерфейс должен подключаться к интернту через рррое и получать внешний адрес с настройками, второй интерфейс настраиваем в подсети со своим шлюзом в интернет. Необходимо настроить ВПН сервер и двух клиентов, первый, подключаясь к впн серверу должен ходить в интернет через рррое, второй впн клиент подключаясь дожен ходить в интернет через второй интерфейс. Возможно ли это реализовать, и если да, то, пожалуйста, подскажите как именно.
servikoze
Сообщения: 2
Зарегистрирован: 18 июн 2012, 23:00

Re: настройка VPN клиентов на разные каналы

Сообщение servikoze » 19 июн 2012, 18:21

ХЕЕЕЛП!!! как заставить впн клиентов с разными адресами из разных подсетей натиться по разным внешним интерфейсам???
iSupport
Сообщения: 2439
Зарегистрирован: 06 фев 2011, 20:44

Re: настройка VPN клиентов на разные каналы

Сообщение iSupport » 19 июн 2012, 22:22

Вам надо маркировать пакеты в файерволе

а затем роутить их на основе routing mark


Код: Выделить всё

add chain=output src-address-list=TO_ISP1 dst-address-list=0.0.0.0/0 action=mark-routing new-routing-mark=route_ISP1 passthrough=no comment="Mark_to_ISP1" disabled=no
add chain=output src-address-list=TO_ISP2 dst-address-list=0.0.0.0/0 action=mark-routing new-routing-mark=route_ISP2 passthrough=no comment="Mark_to_ISP2" disabled=no

/ ip firewall nat
add chain=srcnat out-interface=ISP1 action=masquerade comment="NAT_ISP1" disabled=no
add chain=srcnat out-interface=ISP2 action=masquerade comment="NAT_ISP2" disabled=no

/ip route
add dst-address=0.0.0.0/0 gateway=ISP1 distance=1 scope=255 target-scope=10 routing-mark=route_ISP1 comment="Route_to_ISP1" disabled=no
add dst-address=0.0.0.0/0 gateway=ISP2 distance=1 scope=255 target-scope=10 routing-mark=route_ISP2 comment="Route_to_ISP2" disabled=no


как то так.

Идею честно подсмотрел на этой странице http://mikrotik.axiom-pro.ru/scripts/balancerv1.php и немного подтянул под Вашу задачу

соответственно в ip-firewall adress list заводим два адрес листа

TO_ISP1
TO_ISP2

и указываем в каждом айпишники кто куда ходит
Граждане, сколько раз просил =) чем понятнее и точнее сформулирован вопрос - тем понятнее и точнее будет на него ответ.
Я просматриваю ВСЕ темы форума и стараюсь помочь в каждой из них
Поэтому, НА ЛС отвечаю в последнюю очередь

Вернуться в «MikroTik RouterBOARD»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя