PPTP-клиент

Обсуждение ОС и пр.
maximum
Сообщения: 4
Зарегистрирован: 14 фев 2012, 08:47

Re: PPTP-клиент

Сообщение maximum » 20 июн 2012, 20:39

Леткон? :)
Аватара пользователя
DeN_238
Сообщения: 287
Зарегистрирован: 19 фев 2012, 16:42
Откуда: Тольятти

Re: PPTP-клиент

Сообщение DeN_238 » 20 июн 2012, 21:44

maximum писал(а):Леткон? :)

Да :-)
2011UAS-2HnD-IN | v. 6.37.1 | FW 3.33
mAP 2n | v. 6.36.3 | FW 3.24
Аватара пользователя
DeN_238
Сообщения: 287
Зарегистрирован: 19 фев 2012, 16:42
Откуда: Тольятти

Re: PPTP-клиент

Сообщение DeN_238 » 20 июн 2012, 21:49

iSupport писал(а):скорее всего все совместимо. Протоколы то стандартные.

так что дело опять таки в маршрутах

PS. Я в Тольятти не поеду :roll:

Ну, вроде не пальцем деланный 8-) - мануалки, форумы и прочее прочесть и понять вполне по силам. Ибо железяка эта держала у меня "чистый IPшник"+PPTP-клиент+балансировку - полёт нормальный. А тут как-то интересно получается, даже представители провайдера с наскоку разобраться не могут.
ЗЫ В Тольятти не так плохо ;-)
ЗЫЫ mpd на FreeBSD падает с такими-же симптомами
2011UAS-2HnD-IN | v. 6.37.1 | FW 3.33
mAP 2n | v. 6.36.3 | FW 3.24
podarok66
Модератор
Сообщения: 2864
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Re: PPTP-клиент

Сообщение podarok66 » 20 июн 2012, 22:14

Я, вероятно, ща глупость сморожу, но всё-таки - а на хрена Вам DHCP-client? У меня провайдер тоже инет отдает по РРТР, но Mikrotik работает без DHCP-client'а.
Может и правда что-то не то настроили? Говорите, что из настроек Вам показать, чтобы по аналогии свои поправили, я сброшу.
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
Аватара пользователя
DeN_238
Сообщения: 287
Зарегистрирован: 19 фев 2012, 16:42
Откуда: Тольятти

Re: PPTP-клиент

Сообщение DeN_238 » 20 июн 2012, 22:22

podarok66 писал(а):Я, вероятно, ща глупость сморожу, но всё-таки - а на хрена Вам DHCP-client? У меня провайдер тоже инет отдает по РРТР, но Mikrotik работает без DHCP-client'а.
Может и правда что-то не то настроили? Говорите, что из настроек Вам показать, чтобы по аналогии свои поправили, я сброшу.

Да а что там настраивать? Пробовал и руками все ИПшники, шлюзы, роуты прописывать - те-же яйца, вид с боку. Ну и нет у меня, пока, причин сомневаться в компетентности сотрудников провайдера - всяко удобнее видеть перед собой два лога (клиентский и серверный). Дебильный d-link 320 более или менее нормально работает, а вот МТ и mpd на FreeBSD валяться практически с одинаковыми симптомами.
2011UAS-2HnD-IN | v. 6.37.1 | FW 3.33
mAP 2n | v. 6.36.3 | FW 3.24
iSupport
Сообщения: 2439
Зарегистрирован: 06 фев 2011, 20:44

Re: PPTP-клиент

Сообщение iSupport » 21 июн 2012, 08:20

Выключите в файерволе правила mangle - change mss

добавьте в файерволл правило

Код: Выделить всё

/ ip firewall mangle add chain=forward protocol=tcp tcp-flags=syn tcp-mss=1453-65535 action=change-mss new-mss=1360  disabled=no

Граждане, сколько раз просил =) чем понятнее и точнее сформулирован вопрос - тем понятнее и точнее будет на него ответ.
Я просматриваю ВСЕ темы форума и стараюсь помочь в каждой из них
Поэтому, НА ЛС отвечаю в последнюю очередь
Аватара пользователя
DeN_238
Сообщения: 287
Зарегистрирован: 19 фев 2012, 16:42
Откуда: Тольятти

Re: PPTP-клиент

Сообщение DeN_238 » 21 июн 2012, 08:52

iSupport писал(а):Выключите в файерволе правила mangle - change mss

добавьте в файерволл правило

Код: Выделить всё

/ ip firewall mangle add chain=forward protocol=tcp tcp-flags=syn tcp-mss=1453-65535 action=change-mss new-mss=1360  disabled=no


Попробуем, спасибо за подсказку
2011UAS-2HnD-IN | v. 6.37.1 | FW 3.33
mAP 2n | v. 6.36.3 | FW 3.24
Аватара пользователя
DeN_238
Сообщения: 287
Зарегистрирован: 19 фев 2012, 16:42
Откуда: Тольятти

Re: PPTP-клиент

Сообщение DeN_238 » 23 июн 2012, 16:02

iSupport писал(а):Выключите в файерволе правила mangle - change mss

добавьте в файерволл правило

Код: Выделить всё

/ ip firewall mangle add chain=forward protocol=tcp tcp-flags=syn tcp-mss=1453-65535 action=change-mss new-mss=1360  disabled=no



Не помогло
К сожалению всё больше склоняюсь к "особенностям" провайдера :-(
На днях попытался подключиться через ZyXEL P-330W EE - те-же яйца, только в профиль.
Итого имеем: шлюз на FreeBSD (mpd), MikroTik 751G-2HnD, ZyXEL P-330W EE - не работают. И лишь, простой как 3 копейки, D-Link DIR-320 с горем пополам (бОльшая часть сайтов не открывается, скорость вообще неприятно удивляет) пыхтит.
2011UAS-2HnD-IN | v. 6.37.1 | FW 3.33
mAP 2n | v. 6.36.3 | FW 3.24
podarok66
Модератор
Сообщения: 2864
Зарегистрирован: 11 фев 2012, 18:49
Откуда: МО

Re: PPTP-клиент

Сообщение podarok66 » 24 июн 2012, 21:59

Так, давайте еще раз попробуем. У меня 433UAH, поэтому настройки описывал для него, но по аналогии на своём разберетесь:
У меня провайдер подключает меня по PPTP. Допустим настройки , выданные провайдером таковы:
IP-adress 172.18.4.142
Маска 255.255.0.0
Шлюз 172.18.1.1

DNS 194.190.24.5
Alt DNS 8.8.8.8

Login login22
Password MyPass

Предположительно, первый по счету порт я буду настраивать в интернет, а второй и третий и беспроводку, как локальные.
Настроим порт в интернет ether1:

Код: Выделить всё

/ip address add interface="ether1" address="172.18.4.142/16"
/ip route add dst-address="172.18.0.0/16" gateway="172.18.1.1"
/ip dns set servers=194.190.5.24,8.8.8.8 allow-remote-requests=yes


Теперь создаем второй интерфейс — PPTP-соединение:

Код: Выделить всё

/interface pptp-client add name="MyPPTP" connect-to="172.18.1.1" user="login22" password="MyPass" add-default-route="yes"
/interface enable "MyPPTP"

И, наконец, настраиваем NAT на обоих интерфейсах:

Код: Выделить всё

/ip firewall nat add out-interface="ether1" chain="srcnat" action="masquerade"
/ip firewall nat add out-interface="MyPPTP" chain="srcnat" action="masquerade"


Включим беспроводную карту wlan1:

Код: Выделить всё

/interface enable "wlan1"


А вот дальше у меня было что-то вроде танца с бубном. Я создал мост и закинул туда внутренние интерфейсы:

Код: Выделить всё

/interface bridge add name="bridge1"

/interface bridge port add interface="ether2" bridge="bridge1"

/interface bridge port add interface="ether3" bridge="bridge1"

/interface bridge port add interface="wlan1" bridge="bridge1"


И дальше по логике вещей, мне бы надо присваивать ему адрес
/ip address add interface="bridge1" address="192.168.100.1/24"
, да только у меня в дальнейшем при таком раскладе не было соединения с интернетом, хоть тресни. Поэтому пришлось шаманить. Настраиваем внутренний интерфейс ether2:

Код: Выделить всё

/ip address add interface="ether2" address="192.168.100.1/24"



Задаем пул IP-адресов:

Код: Выделить всё

/ip pool add name="Pool" ranges="192.168.100.2-192.168.100.254"


Затем создаем экземпляр DHCP-сервера, замечу, для моста:


Код: Выделить всё

/ip dhcp-server add name="DHCP" interface="bridge1" address-pool="Pool" disabled="no"


Определяем адреса шлюза по умолчанию и сервера DNS, которые будут использоваться в нашей сети:

Код: Выделить всё

/ip dhcp-server network add address="192.168.100.0/24" gateway="192.168.100.1" dns-server="192.168.100.1" domain="home"


После этого я перезагружал роутер:

Код: Выделить всё

/system reboot


и уж потом прямо в winbox менял в >>IP>>Addresses>> в строке, где прописан интерфейс ether2 заменял на bridge1.
Мануалы изучил и нигде не ошибся? Фаервол отключил? Очереди погасил? Витая пара проверена? ... Тогда Netinstal'ом железку прошей и настрой ее заново. Что, все равно не фурычит? Тогда к нам. Если не подскажем, хоть посочувствуем...
Аватара пользователя
DeN_238
Сообщения: 287
Зарегистрирован: 19 фев 2012, 16:42
Откуда: Тольятти

Re: PPTP-клиент

Сообщение DeN_238 » 26 июн 2012, 09:57

podarok66 спасибо. Но ваша настройка базовая, с ней проблем не возникло.
Сейчас роутер у провайдера, говорят есть некоторые подвижки, если всё удачно завершиться выложу настройки.
2011UAS-2HnD-IN | v. 6.37.1 | FW 3.33
mAP 2n | v. 6.36.3 | FW 3.24

Вернуться в «MikroTik RouterOS»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость