site-to-site l2tp passthrough

Обсуждение ОС и пр.
St0nE
Сообщения: 11
Зарегистрирован: 06 май 2012, 07:30

site-to-site l2tp passthrough

Сообщение St0nE » 31 май 2012, 13:41

Всем здравствуйте!
Подскажите плиз, не получается такая комбинация.
Есть два филиала, на обоих стоят микротики 751G.
За микротиками стоят ТМГ.. Не спрашивайте про зачем такая реализация, на данном этапе нужно именно так.. :-)
Задача, связать эти филиалы site-to-site l2tp vpn каналом, но чтобы vpn устанавливал именно тмг.
Если без микротиков, все работает отлично, как ставлю микротики, vpn не поднимается... типа нет ответа от сервера.
Пробовал делать dst-nat tcp и udp траффиков, не помогло.
Подскажите плиз, что в правиле надо указать, чтобы vpn пробрасывался на тмг?
btw: В одном из филиалов настроено два прова с балансировкой, но весь трафик на второй филиал принудительно заруливается через нужный интерфейс посредством маркировки пакетов. Поэтому здесь не должно быть косяков.
Спасибо... :-)
iSupport
Сообщения: 2439
Зарегистрирован: 06 фев 2011, 20:44

Re: site-to-site l2tp passthrough

Сообщение iSupport » 31 май 2012, 22:17

Тут только DST NAT ковырять, скорее всего не хватает каких то правил

смотрите torch с wan интерфейсов микротиков. Там будут видны управляющие соединения и протокол GRE для передачи данных
Граждане, сколько раз просил =) чем понятнее и точнее сформулирован вопрос - тем понятнее и точнее будет на него ответ.
Я просматриваю ВСЕ темы форума и стараюсь помочь в каждой из них
Поэтому, НА ЛС отвечаю в последнюю очередь
St0nE
Сообщения: 11
Зарегистрирован: 06 май 2012, 07:30

Re: site-to-site l2tp passthrough

Сообщение St0nE » 01 июн 2012, 14:36

хммм... спасибо.. буду дальше ковырять...
St0nE
Сообщения: 11
Зарегистрирован: 06 май 2012, 07:30

Re: site-to-site l2tp passthrough

Сообщение St0nE » 18 окт 2012, 12:11

Вернусь опять к вопросу. В прошлый раз так и не получилось найти в чем мой косяк...
Сейчас опять возникла необходимость в данной конфигурации.
По прежнему никак не получается пропустить l2tp сквозняком через микротики.
Подскажите плиз, что из конфигурации запостить здесь, чтобы проще было разобраться?
Спасибо.
St0nE
Сообщения: 11
Зарегистрирован: 06 май 2012, 07:30

Re: site-to-site l2tp passthrough

Сообщение St0nE » 18 окт 2012, 13:45

Сейчас еще раз повнимательнее поигрался с торчем, выяснилось, что пакеты вроде как даже не уходят.
Т.е. на локальном интерфейсе они есть, а на выходе их нету. :-)
Получается, что одного правила, которое маскарадит пакеты приходящие с сервера наружу не достаточно.
Их получается вообще НАТ-ить нельзя что-ли? А что тогда с ними делать?
Спасибо.

Код: Выделить всё

/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" disabled=\
    no src-address=10.10.10.20 to-addresses=0.0.0.0
add action=dst-nat chain=dstnat disabled=no in-interface=pppoe-netis \
    protocol=gre to-addresses=10.10.10.20
add action=dst-nat chain=dstnat disabled=no in-interface=pppoe-netis \
    protocol=tcp to-addresses=10.10.10.20
add action=dst-nat chain=dstnat disabled=no in-interface=pppoe-netis \
    protocol=udp to-addresses=10.10.10.20


Вернуться в «MikroTik RouterOS»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей